Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-10-2015, 11:27   #1
Registered User

Join Date: Oct 2013
Location: Salish Sea
Boat: Tayana 37
Posts: 172
No spark from our Force 10 stove

The burners on our three-burner Force 10 stove stopped sparking yesterday.

Changed the battery. Still nothing.

We don't have a manual, but I found one online which appears to be the closest for the stove we have.

It seems to suggest that if changing the battery doesn't work I might need a new "spark ignition box".

Anyone know what else I should try before ordering an ignition box?
__________________

__________________
foojin is offline   Reply With Quote
Old 21-10-2015, 11:52   #2
Moderator
 
a64pilot's Avatar

Cruisers Forum Supporter

Join Date: Oct 2013
Location: Albany Ga.
Boat: Island Packet 38
Posts: 17,056
Re: No spark from our Force 10 stove

Where are you located? I ask if it's in the US, many newer barbecue grills use the same ignition box, might could get one right away and save money by going by a Lowes or Home Depot.
__________________

__________________
a64pilot is offline   Reply With Quote
Old 21-10-2015, 11:54   #3
Senior Cruiser
 
Sailmonkey's Avatar

Cruisers Forum Supporter

Join Date: Sep 2009
Location: Houston
Boat: '76 Allied Seawind II, 32'
Posts: 5,780
Re: No spark from our Force 10 stove

Check the push button before paying for an ignition box.......just put some clip leads across the back to make sure it is or isn't working.
__________________
Sailmonkey is offline   Reply With Quote
Old 21-10-2015, 12:06   #4
Senior Cruiser
 
Vasco's Avatar

Cruisers Forum Supporter

Join Date: Apr 2004
Location: Toronto
Boat: CS36Merlin, "La Belle Aurore" Ben393 "Breathless"
Posts: 7,138
Re: No spark from our Force 10 stove

I'd also check the wiring. It's real small wires and rust easily.
__________________
Rick I
Toronto in summer, Bahamas in winter.
http://groups.yahoo.com/group/beneteau393/
Vasco is offline   Reply With Quote
Old 21-10-2015, 12:09   #5
cat herder, extreme blacksheep
 
zeehag's Avatar

Cruisers Forum Supporter

Join Date: Jul 2008
Location: furycame alley , tropics, mexico for now
Boat: 1976 FORMOSA yankee clipper 41
Posts: 17,772
Images: 56
Send a message via Yahoo to zeehag Send a message via Skype™ to zeehag
Re: No spark from our Force 10 stove

could be a bad battery try again. i use a long bbq lighter to light mine, as all that nonsense died long ago.
zeehag is offline   Reply With Quote
Old 21-10-2015, 13:54   #6
Registered User

Join Date: Oct 2013
Location: Salish Sea
Boat: Tayana 37
Posts: 172
Re: No spark from our Force 10 stove

Quote:
Originally Posted by a64pilot View Post
Where are you located? I ask if it's in the US, many newer barbecue grills use the same ignition box, might could get one right away and save money by going by a Lowes or Home Depot.
Over the border in Canada, but Home Depot and others are here. Will have a look around.

Will check the wiring more closely. And did try a couple batteries :-) Thanks
__________________
foojin is offline   Reply With Quote
Old 22-10-2015, 09:09   #7
Registered User

Join Date: Aug 2009
Location: Switzerland
Boat: Outbound 46 -Callisto
Posts: 149
Re: No spark from our Force 10 stove

We found a "sparker" in a hardware store, it is a piezoelectric spark source that never runs out of butane or flint, and it has been perfectly reliable for some years now. Looks like a long butane lighter, but just makes a spark on request.
__________________
DMCantor is offline   Reply With Quote
Old 22-10-2015, 09:19   #8
Moderator
 
a64pilot's Avatar

Cruisers Forum Supporter

Join Date: Oct 2013
Location: Albany Ga.
Boat: Island Packet 38
Posts: 17,056
Re: No spark from our Force 10 stove

Quote:
Originally Posted by DMCantor View Post
We found a "sparker" in a hardware store, it is a piezoelectric spark source that never runs out of butane or flint, and it has been perfectly reliable for some years now. Looks like a long butane lighter, but just makes a spark on request.
I was an oil field contract welder in the very early 80's and bought one of those things to light my torch, one day I was at the top of the derrick in a light rain and found out even slightly wet they won't work, had to climb all the way down and go back up, just remembering is all, they are fine in the Galley I'm sure
__________________
a64pilot is offline   Reply With Quote
Old 22-10-2015, 09:23   #9
Registered User

Join Date: Sep 2014
Location: Canada
Boat: Hans Christian 33
Posts: 3
Re: No spark from our Force 10 stove

I have been using a spark lighter - the kind you would light a welding torch with - for about 15 years now with my Force 10 stove. Works every time, no batteries or gas, readily available and originally cost about 5 bucks.
__________________
svchinamoon is offline   Reply With Quote
Old 22-10-2015, 09:23   #10
Registered User

Join Date: Oct 2013
Location: Salish Sea
Boat: Tayana 37
Posts: 172
Re: No spark from our Force 10 stove

Quote:
Originally Posted by DMCantor View Post
We found a "sparker" in a hardware store....
Sounds interesting. Make a great backup even if we get our internal sparker working again, and much better than cheap butane lighters which usually leak till empty.

Do you have a brand name?
__________________
foojin is offline   Reply With Quote
Old 22-10-2015, 09:26   #11
Registered User

Join Date: Oct 2008
Location: San Diego/Tempe
Boat: KP44 #279
Posts: 117
Re: No spark from our Force 10 stove

Trace all wiring, in particular the grounds. The grounds are terminated with rivets and their connections become weak after a period of time. The most likely culprit is the ground under the main top. It's kind of a pain to get to but not too difficult. You must remover all burner caps and screws in the top. The connection is located centrally and forward just behind the control panel. Once found clean and consider a better way to connect it. You can try your ignitors while a part to verify the issue.
__________________
dlentz is offline   Reply With Quote
Old 22-10-2015, 09:38   #12
Registered User

Join Date: Jan 2013
Location: San Carlos, Sea of Cotez
Boat: Le Guen Hemidy, Croix-du-Sud, 56'
Posts: 61
Re: No spark from our Force 10 stove

It happend to us. Solution is very simple. Use aluminium folio to have better negative contact in the battery box.
__________________
CdS2 Roland is offline   Reply With Quote
Old 22-10-2015, 09:39   #13
Registered User

Join Date: Jan 2015
Location: Victoria BC
Boat: 1980 Hunter 36
Posts: 678
Re: No spark from our Force 10 stove

Quote:
Originally Posted by zeehag View Post
could be a bad battery try again. i use a long bbq lighter to light mine, as all that nonsense died long ago.
Yeah, mine never worked and once I took out the oven and looked at the over complicated mess of wires I decided just to stick with my BBQ lighter.
__________________
S/V Gudgeon
www.gudgeonblog.ca
alctel is online now   Reply With Quote
Old 22-10-2015, 10:02   #14
Registered User

Join Date: Dec 2012
Boat: Jeanneau SO45.2
Posts: 118
Re: No spark from our Force 10 stove

The AA battery holder in ours sort of "stretched" from the pressure of the spring pushing outwards from the bottom of the batteryr, don't recall exactly if I fixed or replaced the holder, but that took care of it.
__________________
Redline452 is offline   Reply With Quote
Old 22-10-2015, 11:20   #15
Registered User
 
hamburking's Avatar

Join Date: Feb 2013
Location: Kingston Ont Canada
Boat: Looking for my next boat!
Posts: 2,149
Re: No spark from our Force 10 stove

Quote:
Originally Posted by zeehag View Post
could be a bad battery try again. i use a long bbq lighter to light mine, as all that nonsense died long ago.
I also am in the long bbq lighter club. A $1 solution which suits me just fine. My lighter ran out of fluid years ago, but still sparks just fine.
__________________

__________________
hamburking is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Honda BF8A lack of spark Gulf Islander Engines and Propulsion Systems 0 25-05-2014 17:22
Mariner 1993 9.9 2 stroke NO SPARK Wander Engines and Propulsion Systems 0 17-05-2014 17:56
Outboard wont spark, narrowed it down but need advice! OrangeCrush Engines and Propulsion Systems 6 28-12-2013 20:28
Suzuki DT2 No Spark tel105 Engines and Propulsion Systems 6 14-03-2011 19:32
Bright Spark electric anti-fouling system multihullsailor6 Electrical: Batteries, Generators & Solar 23 04-06-2008 11:11



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 00:14.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.