Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 17-05-2016, 11:42   #1
Registered User

Join Date: Aug 2015
Location: Cape Coral, FL
Boat: Island Packet 380
Posts: 6
Boat Speed & Wind Instruments

Can someone tell me how to troubleshoot my Boat Speed & Wind Instrument (Raytheon ST 60 - over 15 years old)?
I have removed and cleaned the impeller and have spun it but no reading at the meter.
Wind direction functions but speed starts at 99 Kts and counts down to actual speed then the count down cycle repeats for about 10-15 minutes until the display becomes OK.


Thanks for any advice you can offer!
__________________
Cocaptains is offline   Reply With Quote
Reply

Tags
men, rum, wind

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
B&G Hydra 2000 wind direction but no wind speed Airjordi Marine Electronics 3 15-07-2015 03:43
wireless wind and speed instruments - is it OK jmoreau Marine Electronics 3 30-06-2014 18:54
For Sale: Datamarine Depth & Wind Instruments, Transducers Beersmith Classifieds Archive 4 28-02-2014 09:35
Speed & Depth instruments leaking water Kefalonia Marine Electronics 0 22-07-2013 15:53
New Wind Instruments & electronics in general ErikFinn Marine Electronics 9 07-03-2013 04:38



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:20.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.