Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-04-2007, 20:13   #1
Provocateur & Raconteur
 
knottybuoyz's Avatar

Cruisers Forum Supporter

Join Date: Nov 2005
Location: Iroquois, Ontario
Boat: Bateau.com TW31 Modified
Posts: 3,583
Images: 87
Caption this photo

Ooops! Somebody forget to put the plug in?
__________________

__________________
Yours Aye! Rick
~^~^~^^~^~^~^~^~^~^~^~~^~^~~^~^~^^~~^~^
"It's not the boat "you built" until you've sworn at it, bled on it, sweated over it, cried beside it and then threatened to haul the POS outside and burn it!"
knottybuoyz is offline   Reply With Quote
Old 06-04-2007, 20:23   #2
Registered User

Join Date: Jun 2005
Posts: 1,901
That's a wate of a nice long nose Cessna
__________________

__________________
never monday is offline   Reply With Quote
Old 06-04-2007, 22:07   #3
Registered User
 
sluissa's Avatar

Join Date: Mar 2006
Location: Pensacola, FL, US
Boat: Westfield UK Kingfisher 20+ - Rabbit
Posts: 402
Images: 4
Send a message via AIM to sluissa
The pilot thought he had found a nice flat stretch of clear land to set down on, at least until a few hours later when the tide came in.
__________________
sluissa is offline   Reply With Quote
Old 06-04-2007, 22:29   #4
Registered User
 
BilgeRat's Avatar

Join Date: Dec 2006
Location: W. Seattle
Boat: Trawler
Posts: 66
Darn, I forgot the floats!

__________________
BilgeRat is offline   Reply With Quote
Old 06-04-2007, 23:37   #5
Registered User
 
Thermal's Avatar

Join Date: Jul 2005
Location: Honolulu
Boat: S2 11.0C 36' Puka Wai
Posts: 157
Images: 1
S*#%, the bilge pump quit working again!
__________________
In theory, Practice and Theory are the same. In practice, they are not.
Thermal is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
photo gallery Steve Rust Forum Tech Support & Site Help 7 19-02-2007 01:59
Caption this photo knottybuoyz Health, Safety & Related Gear 23 05-12-2006 05:52
Announcement: Photo Gallery Open Again! Andy R Forum News & Announcements 15 24-10-2006 09:24
Photo Gallery not working after the upgrade CaptainK Forum Tech Support & Site Help 10 23-04-2006 20:01
Increase the clarity of some photo? Default Forum Tech Support & Site Help 1 19-03-2006 08:34



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 17:31.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.