Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-04-2016, 17:01   #1
Registered User

Join Date: May 2009
Location: Grenada
Boat: Shorebro,Royal 33 - Aloisius
Posts: 927
Volvo Penta tach not working

I have a Volvo Penta MD2040D, two alternators, both identical and standard Volvo. My tach continually shuts down. I have been told that when the batteries are fully charged, the Volvo has a flaw that the tach will then shut down. My batteries are up to 14.2. Besides the tach not working, the engine he counter also does not work properly. It is digital and generally flashing all sorts of numbers. The tach has always not worked well even when the batteries are not fully charged.

A few years ago I purchased a new Volvo tach, no change to problem. Any ideas?


Sent from my iPad using Cruisers Sailing Forum
__________________
landonshaw is offline   Reply With Quote
Old 02-04-2016, 18:37   #2
Senior Cruiser

Cruisers Forum Supporter

Join Date: Jul 2005
Boat: Outbound 44
Posts: 4,580
Re: Volvo Penta tach not working

When the regulator shuts the alternator down because the batts are full you can loose the tach signal. With no solar, try putting a load on the system like turning on an incandescent light. This may enable the alt and thus the tach.
The issues with the hour counter sound like you have a bad connection. Maybe a corroded ground?
__________________
Paul L
http://svjeorgia.blogspot.com
Paul L is offline   Reply With Quote
Old 02-04-2016, 20:41   #3
Registered User

Join Date: Dec 2010
Location: W Carib
Boat: Wildcat 35, Hobie 33
Posts: 7,940
Re: Volvo Penta tach not working

Agree. Maybe a combination of regulator and a ground/wiring issue. Dropping the tach signal is not a Volvo specific flaw, many regulators do this.

No change with new tach, so almost certainly eliminates the tach as the issue. The hour meter issue you describe is a common mode of failure of the display, but given that the display is built into the tach (yours is right?) then that points to a different source for this problem too.

Induce a signficant load as suggested, if either or both issues go away then its likely caused by the regulator.
__________________
belizesailor is online now   Reply With Quote
Reply

Tags
penta, volvo

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
440: Volvo tach code HimHerBoySissy Lagoon Catamarans 0 06-01-2015 15:58
Tach does not Always Register BozSail Electrical: Batteries, Generators & Solar 8 08-08-2013 19:11
Yanmar Starting Issues and Tach Not Working Buttercup Engines and Propulsion Systems 0 05-07-2012 20:07
New Balmar ars-5: Not Working, No Tach granche1 Electrical: Batteries, Generators & Solar 6 28-04-2011 17:45
Tach slow/alternator not producing starfish62 Engines and Propulsion Systems 15 28-05-2007 16:04



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:44.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.