Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 13-07-2009, 19:56   #1
Registered User

Join Date: Jul 2009
Posts: 2
Cruisair Marine A/C Issues

I am new to this forum, I have a question to any tech Dometic Cruise Air specialist. I am havining trouble gettin my airconditioner to blow cold. It seem that the thermostat shows the cabin temp to be 55 degrees, this is clearly not the case. I have done a factory reset and the smxi is not reading cabin tempaccuratly. I have manually reset the temp to 73 degrees and a few days later it seems that the tempon the smxi display is frifting. I have removed the tempsensor and held it between my fingers and wathed the temp rise to approx 75 degrees, however it will never reach my body temp. My question is. is there a way totest the logic board to see if this is the issue? A foward thank you for a response.
srdancer320 is offline   Reply With Quote
Old 13-07-2009, 20:03   #2
Moderator Emeritus
Pblais's Avatar

Join Date: Mar 2003
Location: Hayes, VA
Boat: Gozzard 36
Posts: 8,700
Images: 15
Send a message via Skype™ to Pblais
My question is. is there a way to test the logic board to see if this is the issue?
Only if that is the problem. It could never reach your body temp mostly because the tip of the finger won't get there. Cruise Air or any other system mostly works the same. They measure the intake temp and calibrate to the desired set point. There are a lot of reasons why it might not meet the expected temperature you desire.
Paul Blais
s/v Bright Eyes Gozzard 36
37 15.7 N 76 28.9 W
Pblais is offline   Reply With Quote
Old 14-07-2009, 00:11   #3
Do… or do not
s/v Jedi's Avatar

Cruisers Forum Supporter

Join Date: Feb 2009
Location: in paradise
Boat: Sundeer 64
Posts: 8,865
Read your installation manual on the subject of where to place the temp sensor. Keep it away from the A/C unit but in the air-flow going back to the A/C.

s/v Jedi is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruisair Only Blowing Heat Captain Jay Plumbing Systems and Fixtures 9 12-04-2011 06:49
Cruisair Stowaway 7K BTU markpj23 Classifieds Archive 2 27-05-2009 05:27
Cruisair water flow problem mrfordsr Plumbing Systems and Fixtures 16 30-03-2009 17:48
Cruisair Question stuffinbox Plumbing Systems and Fixtures 7 16-11-2007 12:26
Cruisair PMA1000 SW Circ Pump markpj23 Plumbing Systems and Fixtures 0 16-07-2006 18:09

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:12.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.