Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 01-08-2013, 06:46   #1
Registered User

Join Date: Mar 2012
Posts: 127
Yanmar Gear Shift Problem


I recently reinstalled My 2qm15 Yanmar engine during my boat restoration project. This model has the KBW10 gearbox and I'm having real problems shifting into Neutral after selecting Forward or Reverse. This problem is definitely with the shift lever which is located on the side of the gearbox and is operated by a Morse 33c cable.

The gearbox clicks into gear ok but is very, very stiff when trying to select neutral. When the shift lever is disconnected from the cable, the gears can be easily selected by hand but it's very tight trying to get back into Neutral. When the cable is connected to the shift lever it is even worse. it's really so stiff I am worried about breaking the handle on the Morse control lever.

My throttle/gear control is the Teleflex MV-2 Morse type which I fully serviced and rejuvenated before re-installing. I also replaced the original morse cables with brand new ones and there are no tight bends so I know the cables are not contributing to the problem.

Before I installed the engine I serviced the geabox by flushing it with kerosene and oil and have since filled it with the correct new oil as specified by Yanmar.

Does anyone know what I can do to solve this problem, please?

bony is offline   Reply With Quote

yanmar, gear

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yanmar Non-Compliance with Bulletin. armido Product or Service Reviews & Evaluations 25 09-10-2012 16:28
Yanmar 2GM20F Exhaust Mixer/Elbow kiltym Engines and Propulsion Systems 22 08-08-2012 17:34
Capsize Ratio's topfish Monohull Sailboats 266 06-07-2012 18:44
Battery-Charging Regulator Problem ? MasterVolt Problem ? RJV Electrical: Batteries, Generators & Solar 18 06-11-2011 22:53
Problem Since 2.2.918 - Garmin Won't Work MarkJ OpenCPN 28 29-06-2011 17:40

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 13:18.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.