Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-04-2014, 01:43   #1
Registered User

Join Date: Jul 2012
Location: france/dordogne
Boat: Fountaine Pajot Lavezz 40ft
Posts: 197
Yanmar engine electronic RPM

I hope i can find the correct words to explain what I am looking for,
the yanmar engines or dashboard has an electronic gauge for the
engine refs,RPM, one is not indicating anything anymore but when I put
the contact on I can see it move,,, slightly in the wrong direction?
the other, we are talking about a Lavezzi 40, when off indicates
2000 RPM !! and when I put the contact on goes to ZERO,
and when the engine runs indicates the correct refs ????
HOW TO REPAIR BOTH PROBLEMS ??
__________________

__________________
laforge24 is offline   Reply With Quote
Old 06-04-2014, 22:38   #2
Moderator
 
sailorchic34's Avatar

Cruisers Forum Supporter

Join Date: Feb 2011
Location: SF Bay Area
Boat: Islander 34
Posts: 4,812
Re: Yanmar engine electronic RPM

For the first you might try cleaning the contacts /spade connectors that plug into the tach sensor located on the flywheel housing. The second problem, I do not know what would cause the gauge to read 2000 rpm with power off.

Perhaps check the the diodes on the alternator are good as it sounds sort of like a voltage leak to the tach gauge, which should not happen with key/switch off.
__________________

__________________
sailorchic34 is offline   Reply With Quote
Old 06-04-2014, 23:01   #3
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,019
Re: Yanmar engine electronic RPM

The second problem is quite common and does not require repair. Consider it normal behavior. One thing you can try is cleaning the clear plastic of the gauge with a drier fabric softener sheet or a paper towel dampened with some Downey fabric softener.
__________________
transmitterdan is offline   Reply With Quote
Old 06-04-2014, 23:43   #4
Registered User

Join Date: Jul 2012
Location: france/dordogne
Boat: Fountaine Pajot Lavezz 40ft
Posts: 197
Re: Yanmar engine electronic RPM

Quote:
Originally Posted by transmitterdan View Post
The second problem is quite common and does not require repair. Consider it normal behavior. One thing you can try is cleaning the clear plastic of the gauge with a drier fabric softener sheet or a paper towel dampened with some Downey fabric softener.
You thnk it is static electricity ?
__________________
laforge24 is offline   Reply With Quote
Old 09-04-2014, 01:44   #5
Registered User

Join Date: Jun 2013
Posts: 4
Re: Yanmar engine electronic RPM

Apart from the poor contact . You RPM meter may be out of sync with the signal sent from the engine .You didn't tell wheter the signal is from the gear box or from the alternator or the model tpye. It is difficlut to judge . Yanmar has a techncial bullet to tell how you adj the meter to show correct rpm w.r.t. the engine model .
__________________
Hebe is offline   Reply With Quote
Old 09-04-2014, 04:53   #6
Registered User

Join Date: Jul 2012
Location: france/dordogne
Boat: Fountaine Pajot Lavezz 40ft
Posts: 197
Re: Yanmar engine electronic RPM

Quote:
Originally Posted by Hebe View Post
Apart from the poor contact . You RPM meter may be out of sync with the signal sent from the engine .You didn't tell wheter the signal is from the gear box or from the alternator or the model tpye. It is difficlut to judge . Yanmar has a techncial bullet to tell how you adj the meter to show correct rpm w.r.t. the engine model .
Thanks Hebe
that is interesting to know, I was hoping for simple troubleshooting, and
yes I should have mentioned the engine type 3YM30,
If you could tell me where the sensor is situated and where to find that technical bulletin I could take it from there and keep you posted on the outcome,
thanks.
__________________
laforge24 is offline   Reply With Quote
Old 14-04-2014, 01:27   #7
Registered User

Join Date: Jun 2013
Posts: 4
Re: Yanmar engine electronic RPM

This is the link you can view the service manual,in page 184&195,there are the circuit for the panel. It shows the signal is from the P join of the alternator for the type B panel.
For old type panel, the signal is from a sensor outside the flywheel in the engine block.
So check which type of wiring used on your engine, then follow the wire to local any bad contact or too much moisture.
If the malfunction persist ,there may be the malfunction of the panel, or the sensor give incorrect signal.
Isolate the problem to find out where is the source.
good luck

3ym30: Yanmar Inboard Engine 29hp/22.1kw Service Manual
__________________

__________________
Hebe is offline   Reply With Quote
Reply

Tags
engine, rpm, yanmar

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine wear at different RPM's Dockhead Engines and Propulsion Systems 20 05-03-2011 09:50
Loss of Speed / RPM from New Engine s/y spindrift Engines and Propulsion Systems 20 28-05-2010 21:45
Replacement RPM & Engine Gauge Module for My Sagitta 30 captainteacup Auxiliary Equipment & Dinghy 3 23-03-2010 12:24
RPM's Yanmar 3GM engine bobelon Engines and Propulsion Systems 10 31-03-2009 11:42
Drop in RPM'S IN diesel engine candycat Engines and Propulsion Systems 20 07-04-2008 01:40



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 19:10.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.