Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-08-2010, 15:43   #31
Registered User

Join Date: Jul 2008
Location: Vancouver Island
Boat: 27ft catalina
Posts: 492
well still no luck in determining the cause of this issue. engine will not get past 3000 rpm now and surges down to 25-2600 when surging i find that if i crack open the bleed screw on the injector pump it revs back up to around 3000 but will slowly creep back up and down. almost as if air is getting into the system. im curious if it could be a defective diaphragm in the lift pump i priced out a new one here $219 pretty steep. i was thinking of replacing with a walbro electric pump any thoughts or recommendations. this one looks reasonable.
Walbro - Marine Electric 4PSI Fuel Pumps 12 & 24V
__________________

__________________
michaelmrc is offline   Reply With Quote
Old 10-08-2010, 15:56   #32
Senior Cruiser

Cruisers Forum Supporter

Join Date: Mar 2006
Posts: 1,594
Do you have a single lever control?

If so, could be the control cables..
__________________

__________________
Randy

Cape Dory 25D Seraph
rtbates is offline   Reply With Quote
Old 10-08-2010, 15:59   #33
Registered User

Join Date: Jul 2008
Location: Vancouver Island
Boat: 27ft catalina
Posts: 492
no i have twin lever thottle and shifter
__________________
michaelmrc is offline   Reply With Quote
Old 10-08-2010, 16:30   #34
Eternal Member
 
Chief Engineer's Avatar

Join Date: Aug 2006
Location: North of Baltimore
Boat: Ericson 27 & 18' Herrmann Catboat
Posts: 3,798
$219.00 for a Yanmar Lift Pump??????

They cost less than a Hundred down here.
__________________
Chief Engineer is offline   Reply With Quote
Old 10-08-2010, 16:35   #35
Registered User

Join Date: Jul 2008
Location: Vancouver Island
Boat: 27ft catalina
Posts: 492
must be nice $219 canadian funds i thought was outrageous. an electric walbro is $100 less and probably better.
__________________

__________________
michaelmrc is offline   Reply With Quote
Reply

Tags
1gm10, yanmar

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yanmar 1gm10 - Blue Smoke - Help! Solitude Engines and Propulsion Systems 35 25-06-2011 01:39
Yanmar 1GM10 Fuel Leak nednaic Engines and Propulsion Systems 17 22-12-2010 16:37
Yanmar 1GM10 - Smoke, No Power billmcc Engines and Propulsion Systems 62 08-11-2009 06:09
Yanmar 1gm10 Oil Change? heron237 Engines and Propulsion Systems 1 08-06-2009 21:41
DC Generator - Yanmar 1GM10 iain_scott Electrical: Batteries, Generators & Solar 22 07-06-2009 11:42



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 12:43.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.