Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 31-12-2015, 20:46   #46
Registered User

Join Date: Nov 2009
Posts: 101
Re: Westerbeke 8 generator will not start

Ps just logged in so I've not read any comments since I was last on and going to look now .
__________________

__________________
woodyapex is offline   Reply With Quote
Old 31-12-2015, 20:48   #47
Registered User

Join Date: Nov 2009
Posts: 101
Re: Westerbeke 8 generator will not start

I replaced the sensor and if it had have started I think it might have a slight delay any how for that reason .
__________________

__________________
woodyapex is offline   Reply With Quote
Old 31-12-2015, 21:28   #48
Registered User

Join Date: Nov 2009
Posts: 101
Re: Westerbeke 8 generator will not start

Quote:
Originally Posted by Scott Berg View Post
Old trick: try to run it on WD40
Spray in the intake and hit preheat and start
If it starts and runs its glow plugs
Runs till you stop the spray it's the fuel solenoid



Sent from my iPhone using Cruisers Sailing Forum
Great minds think alike but what if it does not even fire . ??
__________________
woodyapex is offline   Reply With Quote
Old 31-12-2015, 21:36   #49
Registered User

Join Date: Nov 2009
Posts: 101
Re: Westerbeke 8 generator will not start

Quote:
Originally Posted by leftbrainstuff View Post
FACT. Fuel, air, compression and timing. All need to be in spec for a diesel to run.

I dont recommend using wd40 or other starting aids. They de oil the bores and the engine will get addicted to it.

Fuel is the usual issue with diesels. Sounds like you have contaminated fuel. Now the fun begins. If crud has got past your filters to the injection pump or injectors you have real problems.

Might be worth checking there is no exhaust or inlet obstruction. These checks are easy.

Diesels are very reliable and trouble free. But they wont tolerate any fuel contamination.

We run a 30 micron primary, 10 micron secondary and 2 micron tertiary fuel filters. We polish weekly. You will never have fuel that is too clean.

Sent from my SM-N900T using Cruisers Sailing Forum mobile app
The fuel is new . In a secondary tank as the old ones have a black crude oil in the bottom and yes I think many moons ago it was run with this **** in and the first fuel filter when I removed it was very clogged . But new filter . Injection pump tested and injectors and as I say it's squirting fine .
__________________
woodyapex is offline   Reply With Quote
Old 31-12-2015, 21:44   #50
Senior Cruiser

Cruisers Forum Supporter

Join Date: Nov 2005
Location: Out there doin' it
Boat: 47' Olympic Adventure
Posts: 2,635
Re: Westerbeke 8 generator will not start

Quote:
Originally Posted by woodyapex View Post
Really sorry guys
Put it all back together . ( injector pump worked perfect on test too .)
I even hooked the injectors up out of the engine and they seemed to work perfect .
On turning it over now I get smoke out of the air intake ( that's with trying to start it on wd40 sprayed in there as advised by the mechanic .

And nowt I can't help but think it it the exhaust or ( the curse of bleeding the westerbeke ) after all there's now talk of its not really self bleeding ?
Easy test to see if it's bled - pop off the fuel return line, put it into a jerry can or pail and press the preheat switch. Fuel should run out clean and free of bubbles.

Did you check for output from the exhaust elbow? With your hand loosely cupped over the hole, when you crank the engine it should feel like gentle puffs against your palm.

Having read back - can you confirm the starter is cranking the engine - this should be obvious as the alternator belt will be spinning.
__________________
Lodesman is offline   Reply With Quote
Old 31-12-2015, 22:21   #51
Registered User

Join Date: Nov 2009
Posts: 101
Re: Westerbeke 8 generator will not start

Quote:
Originally Posted by Lodesman View Post
Easy test to see if it's bled - pop off the fuel return line, put it into a jerry can or pail and press the preheat switch. Fuel should run out clean and free of bubbles.

Did you check for output from the exhaust elbow? With your hand loosely cupped over the hole, when you crank the engine it should feel like gentle puffs against your palm.

Having read back - can you confirm the starter is cranking the engine - this should be obvious as the alternator belt will be spinning.
Took the exhaust off and cupped it . If I did not know any better I'd say besides light puffs I was getting a bit of suction too as it cranks .
The starter is cranking for sure .
__________________
woodyapex is offline   Reply With Quote
Old 31-12-2015, 22:33   #52
Registered User
 
four winds's Avatar

Join Date: Oct 2010
Location: Wandering the US Gulf Coast
Boat: 78 Pearson323 Four Winds
Posts: 2,138
Re: Westerbeke 8 generator will not start

But not a single puff of smoke? Any color.

How could it not be dripping raw fuel out of the manifold by now?
__________________
Life begins at the waters edge.
four winds is offline   Reply With Quote
Old 01-01-2016, 06:21   #53
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,024
Re: Westerbeke 8 generator will not start

Have you checked the lube oil level recently? Is it rising? The injector fuel has to be going somewhere. If not out the exhaust port then the sump is a possibility.
__________________
transmitterdan is offline   Reply With Quote
Old 01-01-2016, 06:43   #54
Senior Cruiser

Cruisers Forum Supporter

Join Date: Nov 2005
Location: Out there doin' it
Boat: 47' Olympic Adventure
Posts: 2,635
Re: Westerbeke 8 generator will not start

Quote:
Originally Posted by woodyapex View Post
Took the exhaust off and cupped it . If I did not know any better I'd say besides light puffs I was getting a bit of suction too as it cranks .
The starter is cranking for sure .
I think a little suction might be normal. If it's a lot, then perhaps you should revisit the intake - have you taken off the air intake silencer and confirmed there's no obstruction? I hesitate to say try to start the engine with the silencer off, but it might be worth a shot if you are very careful about keeping anything from getting sucked in the intake.

I don't suppose you noticed if your hand smelled of diesel after checking the exhaust?
__________________
Lodesman is offline   Reply With Quote
Old 01-01-2016, 07:59   #55
Senior Cruiser

Cruisers Forum Supporter

Join Date: Nov 2005
Location: Out there doin' it
Boat: 47' Olympic Adventure
Posts: 2,635
Re: Westerbeke 8 generator will not start

Have you checked the fuel return line for flow?
__________________
Lodesman is offline   Reply With Quote
Old 30-06-2016, 03:44   #56
Registered User

Join Date: Nov 2009
Posts: 101
Re: Westerbeke 8 generator will not start

Hi everyone
I'm sure you've all had sleepless nights since I posted this thread .
A quick update .
I've only just managed to get back to the boat since January and with a friend more knowledgable then myself had another look at the westebeke .
It seemed besides the heater plugs all not working again one of the Pistons was not getting compression .
So much to my delight ( not ) I spent a few hours and totally removed the whole geni to go to another guy more skilled then me or my friend .
Luckily for me between mr westphal and the previous owner they had been very sympathetic on access to engines and geni so I was able to remove the whole block single handed !
I'm not sure if it's a new feature but for the first time I've put some pictures on I think .
Thanks everyone . I'm back in the uk so as soon as I get news I'll let you know
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	47
Size:	419.6 KB
ID:	127172  
__________________
woodyapex is offline   Reply With Quote
Old 30-06-2016, 03:46   #57
Registered User

Join Date: Nov 2009
Posts: 101
Re: Westerbeke 8 generator will not start

Picture of engine out . Using boom
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	60
Size:	434.9 KB
ID:	127173  
__________________

__________________
woodyapex is offline   Reply With Quote
Reply

Tags
generator, westerbeke

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
When is a Marine Generator not a Marine Generator! Fuss Electrical: Batteries, Generators & Solar 21 12-11-2014 06:35
Next generation ucm1-3.5 generator will not start Sulaire Engines and Propulsion Systems 11 21-03-2013 06:42
Start Small or Start Big ? Zonker Multihull Sailboats 18 16-01-2012 12:13
A/C Start Up on Generator Alecadi Electrical: Batteries, Generators & Solar 57 09-09-2011 11:16
Fault with First Start of Generator ? kerry231168 Electrical: Batteries, Generators & Solar 5 04-12-2010 09:38



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:00.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.