Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 01-07-2014, 10:56   #16
Registered User

Join Date: May 2012
Location: Western Wisconsin
Boat: O’Day Daysailer II, 17'
Posts: 482
Re: Westerbeke 18 hard starting

Do you have a 120 volt block heater that is in use when at the dock? That would explain easy starting even without glow plugs. At anchor the cranking and then waiting and then cranking for an easy start might be glow plugs having enough time to heat the air in the combustion swirl chamber. How long do you wait for glow plugs to warm the engine on initial cranking while at anchor? There might also be some strange wiring issue where the relay for the glow plugs does not work when first cranking. Put a volt meter or test lamp on glow plug circuit to see what is happening when the glow plugs should be in operation when you first try to start the engine.

westwinds is offline   Reply With Quote
Old 05-07-2014, 07:42   #17
Marine Service Provider
Aloha_float's Avatar

Join Date: Mar 2012
Location: Lake Huron
Boat: Tartan 33, 33'6"
Posts: 171
Images: 2
Send a message via Skype™ to Aloha_float
Re: Westerbeke 18 hard starting

Originally Posted by bmm32005 View Post
Similar issue for me. I found that the diesel was draining back into the tank. Installed a check valve and starts right up

Sent from my iPhone using Cruisers Sailing Forum

The pick up line should have a spring loaded ball valve to prevent fuel from returning to tank...I have this on my tank. This also prevents fuel from siphoning into the boat in any case that you have a fuel system failure.

Sent from my iPad using Cruisers Sailing Forum

Aloha_float is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Westerbeke 4-107 starting motor goes 'clunk' mesayousa4 Challenges 5 11-02-2013 18:16
Overpropping = Hard Starting ? ovrmyhead Propellers & Drive Systems 6 17-03-2012 12:34
Hard Starting 4-108 jonathanteller Engines and Propulsion Systems 10 10-03-2011 13:21
Hard Starting Universal - Any Ideas ? Chief Engineer Engines and Propulsion Systems 9 17-09-2010 08:50
Hard Starting Yanmar 3GM30 sailcruz Engines and Propulsion Systems 2 15-05-2007 13:47

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 15:03.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.