Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 14-04-2016, 23:15   #1
Registered User

Join Date: Apr 2016
Location: Juneau, Alaska
Boat: 1982 Catalina 30
Posts: 1
Universal M3-20B wont start after changing fuel filter

I recently went on a three day trip. On the way back my engine would die when I brought the throttle down to idle and it requires the throttle be opened up partially to start it. Also when first starting it cold, the engine revs back and forth varying about 1000 rpm and does this for a few minutes until it warms up and finds a consistent rpm. I have not changed the fuel filters this year so I thought that may be the issue. There was no water in my racor primary filter/water separator. I changed the primary and secondary filters. The primary had some gunk in it and I couldn't see inside the secondary. I filled the filters up with fresh diesel before I screwed them back on. I have bled both bleed screws on the filter and on the injector pump. Fuels flows freely. I loosened up the fuel fittings on the top of the injector and no fuel flows out of the tube when cranking the motor or operating the fuel pump. Not even a dribble. My motor is supposed to be self bleeding but I have tried bleeding anyway and can't get fuel to come out of the injector inlets. I opened the air cleaner and found it was saturated in black oil. I cranked the motor with the air cleaner off to allow plenty of air and still no luck. My glow plug switch has always acted weirdly. Sometimes when I depress it, my oil pressure/water temp alarm will turn off as I am heating the glow plugs and sometimes that alarm does not turn off. I noticed it always starts easier when the alarm goes off while holding the glow plug button but it will still start even if the alarm kept beeping during glow plug warm up. I checked the wires on the back of the glow plug button to make sure that it is functioning when depressed. I don't know how to check glow plugs. And yes I have turned off my seawater seacock to prevent flooding of the engine.

I don't know what else to do. Tomorrow I will try to use some WD-40 as starting fluid to see if it will at least start with that. Any ideas would be appreciated.
__________________

__________________
1982 Catalina 30. Universal M3-20B.
Juneau, Alaska.
mtcaddis is offline   Reply With Quote
Old 15-04-2016, 02:27   #2
Senior Cruiser

Cruisers Forum Supporter

Join Date: May 2013
Location: Oregon to Alaska
Boat: Wheeler Shipyard 83' ex USCG
Posts: 1,699
Re: Universal M3-20B wont start after changing fuel filter

I have no experience with your motor but know diesels.

A diesel needs 3 things to start. Fuel, compression, and enough heat from compression to make ignition temperature. Glow plugs, block heaters, etc. help make temp in a cold engine. Your engine ran before the filter changes, so compression should be ok. Since you opened the fuel system I would start there. If your injector pump has a stop solenoid that is failing, it could explain the problems before the filter change. If the injector pump has a stop lever, make sure the lever is all the way on and any cable or linkage is tight. No fuel coming up the injector lines indicates a stop condition at the pump.
Make sure filters are tight. It's easier to suck air than liquid.
If you use ether, do it lightly. I have heard brake cleaner works with less risk if you don't know the safe amount of ether for your engine.
__________________

__________________
Lepke is offline   Reply With Quote
Old 15-04-2016, 04:55   #3
Moderator
 
HappyMdRSailor's Avatar

Cruisers Forum Supporter

Join Date: May 2008
Location: North Mississippi
Boat: 48 Wauquiez Pilot Saloon-C22 Chrysler Sunpiper- 19 Potter-Preparing to cruise w/my girl
Posts: 5,980
Re: Universal M3-20B wont start after changing fuel filter

Welcome to CF mtcaddis!

Lepke is spot on... Do make sure your stop lever is "fully off" (or solenoid), and then try cracking an injector line at the pump while cranking or using the WD-40... If you do this and you can't get fuel there, there's a leak or restriction in the feed... or restriction in the return... Highly suspect a dirty tank...
__________________
In the harsh marine environment, something is always in need of repair...

Mai Tai's fix everything...
HappyMdRSailor is offline   Reply With Quote
Old 15-04-2016, 06:18   #4
Registered User
 
captjcook's Avatar

Join Date: Jul 2008
Location: Fort Lauderdale Florida
Boat: Northstar 1500, 35'
Posts: 318
Re: Universal M3-20B wont start after changing fuel filter

I believe it possible that your ignition switch contacts could be dirty/worn not making a good power connection to glow plug button, causing the easy/hard start related to glow plugs and warning buzzer. This is not the reason for not starting...Lepke and Happy have that covered.


Sent from my iPad using Cruisers Sailing Forum
__________________
captjcook is offline   Reply With Quote
Old 15-04-2016, 08:39   #5
Registered User

Join Date: Aug 2010
Location: New Jersey, USA
Boat: 1972 Cal 29 - Destiny
Posts: 30
Re: Universal M3-20B wont start after changing fuel filter

I had this happen to me on my Vetus M2.05, new filter and no fuel flow, put the old filter back on and voila....

The 'new' filter I put on had been onboard for a while, the wrapping was a little loose and I can only guess but I suspect the filter had absorbed a lot of moisture over time (no basis for this conjecture so flame away!) which wasn't allowing the fuel to flow, I replaced the 'old' filter with a new new one when I got back to home port and no problems....

Since then I've been very careful about storing the backup filters in ziplog bags just in case and never had the issue again.

Grae Morrison
__________________
grae is offline   Reply With Quote
Old 15-04-2016, 09:08   #6
Registered User

Join Date: Feb 2014
Location: League City Tx. / Glen Haven Co.
Boat: Cal T2 27', Renken 18, Macgregor Venture Cat 15
Posts: 33
Re: Universal M3-20B wont start after changing fuel filter

Possible combination of issues, glow plugs not working and fuel blockage, remove and clean all electrical terminals from the battery, switch and glow plug relays.
Check fuel pressure, treat fuel with an Algeacide, backflush if possible then polish fuel recheck fuel pressure.
Good Luck
__________________
DocRox is offline   Reply With Quote
Old 15-04-2016, 17:45   #7
Registered User

Join Date: Apr 2015
Location: California-Mexico
Boat: Chung Hwa 36 ft ketch
Posts: 18
Angry Re: Universal M3-20B wont start after changing fuel filter

Always start looking for problems where YOU last touched! (Make certain all filter gaskets are properly seated, also check all plugs/ fittings/ be sure both fuel filters are FULL...make certain you have no air leaks!) Since it sounds likely your diesel WAS starving for fuel before you changed the filters, disconnect the fuel line and BLOW air back into the fuel tank. Your engine is not going to start until you get fuel out of the loosened injector tube nuts while cranking. NO fuel=NO START! Remove/ Check the fuel pick up tube , tank shutoff valve, elbows along the line for clogged fuel supply line.(Occasionally a thick, hard precipitate or wax from diesel fuel can plug the line...especially in COLD latitudes!.)
The glow plugs can be checked by touching carefully with your fingers after holding the glow plug button for 15-30 seconds...they should feel at least warm to the touch. The glow plugs are heaters and can be tested for continuity with a voltmeter just the same as you would check a fuse for continuity. I haven't found an inline fuse, relay, or fusible link in the glowplug circuit of my Universal, but you can "jump" the glowplug switch/ wiring with a single wire (10ga.?) directly from the battery to the terminal on the top of one plug. I really encourage you to install an electric fuel pump (you may already have one?) so after fuel filter changes, remove the downstream hose from the secondary filter and turn on the ignition switch/ prime both filters EASY! Good Luck! I really think YOU have a fuel problem! Go real easy and careful with start fluid...easy to BREAK your engine!
__________________
cal20dennis is offline   Reply With Quote
Old 15-04-2016, 22:23   #8
Registered User
 
01kiwijohn's Avatar

Join Date: Mar 2014
Location: Tacoma, Washington, USA
Boat: Casacde 36
Posts: 290
Images: 1
Re: Universal M3-20B wont start after changing fuel filter

" I have bled both bleed screws on the filter and on the injector pump. Fuels flows freely. I loosened up the fuel fittings on the top of the injector and no fuel flows out of the tube when cranking the motor or operating the fuel pump. Not even a dribble."

This being the case, it appears the problem is with the rack control, inside the pump.
If you have bled out all the air, then it should at least start and run ok.
The fuel control rack should go into "full fuel" at rest, which ensures it has plenty of juice to light up when cranked. Once running, the governor takes over and controls the rack, which controls the fuel delivery. If you have NO fuel at the injectors, then this is where the problem must lie.
__________________
01kiwijohn is offline   Reply With Quote
Old 16-04-2016, 07:26   #9
Registered User

Join Date: Feb 2010
Location: East shore Mobile Bay AL
Boat: ODAY 28
Posts: 374
Re: Universal M3-20B wont start after changing fuel filter

good advice in the above threads, are you getting fuel past your secondary filter, I had one that I installed that would not pass fuel, after replacing it again fixed the problem, also if you have a bleeder on in injector pump might try bleeding that also
__________________

__________________
boeing1 is offline   Reply With Quote
Reply

Tags
diesel engine, filter, fuel, fuel filter, fuel injector, injector pump, m3-20, m3-20b, m320, start, starting, universal

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
M3-20B universal/kubota crossover for parts captrick2014 Engines and Propulsion Systems 6 26-04-2016 11:01
oil drain plug dimensions for Universal m3-20b diesel mike shield Engines and Propulsion Systems 3 17-02-2016 10:19
Diesel Won't Start After Filter Change shamrock Engines and Propulsion Systems 51 20-06-2015 09:30
engine won't run well after changing oil/filter gathem Engines and Propulsion Systems 48 09-04-2015 10:34
Fuel Starvation After Upgrading Fuel Filter Snore Engines and Propulsion Systems 5 15-07-2013 06:57



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:53.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.