Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-09-2015, 08:41   #16
Registered User

Join Date: Oct 2009
Location: Rowayton, Ct.
Boat: Cambria 46, Starlight
Posts: 139
Re: Smoky, rough, cold starts on Beta 60

Still no solution. Replaced the lift pump, no difference, next is the injection pump.
__________________

__________________
HHNTR111 is offline   Reply With Quote
Old 05-09-2015, 17:14   #17
Senior Cruiser
 
DeepFrz's Avatar

Cruisers Forum Supporter

Join Date: Mar 2006
Location: Winnipeg
Boat: None at this time
Posts: 7,930
Re: Smoky, rough, cold starts on Beta 60

At least check your compression before you pull the injector pump.
__________________

__________________
The Blue Dot Campaign. This Changes Everything.
DeepFrz is online now   Reply With Quote
Old 05-09-2015, 17:25   #18
Guy
Registered User

Join Date: Feb 2013
Location: So. Oregon, USA
Boat: Seafarer36c
Posts: 4,308
Re: Smoky, rough, cold starts on Beta 60

Quote:
Originally Posted by DeepFrz View Post
At least check your compression before you pull the injector pump.

Yeah that sounds more interesting than an injection pump.
__________________
Guy is offline   Reply With Quote
Old 06-09-2015, 04:57   #19
Registered User

Join Date: Jan 2009
Location: Eastern Caribbean
Boat: Cal 44
Posts: 152
Send a message via ICQ to barboak
Re: Smoky, rough, cold starts on Beta 60

My Beta 50 gets her (diesels feminine?) oil changed by 150 hours no matter the recommended interval. 1200 hours and don't need the glow plugs for starting in the Caribbean!


Sent from my iPad using Cruisers Sailing Forum
__________________
"There was nowhere to go but everywhere,
so just keep on rolling under the stars."
Jack Kerouac, On the Road
barboak is offline   Reply With Quote
Old 06-09-2015, 05:56   #20
Registered User
 
stevec195's Avatar

Join Date: Oct 2011
Location: Fairhope, AL
Boat: Allied Seawind II #103
Posts: 149
Send a message via Skype™ to stevec195
Re: Smoky, rough, cold starts on Beta 60

Potential oil over servicing. Not likely valve stems worn at this point.


Sent from my iPad using Cruisers Sailing Forum
__________________

__________________
stevec195 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Greetings from the Smoky Mountains CrossAndAnchor Meets & Greets 6 03-03-2015 21:14
Volvo 2040 Rough Idle when Cold ben373 Engines and Propulsion Systems 5 03-08-2014 08:27
Smoky Perkins 4-108, lets narrow down the.... Tranquilo Engines and Propulsion Systems 4 30-05-2011 16:06
Smoky Yanmar Part 2 Acadia Engines and Propulsion Systems 12 30-05-2008 09:50
Smoky Farymann - Overpropped? clausont Engines and Propulsion Systems 11 26-05-2008 05:48



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:07.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.