Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 15-12-2013, 13:55   #1
Registered User

Join Date: Jul 2011
Boat: Wauquiez centurion 36
Posts: 24
SDMO suitcase genset

Hi

I have an SDMO Neo 1000 genset, which has been excellent for the past 3 years cruising, but the last time I used it, it wouldnt run properly.

It starts but then it alternates between nearly stalling and reving hard, it runs smoother if I leave the choke partially closed, but it doesn't produce enough power to run my battery charger.

I initially though it was a fuel problem. I emptied all the fuel and filled with new, I have dismantled the carb and ensured the jets are clear (twice!) but it is still the same.

Any thoughts?

Mark
__________________
Thegoodshipmagn is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 21:47.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.