Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 23-04-2012, 09:51   #1
Registered User

Join Date: Aug 2009
Location: Los Angeles Harbor
Boat: Newport 30
Posts: 94
odor--algae bloom?

Have recently noticed an offensive odor in the boat, usually in late afternoon/early evening, as the sun heats up the aft end of the boat.

It's not the holding tank/head/hoses..wrong type of odor. Yesterday, I flushed the scupper/deck drains & they are free. Bilges are nearly dry & cannot detect any odor when lifting the floorboards. Also suspected possible battery gassing, but that's not the issue.

That leaves me with the diesel fuel tank..have any of you experienced an odor associated with an algae bloom in the fuel tank? I try to keep the tank full, but that means that most of the fuel is about 3 years old..have only added about 10 gallons (5 gal/yr) since I filled the tank, when I took delivery & brought her down the coast.

Any ideas appreciated...thanks all,
__________________
jerrymc is offline   Reply With Quote
Reply

Tags
odor

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 00:36.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.