Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 24-11-2015, 04:07   #1
Registered User

Join Date: Oct 2010
Location: Oregon
Boat: 57' Laurent Giles Yawl
Posts: 755
Injector pump not pumping to 2 injectors

My injector pump barely dribbles fuel from two of its output ports. It pumps vigorously to the other two injectors, and the engine starts immediately and runs on those two cylinders. Above idle it sounds normal, but under way there's a lot of vibration, black smoke, and diesel in the exhaust.

So far I've:
- Cleaned the needle valves on top of the injector pump.
- Run the engine with the two high pressure fuel lines off to confirm that fuel barely flows out at idle. At high RPM there is more flow, but given the black smoke, I'm not sure its enough to get the two cylinders firing.
- Replaced fuel filters.
- Had injectors checked.

Should I try anything else before replacing the injector pump? I thought these things never break...

This is a Yanmar 4JH2E with less than 1000 hours on it.
__________________

__________________
our blog
msponer is offline   Reply With Quote
Old 24-11-2015, 05:19   #2
Moderator
 
a64pilot's Avatar

Cruisers Forum Supporter

Join Date: Oct 2013
Location: Albany Ga.
Boat: Island Packet 38
Posts: 17,037
Re: Injector pump not pumping to 2 injectors

Any good Diesel shop can rebuild one, to be truthful I've never had one apart, always thought it need more expertise and equipment that I have, but I've had several re-built.
I'd go the rebuild route as opposed to new. At least you know the problem, that is 99% of the work right there
__________________

__________________
a64pilot is offline   Reply With Quote
Old 24-11-2015, 06:21   #3
Registered User

Join Date: Nov 2014
Posts: 606
Re: Injector pump not pumping to 2 injectors

Take the injection pump to a diesel injection repair facility to be checked. Most likely the pump plungers on the two cylinders that aren't putting out fuel are gummed up to the point that the return springs can't return the plungers all the way back down to the cam lobe, so each stroke is really only getting a partial fill. That's the normal cause of your described scenario.

Of course there could also be other internal problems, but the shop can tell you that.
DougR
__________________
DougR is offline   Reply With Quote
Old 24-11-2015, 07:41   #4
Registered User

Join Date: May 2015
Location: Muskegon, Mi
Boat: Columbia 36
Posts: 187
Re: Injector pump not pumping to 2 injectors

I took the pump off my Universal 5411 to the local diesel injection shop. They replaced a couple of springs, cleaned and tuned it and tested the nozzles for $200. Replacement cost would be over $600. Money well spent.
__________________
capt jgw is offline   Reply With Quote
Old 24-11-2015, 07:42   #5
Registered User

Join Date: Oct 2010
Location: Oregon
Boat: 57' Laurent Giles Yawl
Posts: 755
Re: Injector pump not pumping to 2 injectors

Thank you, guys, for confirming what's probably wrong. It seems to make sense but I wanted you all's opinion, to be sure I wasn't missing another possibility.

We are in Carriacou, so the plan is to fly a replacement into Grenada, get it through customs (ugh), then put it on a ferry to here. The closest diesel shop capable of rebuilding this is either Trinidad or Martinique-- so sending this one out on a round trip to be rebuilt can be chaotically slow and expensive.

Do you think there could be a problem with my fuel, that caused this? I hate to fix it and then kill the next injector pump with bad fuel. If that's possible?

Thanks again.
__________________
our blog
msponer is offline   Reply With Quote
Old 24-11-2015, 07:56   #6
Moderator
 
a64pilot's Avatar

Cruisers Forum Supporter

Join Date: Oct 2013
Location: Albany Ga.
Boat: Island Packet 38
Posts: 17,037
Re: Injector pump not pumping to 2 injectors

It could be fuel, dirt and or "bugs" in the fuel, but then of course that means it's gotten by two filters, pretty unlikely, but possible
__________________
a64pilot is offline   Reply With Quote
Old 24-11-2015, 09:48   #7
Registered User

Join Date: Oct 2011
Location: Sequim, WA
Boat: Pacific Seacraft Dana 24
Posts: 165
Re: Injector pump not pumping to 2 injectors

Water does a number on injector systems. It will get past the filters and causes seizing in pumps and injectors.
__________________
Xthewater is offline   Reply With Quote
Old 24-11-2015, 10:17   #8
Senior Cruiser
 
Lancerbye's Avatar

Cruisers Forum Supporter

Join Date: Mar 2007
Location: Ladysmith,BC, Vancouver Island , Canada
Boat: Lancer 44 Motorsailer
Posts: 1,757
Images: 32
Re: Injector pump not pumping to 2 injectors

After spending 1300 CAD for a major pump rebuild, for a 34 year old pump, I was told by the experienced specialist, that the major reason for pump problems, on older model pumps, is lack of lubrication by the diesel formulation that was changed some years back when low sulphur was introduced. For older model pumps a lubricant has to be added.
__________________
The basis of accomplishment is in never quitting
Mengzi Meng-tse
Lancerbye is offline   Reply With Quote
Old 24-11-2015, 10:26   #9
Registered User

Join Date: Jun 2011
Location: Miami
Boat: Leopard 48' Cat
Posts: 88
Re: Injector pump not pumping to 2 injectors

I recommend without any reservations the following shop for either fuel injection pumps or turbochargers.

I have used them many times over the years

give them a call to discuss your problem or get a quote to rebuild if needed

great service and reasonable prices

good luck
Diesel Power and Injection
305 592 7070
7741 NW 53rd St.
Miami, Fl. 33166
__________________
Starblossom is offline   Reply With Quote
Old 24-11-2015, 10:27   #10
Registered User

Join Date: Jan 2011
Location: The Netherlands
Boat: Victoire 1122
Posts: 70
Re: Injector pump not pumping to 2 injectors

On my VP 2040 there are shims under the high pressure pump. You have to check if any other pump can be mounted without measuring the thikness of the needed shims!?
Reuse of your pump might be better.


Pump leakage of fuel to the carter of the engine can blow your engine while running. So take care of this. Is your engine oil level oke (not to high?)
__________________
Horus is offline   Reply With Quote
Old 24-11-2015, 10:31   #11
Registered User

Join Date: May 2015
Location: Muskegon, Mi
Boat: Columbia 36
Posts: 187
Re: Injector pump not pumping to 2 injectors

Quote:
Originally Posted by Horus View Post
On my VP 2040 there are shims under the high pressure pump. You have to check if any other pump can be mounted without measuring the thikness of the needed shims!?
Right. The shims adjust the pump timing, and if you change the pump you'll need a set of shims to retime it. Rebuilding or tuning the pump should not require retiming, at least mine didn't.
__________________
capt jgw is offline   Reply With Quote
Old 24-11-2015, 10:41   #12
Registered User

Join Date: Oct 2010
Location: Oregon
Boat: 57' Laurent Giles Yawl
Posts: 755
Re: Injector pump not pumping to 2 injectors

So a pump with the same part number has to be adjusted for a specific engine?

The local mechanic suggests we sail to an island with better facilities and have the pump rebuilt. He says we won't hurt the engine running it slow (~1800 rpm) on two cylinders for a short while to get into the harbor.

So we are thinking of a ~350nm reach to St Maarten in the prevailing 10-20 knot trades.
__________________
our blog
msponer is offline   Reply With Quote
Old 24-11-2015, 10:57   #13
Registered User

Join Date: May 2015
Location: Muskegon, Mi
Boat: Columbia 36
Posts: 187
Re: Injector pump not pumping to 2 injectors

Quote:
Originally Posted by msponer View Post
So a pump with the same part number has to be adjusted for a specific engine?

The local mechanic suggests we sail to an island with better facilities and have the pump rebuilt. He says we won't hurt the engine running it slow (~1800 rpm) on two cylinders for a short while to get into the harbor.

So we are thinking of a ~350nm reach to St Maarten in the prevailing 10-20 knot trades.
Yes. Each one is individually timed with the shims. The tolerances are too tight to make them interchangeable without shims.
__________________
capt jgw is offline   Reply With Quote
Old 24-11-2015, 20:11   #14
Registered User

Join Date: Oct 2015
Location: Summerstown Ontario Canada
Posts: 236
Re: Injector pump not pumping to 2 injectors

Before you take anything apart. I would add 1 litre of transmission oil in the fuel tank and run this for some time to see if this will lubricate the pump and injector. We had to do this with a number of diesel engines to swell up seals to prevent leakage and other diesel engines to help with the black smoke. This is due to the no lead removal in the fuel. Let me know if you try it and the results. Thanks Roger
__________________
seabreez is offline   Reply With Quote
Old 25-11-2015, 03:04   #15
Registered User

Join Date: Oct 2009
Location: australia
Posts: 467
Re: Injector pump not pumping to 2 injectors

How long had the motor been sitting prior to problem? Did you find any water or range silt at Filter change?
__________________

__________________
shakey doug is offline   Reply With Quote
Reply

Tags
injector pump

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New injectors v rebuilding injectors Pirateking Engines and Propulsion Systems 54 06-11-2015 06:50
Head Not Pumping Out Completely Tori Plumbing Systems and Fixtures 11 21-07-2011 11:38
Injectors or Pump hooligan6a Engines and Propulsion Systems 29 12-02-2011 10:29
My Diesel Makes LOTS of Blue Smoke, but Does NOT Burn Oil - Is it My Injectors ? Mark Johnson Engines and Propulsion Systems 39 19-01-2011 10:43
Not Pumping Diesel Overboard ? SvenG Construction, Maintenance & Refit 21 19-06-2010 18:45



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 04:52.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.