Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 08-05-2013, 18:13   #1
Marine Service Provider

Join Date: Sep 2012
Location: Cook Islands Rarotonga
Boat: Hudson 50 and Formossa 51
Posts: 82
pirate honda 30 hp starting problem

4 stroke ,30 hp , starts perfect when cold and turns over slowly any other time.changed battery and leads and starter ,solonoid ,and ignition modual.spins slowly if the ignition is on and spins properly if the plug leads are off . ..............remote box and loom have been changed its a twin engine setup .
bizzy is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 01:54.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.