Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-03-2011, 09:29   #1
Registered User
 
Jetexas's Avatar

Join Date: Jul 2009
Location: Houston, TX
Boat: 1982 Oday 34
Posts: 439
Images: 10
Faria temperature gauge problems

I purchased a salvage beta marine diesel last year and dropped it into my 27' Starwind. It came with the control panel full of Faria gauges, but none of the gauges seemed to work. The temperature gauge would read about 125 degrees but never go higher.

We grabbed some other brand temp gauge at West Marine and used that for a couple weeks. It read 160-180 when the engine was running, but of course, it wasn't quite the same size as the Faria, so I switched back to a matching set of Faria gauges once I finished constructing the new control panel.

The new Faria temperature gauge worked great all through the fall, but now it's reading 120-125 just like the old one.

Anyone else have experience with these Faria gauges failing in this manner?

One disclaimer, I have switched some wiring off the alternator around and I did have a wire grounded that shouldn't have been. However, none of the wiring I changed was connected to the temp gauge in any way.

If nobody has heard of the Faria gauges failing, anyone know an electrical reason why a temperature sending unit or gauge would suddenly start showing 125 instead of the correct temperature?
__________________

__________________
Jetexas is offline   Reply With Quote
Old 23-03-2011, 07:33   #2
Marine Service Provider

Join Date: Aug 2008
Location: North Carolina
Posts: 252
Re: Faria temperature gauge problems

Generally a temp gauge is matched to its sender.
Beta Marine have never used Faria gauges so I dont know what wiring you have.
Beta Marine can supply wiring diagrams and wiring harness' for their engines.
Stanley
__________________

__________________
NCboatrx is offline   Reply With Quote
Old 23-03-2011, 07:38   #3
Registered User
 
Jetexas's Avatar

Join Date: Jul 2009
Location: Houston, TX
Boat: 1982 Oday 34
Posts: 439
Images: 10
Re: Faria temperature gauge problems

It's actually a Phasor Marine engine, which is almost identical to the Beta Marine, but nobody knows what I'm talking about when I say Phasor. The Faria gauges were stock with the Phasor.

Since I just bought this gauge in July last year, SJK Marine sent me a number to contact Faria customer service about the issue.
__________________
Jetexas is offline   Reply With Quote
Old 23-03-2011, 07:54   #4
Moderator Emeritus
 
GordMay's Avatar

Join Date: Mar 2003
Location: Thunder Bay, Ontario - 48-29N x 89-20W
Boat: (Cruiser Living On Dirt)
Posts: 31,583
Images: 240
Re: Faria temperature gauge problems

Faria Senders are designated by the following descriptions, and must be selected in combinations of one each from A, B, & C.
(For example: Single station, American resistance, Standard ground)
A Station: Single or Dual
B Resistance: American or European
C Ground: Standard or Floating

See ➥ http://faria-instruments.com/site_manuals/IS0002F.pdf

See also “Testing Engine Gauges”

Page 1 ➥ http://www.cruisersforum.com/gallery...r&imageuser=79

Page 2 ➥ http://www.cruisersforum.com/gallery...r&imageuser=79

Wiring Diagram ➥
http://www.cruisersforum.com/gallery...r&imageuser=79

* Faria's Positive "P" terminal is labeled "I" (Ignition).
__________________
Gord May
"If you didn't have the time or money to do it right in the first place, when will you get the time/$ to fix it?"



GordMay is offline   Reply With Quote
Old 23-03-2011, 11:50   #5
Marine Service Provider

Join Date: Aug 2008
Location: North Carolina
Posts: 252
Re: Faria temperature gauge problems

Quote:
Originally Posted by Jetexas View Post
It's actually a Phasor Marine engine, which is almost identical to the Beta Marine, but nobody knows what I'm talking about when I say Phasor. The Faria gauges were stock with the Phasor.

Since I just bought this gauge in July last year, SJK Marine sent me a number to contact Faria customer service about the issue.
There is a world of differance where you say "almost identical". Please use the correct name as you will have trouble getting spare parts otherwise. If you requested a company to send you parts for a Beta Marine and they didnt fit your Phasor, would you assume the responsibility for the freight and possible re-stocking charge that some companies charge or would you complain about the company sending the incorrect parts?
__________________
NCboatrx is offline   Reply With Quote
Old 23-03-2011, 12:06   #6
Registered User
 
Jetexas's Avatar

Join Date: Jul 2009
Location: Houston, TX
Boat: 1982 Oday 34
Posts: 439
Images: 10
Re: Faria temperature gauge problems

They are virtually identical motors based on the Kubota Z482. All of the parts are interchangeable. In fact, Phasor was sued by Beta Marine for patent infringement in regard to their heat exchanger design. The only difference when you put them side by side are the engine mount brackets. All parts I used when rebuilding the Phasor were Beta parts.

But the Faria temp sensor and gauge were matched, and the Faria temp sensor was working correctly until recently. To clear up any other confusion, I never changed any of the temp sensor wiring, only the alternator wiring. I don't know if that just randomly coincided with this gauge quitting or if there's some strange electrical magic going on here. However, the only place any of the wires would meet up is at the ignition switch.
__________________
Jetexas is offline   Reply With Quote
Old 30-10-2015, 06:18   #7
Registered User

Join Date: Aug 2007
Location: Panama
Boat: Alberg 30, 30' sloop.
Posts: 59
Re: Faria temperature gauge problems

Did you ever solve this issues, I'm having similar problems on my Kubota. Thanks.
__________________

__________________
kirkalittle is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electric Motor Temperature? Extemporaneous Electrical: Batteries, Generators & Solar 12 04-08-2012 02:37
What Is the Right Operating Temperature ? Alecadi Engines and Propulsion Systems 22 06-03-2011 20:17
Engine Temperature biltong Engines and Propulsion Systems 8 15-09-2010 01:09
Installing Temperature Gauge for Yanmar 4JH4E Charlie Engines and Propulsion Systems 8 12-03-2010 11:06
Fuel Gauge Problems Geno53 Engines and Propulsion Systems 4 12-01-2006 11:32



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 13:26.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.