Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-03-2014, 19:34   #1
Registered User

Join Date: Mar 2014
Posts: 9
engine stalls

I have a M4 30 in a Catalina 30. More times then not the engine dies when shifting into gear. I raised the rpm but no help. I heard that maybe the shift cable needs to be replaced? Engine runs great except for this problem Any ideas?
__________________

__________________
Brian S is offline   Reply With Quote
Old 10-03-2014, 20:55   #2
Senior Cruiser
 
delmarrey's Avatar

Cruisers Forum Supporter

Join Date: Mar 2003
Location: Now in Blaine, WA
Boat: Modified Choate 40
Posts: 10,702
Images: 122
Re: engine stalls

Hi Brian,
Welcome aboard!
I wouldn't think a cable would be a cause but the tranny sounds like the cooperate.

If possible try cranking the motor while in gear. If it sound hard to turn then I'd be tearing into the tranny.

With it in neutral, try turning the prop shaft by hand. If no go then it could be a number of things causing a restricted rotation.

Check the oil in the trans too. It should be clear. If milky then water has ingressed into the oil.

More details would help with troubleshooting.
__________________

__________________
Faithful are the Wounds of a Friend, but the Kisses of the Enemy are Deceitful! ........
A nation of sheep breeds a government of wolves!

Unprepared boaters, end up as floatsum!.......
delmarrey is offline   Reply With Quote
Old 10-03-2014, 23:03   #3
Registered User

Join Date: Mar 2014
Posts: 9
Re: engine stalls

Engine turns over and will start fine in gear or out. Shaft is free rotating. I'm looking at maybe injectors? I'm new to diesels so don't know much about them and how thy should sound. Is 900 rpm to high an idle?
__________________
Brian S is offline   Reply With Quote
Old 10-03-2014, 23:40   #4
Senior Cruiser
 
delmarrey's Avatar

Cruisers Forum Supporter

Join Date: Mar 2003
Location: Now in Blaine, WA
Boat: Modified Choate 40
Posts: 10,702
Images: 122
Re: engine stalls

Quote:
Originally Posted by Brian S View Post
Engine turns over and will start fine in gear or out. Shaft is free rotating. I'm looking at maybe injectors? I'm new to diesels so don't know much about them and how thy should sound. Is 900 rpm to high an idle?
I would start by looking at your fuel lines. It could be sucking air at one or more fittings. If the lines are old that would be an indicator. Also the fuel filter seal.

To test it get a fuel can and a short new fuel line and then just suck fuel from the can right at the fuel pump. If it still dies then it could be injectors or HP pump timing.

How many hours on the motor and what kind of condition is your engine room?
__________________
Faithful are the Wounds of a Friend, but the Kisses of the Enemy are Deceitful! ........
A nation of sheep breeds a government of wolves!

Unprepared boaters, end up as floatsum!.......
delmarrey is offline   Reply With Quote
Reply

Tags
engine

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 08:20.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.