Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-03-2016, 11:16   #16
Registered User

Join Date: Feb 2010
Location: East shore Mobile Bay AL
Boat: ODAY 28
Posts: 374
Re: Alternator alarm sounds at idle

agree on the low oil press alarm. as stated above, suggest first check your Idle speed, then put in in gear and recheck to see if the drops to trigger the alarm
__________________

__________________
boeing1 is offline   Reply With Quote
Old 27-03-2016, 11:36   #17
Senior Cruiser
 
Cheechako's Avatar

Cruisers Forum Supporter

Join Date: Aug 2006
Location: Skagit City, WA
Posts: 19,369
Re: Alternator alarm sounds at idle

I've not heard of an Alternator alarm either, but if you have one, is it possible that your regulator doesnt kick in at low rpm? That happens a lot for tach sensors off alternators.
__________________

__________________
"I spent most of my money on Booze, Broads and Boats. The rest I wasted" - Elmore Leonard











Cheechako is offline   Reply With Quote
Old 27-03-2016, 15:28   #18
Registered User

Join Date: Apr 2011
Location: Cruising the east coast and Bahamas
Boat: Pearson 422
Posts: 228
Re: Alternator alarm sounds at idle

It might be the belt alarm, but not because of the belt. On our beta engine with external balmar regulator, when the batteries are fully charged and the solar panels are holding a higher voltage in than the balmar setpoint, the balmar turns off the output from the alternator. Then the beta alarm panel thinks a belt must have broken since there is no alternator output.

If your primary alternator is putting out enough to turn 'off' the alternate alternator, the alarm panel may think the belt broke

Our answer is to either turn off the solar panels or to turn on something like radar that draws enough current to keep the balmar regulator happy


Sent from my iPhone using Cruisers Sailing Forum
__________________
Greg Long
s/v Paperbird
www.paperbird.us
Paperbird is online now   Reply With Quote
Old 27-03-2016, 17:13   #19
Registered User

Join Date: Jan 2008
Location: Sydney
Boat: Delphia 40
Posts: 3
Re: Alternator alarm sounds at idle

Hi. I have a D2-40 and the alarm sounds at idle when the current draw is too high. It is usually when the batteries are down and the Sterling DC DC charger is pulling around 85 amps from the alternator. I simply raise to fast idle while we get underway and the charger puts the initial charge in and things settle down. Still have original 125 amp alternator and 500ah battery bank. Same setup since 2007.
So, I suggest you check initial current draw. Rebuilt alt may have less capacity if parts have been replaced.
Cheers
__________________
Psalm8 is offline   Reply With Quote
Old 27-03-2016, 17:33   #20
Registered User

Join Date: Jan 2013
Location: Ormond Beach, Florida
Boat: 1988 Wilbur 34
Posts: 148
Re: Alternator alarm sounds at idle

I do not have an alternator alarm. However, I've noticed that when the fridge is operating the ammeter may drop to the negative side when operating at idle. As noted by Psalm8, just need to provide a few more rpm's to provide for the 30 amps drawn by the compressor.
__________________
Seighlor is offline   Reply With Quote
Old 27-03-2016, 17:41   #21
Senior Cruiser

Cruisers Forum Supporter

Join Date: Aug 2009
Location: between the devil and the deep blue sea
Boat: a sailing boat
Posts: 17,314
Re: Alternator alarm sounds at idle

1) Make sure the alt did kick in. At times they need to be reved up to kick in. Once they kick in, they should not sound.

2) Make sure the cabling and connectors are fast and secure, electric alarms at times sound when cabling and connectors move under way (rare but did happen to us once).

3) If there is an electronics block, if everything is fine (you have charge) and the alarm sounds - may be a sign the block is going nuts. VP staff can check it in a VP service point.

b.
__________________
barnakiel is offline   Reply With Quote
Old 29-03-2016, 14:38   #22
Registered User

Join Date: May 2009
Location: Grenada
Boat: Shorebro,Royal 33 - Aloisius
Posts: 927
Re: Alternator alarm sounds at idle

I checked my lights, it is the battery light. Engine idles at 850 rpm. Will heck cables and the other suggestions.


Sent from my iPad using Cruisers Sailing Forum
__________________

__________________
landonshaw is offline   Reply With Quote
Reply

Tags
alarm, alternator

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle first or immediate shutdown if temp alarm goes off? rgesner Engines and Propulsion Systems 25 21-12-2015 10:01
anker alarm only sounds once hackoon OpenCPN 1 15-12-2012 15:12
Alarm Sounds yachtvalhalla OpenCPN 0 23-02-2012 23:12
Engine idle woes-Will not idle after warm Pa La O La Engines and Propulsion Systems 5 24-09-2006 13:13



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 19:33.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.