Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 17-08-2016, 20:50   #1
Registered User

Join Date: Oct 2014
Location: Marina Del Rey, CA
Posts: 326
Raymarine ST 60 multi indicator.

Speed indicator part went to 00:00, working fine last time, temp indication is fine. Is this transducer problem or indicator problem? This indicator has depth on the top , speed in the middle and water temp in the bottom.
Thanks in Advance!!


Sent from my iPad using Cruisers Sailing Forum
__________________

__________________
cpt_757 is offline   Reply With Quote
Old 17-08-2016, 21:08   #2
Bailing as fast as I can.
 
GILow's Avatar

Join Date: Sep 2008
Location: Adelaide, South Australia
Boat: Swanson 42
Posts: 3,567
Raymarine ST 60 multi indicator.

Ok, I assume you've checked the obvious and pulled the sender out to see if it is jammed with seaweed or similar?


Sent from my iPad using Cruisers Sailing Forum
__________________

__________________
Very funny Scotty, now beam down my clothes.
http://www.swansonsailor.id.au
GILow is offline   Reply With Quote
Old 18-08-2016, 09:08   #3
Registered User

Join Date: Oct 2014
Location: Marina Del Rey, CA
Posts: 326
Re: Raymarine ST 60 multi indicator.

I checked them, assuming clean, wire contacts also.


Sent from my iPad using Cruisers Sailing Forum
__________________
cpt_757 is offline   Reply With Quote
Old 18-08-2016, 14:27   #4
Bailing as fast as I can.
 
GILow's Avatar

Join Date: Sep 2008
Location: Adelaide, South Australia
Boat: Swanson 42
Posts: 3,567
Re: Raymarine ST 60 multi indicator.

I don't quite understand the use of the word "them" in your response.
Are you saying you pulled the sender unit and the paddle wheel was spinning freely? Or was it something else you checked?

Matt


Sent from my iPhone using Cruisers Sailing Forum
__________________
Very funny Scotty, now beam down my clothes.
http://www.swansonsailor.id.au
GILow is offline   Reply With Quote
Old 18-08-2016, 18:46   #5
Registered User

Join Date: Oct 2014
Location: Marina Del Rey, CA
Posts: 326
Re: Raymarine ST 60 multi indicator.

I mean I check the wiring and contacts both indicator and transducer.


Sent from my iPad using Cruisers Sailing Forum
__________________
cpt_757 is offline   Reply With Quote
Old 18-08-2016, 19:34   #6
Bailing as fast as I can.
 
GILow's Avatar

Join Date: Sep 2008
Location: Adelaide, South Australia
Boat: Swanson 42
Posts: 3,567
Re: Raymarine ST 60 multi indicator.

Ok, you have checked the wiring.

But nearly every time a speed log stops working it is because it has a bit of seaweed or something jammed in the impeller wheel. You need to pull the sender unit out to check this.

Usually there is a plug next to the sender unit that you can swap into the place of the sender while you are cleaning the sender. You should also remove the sender and put the plug in its place when you are not under way, but I don't think many of us do this.

Matt


Sent from my iPhone using Cruisers Sailing Forum
__________________
Very funny Scotty, now beam down my clothes.
http://www.swansonsailor.id.au
GILow is offline   Reply With Quote
Old 18-08-2016, 20:09   #7
Registered User

Join Date: Oct 2014
Location: Marina Del Rey, CA
Posts: 326
Re: Raymarine ST 60 multi indicator.

Thank you very much and I will do so.


Sent from my iPad using Cruisers Sailing Forum
__________________
cpt_757 is offline   Reply With Quote
Old 18-08-2016, 22:25   #8
Bailing as fast as I can.
 
GILow's Avatar

Join Date: Sep 2008
Location: Adelaide, South Australia
Boat: Swanson 42
Posts: 3,567
Re: Raymarine ST 60 multi indicator.

You may know this already, but if you don't, please be aware that even if you find it is clogged with barnacles, you should not put any antifouling on the device. Even the tiniest bit messes up the water flow over the little cups on the paddle wheel and will cause the speed to read low.

This is why you should remove the sender and replace it with the plug whenever you are not using the boat.

Matt


Sent from my iPad using Cruisers Sailing Forum
__________________
Very funny Scotty, now beam down my clothes.
http://www.swansonsailor.id.au
GILow is offline   Reply With Quote
Old 19-08-2016, 08:02   #9
Registered User

Join Date: Oct 2014
Location: Marina Del Rey, CA
Posts: 326
Re: Raymarine ST 60 multi indicator.

I realized that, will be careful.
Thank you very much for your inputs!!


Sent from my iPhone using Cruisers Sailing Forum
__________________

__________________
cpt_757 is offline   Reply With Quote
Reply

Tags
marine, raymarine

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raymarine ST60 wind direction indicator GILow Marine Electronics 9 21-02-2015 19:00
For Sale: Raymarine ST60+ Rudder Angle Indicator Instrument NahanniV Classifieds Archive 1 24-03-2013 06:53
For Sale: Raymarine ST60 Multi and Masterview atmarine Classifieds Archive 5 18-03-2011 19:24
For Sale: Raymarine E80 Series Multi-Pack TritonSailor Classifieds Archive 2 30-09-2009 13:38
Multi vs multi poll Keegan Multihull Sailboats 14 09-05-2008 04:28



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 23:17.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.