Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 13-06-2013, 12:49   #1
thh
Registered User

Join Date: Jun 2011
Posts: 12
Bleeding Universal 5416

I have to bleed the fuel system on an Atomic universal 5416 after I changed the fuel filter. I followed the instruction in the manual and turnde the ignition key to activate the fuel pump. However when I opened the bleeding srew on top neither air nor fuel was dispensed. In fact I did not hear the fuel pump working. Does anyone know what I am doing wrong?
__________________
thh is offline   Reply With Quote
Old 13-06-2013, 13:01   #2
Registered User

Join Date: Jan 2010
Location: Hingham Ma
Boat: Ericson 28 - Cool Change
Posts: 15
Re: Bleeding Universal 5416

Battery switch on?
__________________
Joe & Fran
joe-fran is offline   Reply With Quote
Old 13-06-2013, 13:02   #3
thh
Registered User

Join Date: Jun 2011
Posts: 12
Re: Bleeding Universal 5416

yes battery is on and oil light is on too
__________________
thh is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 04:09.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.