Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 30-08-2009, 20:36   #1
Registered User
mbianka's Avatar

Join Date: Mar 2008
Posts: 2,125
Images: 1
Xantrex XBM Display Problem

I installed an Xantrex XBM battery monitor last June to monitor the 48 volts battery bank for my electric propulsion system. It worked great until July of this year. One month after the warrenty expired. Of course. The problem is the display has all the LCD segments turned on and so I have no idea what the battery bank is doing. Maybe I'm asking to much from s company like Xantrex but, I was hoping to get more than a year for the $350 I paid for the XBM. Two phone calls and two emails to Xantrex "technical support" have not gotten me any return replies let alone answers. I can't even get them to tell me if I can get this unit repaired. They have since discontinued selling the XBM too.
Anyone run into this problem with the XBM and have a fix. I have disconnected the power to the unit several times but, still have all the segments and messages turned on. After this experience especially with their "technical support" I am rather reluctant to purchase another product from them. So I am hoping someone here has a fix for the problem because Xantrex has not been helpful at all.
mbianka is offline   Reply With Quote
Old 31-08-2009, 02:56   #2
Now on the Dark Side: Stink Potter.
CSY Man's Avatar

Cruisers Forum Supporter

Join Date: Aug 2003
Location: Ft. Lauderdale
Boat: 2016 Glacier Bay 2770
Posts: 3,101
Images: 114
I had a problem recently with same monitor.

Disconnected all the wires, then put them back on again.
The connectors in the back are flimsy and shorts are possible.

Life is sexually transmitted
CSY Man is offline   Reply With Quote
Old 31-08-2009, 07:37   #3
Registered User
mbianka's Avatar

Join Date: Mar 2008
Posts: 2,125
Images: 1
Thanks CSY.

I'll give that a try. Being able to measure the current draw to or from the battery is kind of important for an electric boat. Since the system was setup for the XBM shunt I am hoping to get it working again and not have to replace it after only a year if I can avoid it.
mbianka is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gen / Xantrex Charging Problem dohenyboy Electrical: Batteries, Generators & Solar 28 14-07-2009 10:33
Wanted: Old Raytheon 2500 Display knottidedownalt Classifieds Archive 0 04-05-2009 13:09
flashing display in deep measurement Milton Bertin Marine Electronics 1 14-04-2009 02:23
Autohelm ST 7000 display George Elliott Classifieds Archive 0 02-11-2008 15:50
Remote display for laptop? WindDancer Marine Electronics 9 03-05-2007 21:28

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:36.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.