Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 25-04-2019, 05:14   #1
Registered User

Join Date: Jun 2009
Posts: 2
Xantrex Linkpro won’t clear

Hi all. A couple days ago I swapped out my AGM batteries for a larger house bank, from 240ah up to 720ah, as we’re getting ready for full time cruising in a couple weeks. Then I changed the amp hour setting on my Magnum remote panel. All appeared good. But when I went to reset my Xantrex Linkpro to 720 ah, it didn’t appear to accept the change... The Linkpro reads: “720” and stays lit...I can’t clear it nor “toggle” to a different reading. Any ideas? Thx in advance, Rob
sailorrob is offline   Reply With Quote
Old 25-04-2019, 10:39   #2
Registered User
 
Stu Jackson's Avatar

Join Date: Jan 2011
Location: Cowichan Bay, BC (Maple Bay Marina)
Posts: 7,424
Re: Xantrex Linkpro won’t clear

Disconnect the Link. Essentially a "reboot." Once power is gone, let it sit for a bit, then reprogram it.


You may also be interested in this if you haven't seen it already:


For everyone installing a battery monitor: The "Gotcha Algorithm" thread, a "MUST READ"

Link-series Charging Algorithms -- The "Gotcha" Factor!

DEFAULTS are factory settings that are made to be modified to suit your setup.

Also read this one:

Programming a Battery Monitor (by Maine Sail)

https://marinehowto.com/programming-a-battery-monitor/
__________________
Stu Jackson
Catalina 34 #224 (1986) C34IA Secretary
Cowichan Bay, BC, (Maple Bay Marina) SR/FK, M25, Rocna 10 (22#) (NZ model)
Stu Jackson is offline   Reply With Quote
Old 27-04-2019, 06:53   #3
Registered User

Join Date: Jun 2009
Posts: 2
Re: Xantrex Linkpro won’t clear

Thx Stu...gotta love it. So, first I reboor it...then lose power completely. Aarrghh... tried “everything”...except, of course what i should’ve checked first - yup, blew a simple fuse. New fuse, system rebooted...life is good again. LOL

Thx again...gotta love fellow Catalina owners. Rob
sailorrob is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xantrex LinkPro - Advanced Functionality Questions Patrick_DeepPlaya Electrical: Batteries, Generators & Solar 4 23-07-2015 16:47
Xantrex LinkPro - relay wiring bluenoser613 Electrical: Batteries, Generators & Solar 1 26-04-2012 18:44
Xantrex LinkPro Questions - DOA or User Error? akio.kanemoto Electrical: Batteries, Generators & Solar 7 27-06-2011 03:03
Xantrex Link20 and LinkPro wiring captaincookieJP Electrical: Batteries, Generators & Solar 2 20-04-2011 04:22



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 19:42.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.