Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 15-08-2011, 08:10   #1
Registered User

Join Date: Aug 2011
Posts: 1
Westerbeke 4.0bcd Problems

I have a relatively new (240 hrs) Westerbeke 4.0bcd genset,. When I started it the other day it ran at about 50% rpm as usual and was pulsing. Occaisionally it woud rev up to normal then immediately return to running rough. I assumed a fuel filter so I replaced it. Did not fix it. Any ideas ?
__________________
jrelaford is offline   Reply With Quote
Reply

Tags
westerbeke

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Westerbeke Fuel Lift Pump Capt. Rich Engines and Propulsion Systems 2 22-07-2011 09:25
Wanted For Free: Westerbeke Parts / Engine liaison Classifieds Archive 0 28-06-2011 11:10



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 16:33.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.