Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 25-04-2016, 16:05   #1
Registered User

Join Date: Mar 2015
Posts: 15
solar, 100w, open circuit ok, short circuit ok, no power to battery

I have a100w solar panel that worked ok but is now faulty, 1 year old. Open circuit is 19v a bit low but OK. Sort circuit amps are just over 5A, also OK. But when connected to battery no current flows. Even direct connect to battery, no controller. The other panel, I have 2, works fine, charging amps are just a bit less than short circuit amps

Anyone any suggestions?

Thanks
__________________

__________________
NotreVoyage is offline   Reply With Quote
Old 25-04-2016, 16:13   #2
Registered User

Join Date: May 2014
Boat: Morgan Out Island 41
Posts: 697
Images: 2
Re: solar, 100w, open circuit ok, short circuit ok, no power to battery

If the panel is only a year old, contact the mfg. surely it would still be under warranty. What are the specs on the panel? 19v might be fine depending on the panel. 5 amps short circuit seems right too.
__________________

__________________
pcmm is offline   Reply With Quote
Old 25-04-2016, 20:28   #3
Moderator
 
Paul Elliott's Avatar

Cruisers Forum Supporter

Join Date: Sep 2006
Posts: 3,858
Images: 4
Re: solar, 100w, open circuit ok, short circuit ok, no power to battery

If the open-circuit voltage and the short-circuit current are good (and they sound fine), then the panel is functioning as it should. How are you measuring the charging current? Could there be a blown fuse or a missing connection? Is there a diode in the circuit? Even if your battery is fully charged, a direct panel-to-battery connection should deliver measurable current.
__________________
Paul Elliott, S/V VALIS - Pacific Seacraft 44 #16 - Friday Harbor, WA
www.sailvalis.com
Paul Elliott is offline   Reply With Quote
Old 26-04-2016, 23:41   #4
Registered User
 
Sailor647's Avatar

Join Date: Feb 2013
Location: Hailing Port: Portland, Oregon
Boat: Norseman 400
Posts: 197
Re: solar, 100w, open circuit ok, short circuit ok, no power to battery

See our post under Solara Solar Panel Troubleshooting. We were getting no power from the panel until we removed the (bad) diodes completely. The panel also produced measurable power when new diodes were re-installed.
__________________
Sailor647 is offline   Reply With Quote
Reply

Tags
battery, solar

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
100W Solar Charger is Slow P30Dude Electrical: Batteries, Generators & Solar 43 17-05-2015 15:26
8 X 100W Flexible Solar + Morningstar MPPT-60 did I make a mistake autumnbreeze27 Electrical: Batteries, Generators & Solar 14 15-02-2015 15:15
100W Solar wiring theway Electrical: Batteries, Generators & Solar 6 26-11-2014 03:29
Inexpensive 100W flexible solar panel install, part 1 autumnbreeze27 Electrical: Batteries, Generators & Solar 19 30-10-2014 18:06
Renogy 100w solar panels Tide Roller Electrical: Batteries, Generators & Solar 20 31-05-2014 01:13



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:36.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.