Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-07-2011, 15:37   #16
Registered User

Join Date: Jul 2011
Posts: 7
Problem solved. Grass plug in the intake hose. Had to cut the hose to free. Luckily, enough to re-clamp. Given the condition of the oil, we clearly have some maintenance to do when we get the boat home. Thanks again!
__________________

__________________
LaVieSB is offline   Reply With Quote
Old 16-07-2011, 16:29   #17
Registered User
 
Jonathan Reiter's Avatar

Join Date: Jun 2011
Location: aboard Karen in Ft.Pierce, Florida
Boat: 1965 Alberg 35 #190
Posts: 138
Re: Phasor 3.5kw Generator Shuts Off

I'm glad you solved the problem by eliminating everything it couldn't be and then fixing the only thing left, a plugged raw water intake. Cool. Literally.. Have a great time.
__________________

__________________
Jonathan Reiter is offline   Reply With Quote
Old 16-07-2011, 16:33   #18
Senior Cruiser

Cruisers Forum Supporter

Join Date: Oct 2005
Location: Cruising NC, FL, Bahamas, TCI & VIs
Boat: 1964 Pearson Ariel 'Faith' / Pearson 424, sv Emerald Tide
Posts: 1,531
Thumbs up Re: Phasor 3.5kw Generator Shuts Off

From post #5....

Quote:
Originally Posted by s/v 'Faith' View Post
I worked on this generator over and over again on a 424 I was delivering...

... had to troubleshoot 4 different failures in a 3 week time period.

Here is what I recall from that experience.

I suspect the thermal time out issue is right, must be at least a partial flow of cooling water, as the normal run time (from cold) to overheat is ~ 5-7 min... verified a couple times.

BTW, once you fix this, get an extra belt, AND an extra regulator capacitor to put in your spares kit... Need not be a 'Phasor' branded cap, better to mount it outside the gen head so as to avoid all the heat (that is what makes them fail).

Oh, and the 'self bleeding' feature may not always work as advertised (depending on your install). If not, just remove the return line from the injector and let the pump click over for about half a pint of fuel... then the bubbles will come....
Glad you got it... you are still going to want to pick up an extra belt (and maybe a reg.Cap) for your spares kit.
__________________
s/v 'Faith' is offline   Reply With Quote
Old 17-07-2011, 19:50   #19
Registered User

Join Date: Jul 2011
Posts: 7
Thanks! We will take the advice and stock up on spares in the repair and maintenance kit that the previous owners left us. Everything still working well!
__________________
LaVieSB is offline   Reply With Quote
Old 15-10-2013, 13:48   #20
Senior Cruiser

Cruisers Forum Supporter

Join Date: Oct 2005
Location: Cruising NC, FL, Bahamas, TCI & VIs
Boat: 1964 Pearson Ariel 'Faith' / Pearson 424, sv Emerald Tide
Posts: 1,531
Re: Phasor 3.5kw Generator Shuts Off

Btw,

The replacement belts for the Phasor 3.5k are now available on Amazon.com

The part number is; PANTHER RPP BELT PART NUMBER 800-8M-30

Anyone with the generator ought to have a spare,I am on my second replacement.

I am posting this here, since the information is not in the copy of the manual I have and I have had to contact the company twice to get it. Hope this helps someone in the future.
__________________

__________________
s/v 'Faith' is offline   Reply With Quote
Reply

Tags
generator

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 16:15.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.