Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-07-2017, 19:57   #1
Registered User

Join Date: Mar 2012
Location: Vancouver Island
Boat: 37' Tollycraft Sedan
Posts: 21
Onan MDJE won't stay running after start switch released

Hello. I have an Onan MDJE 7.5 kw generator. It seems like it is going to start but as soon as I release the start switch the engine dies.

Suspecting the oil pressure safety switch, I removed the one wire from it and grounded it to the block while starting the engine with no luck. Not knowing if it was a normally open or closed switch I removed the wire and didn't ground it to the engine. Is this a suitable test for this switch? Or should I replace it? There is an engine mounted oil pressure gauge, so I know I have pressure.

Anything else I should check? In the manual there is a chart showing the sequence of operation and during the start cycle it says the "centrifugal switch" closes. I don't know what this is, or where it is located on the engine.

Thanks in advance....
Gregg
__________________

Perdiem is offline   Reply With Quote
Old 04-07-2017, 04:46   #2
Registered User

Join Date: Aug 2015
Posts: 460
Re: Onan MDJE won't stay running after start switch released

How many terminals on the oil pressure switch? If it is more than one, the switch is isolated ground and probably carried +12v when running. By grounding it, you either blew the fuse or broke one of the other safety switches.

As I recall, on an Onan the oil pressure, exhaust temp and water temp switches all run in series and deliver 12v back to the electric fuel pump (if equipped) and the fuel solenoid "hold" coil. During cranking the preheat button powers the fuel solenoid "pull in" coil and as soon as oil pressure comes up, power gets to the hold coil and it stays engaged.

If the engine dies after you let off preheat, the problem is likely in one of the safety sensors or a blown fuse. Multimeter/ohm meter for troubleshooting.
__________________

boatbod is offline   Reply With Quote
Old 04-07-2017, 05:16   #3
Registered User

Join Date: Mar 2012
Location: Vancouver Island
Boat: 37' Tollycraft Sedan
Posts: 21
Re: Onan MDJE won't stay running after start switch released

Thanks for the reply. Only one wire on the oil pressure sensor and the other end is screwed into the block - so I assume it supplies a ground to keep the fuel solenoid happy.

I hadn't thought of the pre heater supplying power to the fuel solenoid during cranking. I'll try holding that in after releasing the starter.
Perdiem is offline   Reply With Quote
Old 04-07-2017, 05:35   #4
Registered User

Join Date: Aug 2013
Posts: 40
Re: Onan MDJE won't stay running after start switch released

My MDJE did the exact same thing. It turned out to be the centrifugal switch points needed gapping after a two year layup. Unfortunately, you can't buy those points new anymore. We my post on smokstack.com for more detail
snotter is offline   Reply With Quote
Old 04-07-2017, 09:40   #5
Registered User

Join Date: Jan 2013
Location: Ormond Beach, Florida
Boat: 1988 Wilbur 34
Posts: 210
Re: Onan MDJE won't stay running after start switch released

For a number of years I had a 5KW that would continue to run only if the preheat switch was held for another five to ten seconds after releasing the starter button.

You might give it a try.
Seighlor is offline   Reply With Quote
Old 04-07-2017, 11:39   #6
Registered User

Join Date: Aug 2015
Location: Bar Harbor, ME USA
Boat: West Wight Potter 19
Posts: 178
Re: Onan MDJE won't stay running after start switch released

Ethanol in the gas?
zedpassway is offline   Reply With Quote
Old 04-07-2017, 12:14   #7
Registered User

Join Date: Dec 2014
Location: the Med
Boat: Nauta 54' by Scott Kaufman/S&S - 1989
Posts: 1,177
Images: 3
Re: Onan MDJE won't stay running after start switch released

If only we could get rid of those ******ng fuel solenoids on gens.

At least, a by-pass option....

M arine
D iesel
J oking
E xperiments
TheThunderbird is offline   Reply With Quote
Old 04-07-2017, 14:00   #8
Registered User
 
Cadence's Avatar

Join Date: Dec 2008
Location: SC
Boat: None,build the one shown of glass, had many from 6' to 48'.
Posts: 7,786
Re: Onan MDJE won't stay running after start switch released

Being as dumb rock. Have you check that your kill isn't stuck?
Cadence is offline   Reply With Quote
Old 04-07-2017, 15:48   #9
Registered User

Join Date: Apr 2017
Location: Temecula CA
Boat: Still not big enough..!!!
Posts: 29
Re: Onan MDJE won't stay running after start switch released

Start-Run switches can fail on the 'Run" contacts side. If this model has that wiring arrangement, then Ohmmeter test that switch section/side.....
bluewatervet is offline   Reply With Quote
Old 04-07-2017, 18:27   #10
Registered User

Join Date: Feb 2015
Location: Los Angeles Harbor
Posts: 177
Re: Onan MDJE won't stay running after start switch released

On my Westerbec 5k genny, the starting sequence, even in warm weather, is 10 seconds preheat, start, continue to hold preheat 20 seconds, runs great. Modern diesel cars and trucks do this sequence automatically. I'd give it a try before taking anything apart.
Rough Magic is offline   Reply With Quote
Old 04-07-2017, 21:31   #11
Registered User

Join Date: Mar 2012
Location: Vancouver Island
Boat: 37' Tollycraft Sedan
Posts: 21
Re: Onan MDJE won't stay running after start switch released

Thanks for all your ideas! The generator is working again - but I'm not 100% sure what I did.

Holding down the preheat button after cranking didn't help.

I confirmed the oil pressure switch was working - it is normally closed and during cranking the oil pressure interrupts the ground (I thought it would be the other way around).

I confirmed the high temp switch was passing 12 volts to the stop solenoid during cranking (and shorted the end off my meter probe trying to hold both ends while cranking).

I removed the cover for the centrifugal switch but there isn't enough room to get in there and do anything. I'll have to remove the main engine start battery. While playing around there I moved the stop solenoid plunger up & down and it seemed sticky at first and then it came free. After that the engine started fine. (could that have been the trouble??)

Our next trip out is for a month and obviously I would rather not have gen problems. Other than getting in there and adjusting the contacts is there anything else I should check/do?

Thanks again.
__________________

Perdiem is offline   Reply With Quote
Reply

Tags
lease

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan MDJE name plate location Perdiem Electrical: Batteries, Generators & Solar 1 03-01-2017 10:28
Frigibar evaporator unit won't stay running Mayhemdog75 Plumbing Systems and Fixtures 7 21-06-2016 20:08
5 HP Yamaha won't stay running landonshaw Auxiliary Equipment & Dinghy 41 24-11-2014 09:02
Yanmar 2GM Won't Start After Winter Layup zippy Engines and Propulsion Systems 17 31-07-2011 20:04
Diesel Won't Start After Sitting for a Year joburnet Engines and Propulsion Systems 56 17-03-2010 08:44



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:26.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.