Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 23-02-2014, 22:48   #1
Registered User

Join Date: Jan 2014
Posts: 33
Next Step Regulator

We have a Next Step Regulator that is malfunctioning after 10years of service. I suspect we need a new one and thats OK but I'd like to confirm this before going ahead. I am having trouble contacting Ample Power or their forum. Can anyone help if I give the symptoms?
__________________

__________________
jaramanpotter is offline   Reply With Quote
Old 24-02-2014, 03:28   #2
Registered User

Join Date: Dec 2010
Location: W Carib
Boat: Wildcat 35, Hobie 33
Posts: 7,961
Re: Next Step Regulator

The Ample crew is on vacation thru today. Maybe why no forum response. I would also just call or email directly. Have always gotten good support from them.

Why kind of problem are you having?
__________________

__________________
belizesailor is offline   Reply With Quote
Old 24-02-2014, 05:01   #3
Moderator Emeritus
 
GordMay's Avatar

Join Date: Mar 2003
Location: Thunder Bay, Ontario - 48-29N x 89-20W
Boat: (Cruiser Living On Dirt)
Posts: 31,586
Images: 240
Re: Next Step Regulator

See "Troubleshooting the Next Step Regulator"
https://amplepower.com/trouble/next/index.html
__________________
Gord May
"If you didn't have the time or money to do it right in the first place, when will you get the time/$ to fix it?"



GordMay is offline   Reply With Quote
Old 24-02-2014, 13:31   #4
Registered User

Join Date: Jan 2014
Posts: 33
Re: Next Step Regulator

Symptoms - over 2 months several episodes of over voltage charging. Voltage up to 15 +. replaced fuse on batt sensor lead - this worked for a while then same again so put in new lead bypassing the fuse block, which was a new addition and we thought maybe faulty. This worked fine for a while. On these occasions there was no error light just high voltage and not entering the absorption adjustment phase. The last occasion we had the error message - No Battery sense. I have the trouble shooting guide. When I go to the forum I cannot login. It requires a special email to circumvent spammers but I have had no reply...if they are on leave maybe I will get something soon. We are in a different time zone with a patchy phone service but I will try that if all else fails.
__________________
jaramanpotter is offline   Reply With Quote
Reply

Tags
regulator

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:27.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.