Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 17-06-2013, 07:52   #1
Registered User

Join Date: Aug 2011
Posts: 9
LunaSea Tricolor assembly-anyone using it?

Hi, I had read the PS review of LED navigation replacement bulbs and assemblies. LunaSea bulbs got a good review. It looks like they now sell a mast head tricolor with a strobe. I was wondering if anyone was using it and if so how you liked it. Any info appreciated.

I tried to post this earlier but I had included a link and I don't think it went through due to that.

Thanks.
__________________

__________________
eddy is offline   Reply With Quote
Old 09-07-2013, 15:34   #2
Registered User
 
riggear's Avatar

Join Date: Mar 2013
Location: Florida
Boat: Creekmore 34
Posts: 143
Quote:
Originally Posted by eddy View Post
Hi, I had read the PS review of LED navigation replacement bulbs and assemblies. LunaSea bulbs got a good review. It looks like they now sell a mast head tricolor with a strobe. I was wondering if anyone was using it and if so how you liked it. Any info appreciated.

I tried to post this earlier but I had included a link and I don't think it went through due to that.

Thanks.
My mast is down too and I would like to install Tri/anchor led too.
The LunaSea does look interesting and relatively decent price I thought.
Hope we hear some real experience here
Thanks for bringing it to my attn.
Cheers,
__________________

__________________
riggear is offline   Reply With Quote
Old 09-07-2013, 21:46   #3
Registered User

Join Date: Feb 2006
Location: Surrey, BC
Boat: Valiant 40-169
Posts: 175
Re: LunaSea Tricolor assembly-anyone using it?

I have installed the tri-color recently (no strobe) and can state it is very bright. Quality of the unit seems very good. I have their single color lights on my bow and stern pulpit as well. Again very bright. I liked the fact they are 100% waterproof. After inserting the bulbs in the sockets I coated the exposed metal with silicone grease for protection.
I think they have a lifetime warranty so that would imply they should last quite a while but the future will tell.
__________________
gordwedman is offline   Reply With Quote
Old 10-07-2013, 05:54   #4
Registered User

Join Date: Aug 2011
Posts: 9
Re: LunaSea Tricolor assembly-anyone using it?

I've purchased the tri-color with strobe and have it fitted but have not installed the mast back in the boat. I can say that the LED's are very bright and the unit appears to be well built...and the price was very reasonable when you compare it to others of similar function. I was going to use the threaded hole at the top to mount the Windex but it ended up interfering with the antennas. If you order from LunaSea ask them to remove the spike when they box it up mine showed up with a couple of holes in the box and the spike was bent.
__________________
eddy is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 16:40.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.