Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-05-2011, 14:58   #1
Senior Cruiser
 
tartansail's Avatar

Cruisers Forum Supporter

Join Date: Oct 2010
Location: Tiverton, RI, USA
Boat: ex-Tartan 40
Posts: 614
Images: 1
Link 2000 Question

OK. Finally got the new boat underway. We're en route to her summer home in Rhode Island. We stopped for the night at a marina at the East end of the Cape Cod Canal. I plugged into shore power. AC panel says juice is coming in. Link 2000 has a green light for AC in and red light for charging. All good. But, the voltage keeps dropping and the amp hours are negative. When I start the engine the voltage immediately climbs. Any ideas as to why the AC doesn't seem to be charging? I'm thinking I'm missing something simple, but can't figure out what. TIA for any suggestions.
__________________
- David
S/V Sapphire Tartan 40 #71

tartansail is offline   Reply With Quote
Old 16-05-2011, 15:01   #2
Senior Cruiser

Cruisers Forum Supporter

Join Date: Feb 2006
Location: Highlands, NJ 07732
Boat: Laurent Giles Salar 40
Posts: 261
Re: Link 2000 Question

Assume you're charging thru a Inverter/Charger. Check both your AC and DC breakers on the charger.
__________________
chris07732 is offline   Reply With Quote
Old 16-05-2011, 15:16   #3
Senior Cruiser
 
tartansail's Avatar

Cruisers Forum Supporter

Join Date: Oct 2010
Location: Tiverton, RI, USA
Boat: ex-Tartan 40
Posts: 614
Images: 1
Many thanks. I figured it was going to be something simple. Not that anything is easy on a new boat. You reminded me that, of course, the controller isn't the charger. The main switch to the charger was turned off. (I'd do five :bang heads: if I wasn't using my iPad to type this.) Works like a charm.
__________________
- David
S/V Sapphire Tartan 40 #71

tartansail is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Link 2000 Replacement ? Wmiii Electrical: Batteries, Generators & Solar 18 22-09-2016 12:00
Link 2000 Problem dweller Electrical: Batteries, Generators & Solar 5 29-01-2011 14:19
Want To Buy: Link 2000 Trevor R Classifieds Archive 5 10-05-2010 16:37
Help, Please, with Link 2000 luso Electrical: Batteries, Generators & Solar 4 31-03-2010 22:20
Want To Buy: Link 2000 with Shunt - 84-2000-06 yacht_planb Classifieds Archive 2 21-02-2010 13:44



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:30.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.