Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 25-12-2011, 12:11   #1
Registered User

Join Date: Jun 2009
Posts: 94
Link 2000 Error Code E-1

Just recently I have started to get an error code on the Link 2000 while connected to shore power and charging the batteries; E-1, Inverter High DC / Battery Voltage Shutdown; Battery voltage has risen above 15.5 volts.

The Link 2000 is connected to a Xantrex Freedom 25 Inverter Charger. The error code is real i.e. the battery voltage is rising to 15.5v, and then the charger shuts down.

The link is programmed for AGM batteries which should regulate to 14.3 accept, 13.3v (70 degF) voltages. If I discharge the batteries 30% and then start to recharge on shore power - it appears to regulate the battery voltages as per the charging profile, without problem. It seems as though this error occurs after the batteries have been at the float voltage for an extended period of time i.e. just leaving the shore power connected and having the charger switched on as 'default'.

Just to be clear this is happens on shore power only, while the xantrex inverter charger is active. I am not trying to equalize the batteries i.e. this mode is not active.

Any thoughts out there as to the reasons this is happening?

Many thanks, michael
__________________

__________________
svfinnishline is offline   Reply With Quote
Old 25-12-2011, 13:25   #2
Registered User
 
xymotic's Avatar

Join Date: Dec 2007
Posts: 1,076
Re: Link 2000 Error Code E-1

I don't have a good lead for you on the why, but I will say you need to get in there with a meter and see what's going on. 15+ volts will kill an AGM battery dead in very short order. I'd disconnect the bank til you can sort out why the Xantrex is overcharging
__________________

__________________
xymotic is offline   Reply With Quote
Old 22-11-2012, 07:24   #3
Registered User

Join Date: Oct 2007
Location: Beaumont
Boat: Passport 41-Touche'
Posts: 135
Re: Link 2000 Error Code E-1

Michael,
I hate to revive an old thread but I am having the same problem and wonder what you found as your gremlin. I have a freedom 20 and link2000r. Last two weeks it will occasionally fail to go from acceptance to float but instead give the e1,overvoltage 15.5 error on the link and shut off the charger. It will successfully go from acceptance to float 15-20 times then fail 1=2 times in a row. I never see high voltages,all connections appear ok on charging system. Just wondered what you found.
__________________
Eddie is offline   Reply With Quote
Old 23-11-2012, 09:34   #4
Registered User

Join Date: Oct 2007
Location: Beaumont
Boat: Passport 41-Touche'
Posts: 135
Re: Link 2000 Error Code E-1

anyone else have a similar problem? thanks
__________________
Eddie is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: Lagoon 440 Private 2007 Huggi21 Classifieds Archive 3 06-11-2011 00:47
Good and Cheap Hotel in Annapolis in November ? Alecadi Atlantic & the Caribbean 11 19-09-2011 07:56
Want To Buy: Xantrex Link 2000 jlubimir Classifieds Archive 4 12-08-2011 23:51



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:18.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.