Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 18-11-2013, 10:47   #1
Registered User

Join Date: Nov 2013
Posts: 2
Gen engine does not run

re Cummins Onan 17kva Gen. approx 3600 hrs.
I have had gen exceed fixed revs and on two successive occasions red pop out button caused shutdown. Gen engine does not run now, I can get it to start, but it soon shuts down. I can confirm that if a direct 12v supply is connected to fuel pump motor runs constantly. I wish to know what is causing this electrical control problem? Anyone out there any ideas> Boat is recently bought, no manuals are available on board and No electrical diagrams for generator protective control systems available. Tks Bobichan http://www.cruisersforum.com/images/smilies/frown.gif
__________________

__________________
Verobob is offline   Reply With Quote
Old 18-11-2013, 13:56   #2
Senior Cruiser
 
Sailmonkey's Avatar

Cruisers Forum Supporter

Join Date: Sep 2009
Location: Houston
Boat: '76 Allied Seawind II, 32'
Posts: 5,779
What make and model of gen?
__________________

__________________
Sailmonkey is online now   Reply With Quote
Old 19-11-2013, 08:07   #3
Registered User

Join Date: Nov 2013
Posts: 2
Re: Gen engine does not run

dear Sailmonkey... Make is "Cummins - Onan" Model 17kva Control Box (on top of Generator ) has M>>>>>>>>> something(sorry I am not on board and will revert with nos. later)
It is older type, i.e. not digital display and the problem seems to be something to do with over - reving of motor and "red" push out/in button control. Engine over-revved twice and on each occaSION RED BUTTON SHUT-DOWN MOTOR., ON SECOND AND CURRENTLY ENGINE STARTS, BUT DOES NOT RUN , ONBLY FOR A FEW SECONDS WITHOUT A direct , batt to fuel pump 12 v supply. Something in the control-side is denying the motor its correct voltage.Thanks your interest any advice gladly received. Verobob
__________________
Verobob is offline   Reply With Quote
Old 19-11-2013, 08:16   #4
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
The best place to post this type of question is on the SmokStak diesel forum in the onan genset section. Lots of really smart guys there. Over there you'll get answers - here you'll get guesses.
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Reply

Tags
engine

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Small 1KW Diesel Generator zboss Electrical: Batteries, Generators & Solar 60 02-03-2014 16:19
Which Engine? Charlie Engines and Propulsion Systems 30 11-11-2012 07:51
Engine Room Removal Hoist Charlie Engines and Propulsion Systems 13 06-02-2012 06:02
Stalling Universal 5424 Engine ryderstk Engines and Propulsion Systems 13 27-07-2011 10:20
Engine Vibrating Violently when Shifting to Neutral Heikki Engines and Propulsion Systems 24 13-07-2011 08:07



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 11:07.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.