Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 14-11-2015, 17:44   #1
Registered User

Join Date: Sep 2013
Posts: 25
Charging issue

2 new 4d house batteries,1 new 4d starter bat.

3 position guest battery switch

Freedom 20 charger

Link 2000 interface

When connected to shore, both batteries charge in all position on bat switch , house batteries charge in 2 position on switch. Problem is start bat is not charging on bat switch when in position 1.

Same issue when running off of engine alternator.

Is it the battery switch, my charger or something else?

Thanks for any advice.







Sent from my iPad using Cruisers Sailing Forum
__________________

__________________
Seaman gagging is offline   Reply With Quote
Old 14-11-2015, 17:52   #2
Registered User

Join Date: Oct 2011
Location: Canada
Boat: CT 56
Posts: 418
Images: 3
Send a message via Skype™ to undercutter
Re: Charging issue

Have you done a continuity test between the Terminal 1 position and the battery?

Did you wire all the leads yourself or was it already done previously and you just changed batteries, etc.

Does the engine start when the switch is just in the engine battery position?

All these should give you the info you need to resolve your problems.
__________________

__________________
undercutter is offline   Reply With Quote
Old 14-11-2015, 17:56   #3
Senior Cruiser
 
Sailmonkey's Avatar

Cruisers Forum Supporter

Join Date: Sep 2009
Location: Houston
Boat: '76 Allied Seawind II, 32'
Posts: 5,780
Re: Charging issue

Sounds to me like your alternator as well a your batt charger are plumbed directly to your house batteries.


Sent from my iPhone using Cruisers Sailing Forum
__________________
Sailmonkey is offline   Reply With Quote
Old 14-11-2015, 19:26   #4
Senior Cruiser

Cruisers Forum Supporter

Join Date: Mar 2007
Location: Santa Cruz
Boat: Boatless Again
Posts: 4,330
Re: Charging issue

Quote:
Originally Posted by Sailmonkey View Post
Sounds to me like your alternator as well a your batt charger are plumbed directly to your house batteries.


Sent from my iPhone using Cruisers Sailing Forum
you have nailed it.
__________________
donradcliffe is offline   Reply With Quote
Old 14-11-2015, 19:46   #5
Registered User

Join Date: Sep 2013
Posts: 25
Re: Charging issue

Sail monkey, thanks for the reply. My set up has not changed through the years. My issue is my start batter is not receiving a charge unless my switch is on all. Is this correct set up? At dockside do I run my switch on all, and when away from the dock run just house batteries? Will my start battery drain after a while? Bilge pumps are connected to start battery also.


Sent from my iPad using Cruisers Sailing Forum
__________________
Seaman gagging is offline   Reply With Quote
Old 14-11-2015, 19:55   #6
Senior Cruiser
 
Sailmonkey's Avatar

Cruisers Forum Supporter

Join Date: Sep 2009
Location: Houston
Boat: '76 Allied Seawind II, 32'
Posts: 5,780
Re: Charging issue

There is no "right" way, but in your case I'd move the bilge pumps to the house bank. When shoreside leave the switch in all, when sailing leave it on 2 and when motoring put it on all. If the house is too low to start the engine then you will have the isolated start battery to save you.

I'm not a fan of this type of setup as it requires doing something, a far better (IMHO) would be an acr, and wire the starter to the start battery.


Sent from my iPhone using Cruisers Sailing Forum
__________________

__________________
Sailmonkey is offline   Reply With Quote
Reply

Tags
charging

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Issue Sterling Error Light, Solar Stops Charging simonpickard Electrical: Batteries, Generators & Solar 35 10-08-2014 16:00
Alternator not charging issue prof_mariner Electrical: Batteries, Generators & Solar 24 22-05-2014 16:14
Battery Charging Issue Labatt Electrical: Batteries, Generators & Solar 6 22-02-2009 15:19
Major issue with new Mercury RIB phorvati Auxiliary Equipment & Dinghy 19 22-06-2008 05:23
Hey Cascade29. Nice article on Cascade boats in the New issue of Good Old Boat Thomas Stone Monohull Sailboats 4 25-12-2003 15:23



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 15:44.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.