Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-08-2017, 22:36   #1
Registered User

Join Date: Apr 2016
Posts: 12
Battery light on Wauquiez Perkins.

I serviced my engine in 88 Wauquiez Centurion and did the timing and alternator belt oils and filters. Subsequently I cleaned out the bilge and engine bay also. No major impact i thought - just wipe around the wiring looms with a cloth and removing the rubber and dirt from between the wiring.

Subsequently the battery light has come on on the dash and the tacho ticking off zero regularly until I up the revs where it sits on normal level. If

i drop the revs it goes back to zero and ticks off there about 2 x a second.

The PO had had a lot of rubber chewed up from the alt belts he was using and noted how he used to use a lever to tension the alternator. His belts were x size and seemed to sit on the internal seat of the alt pulley not necessarily on the sides of the belt but they sat well on the engine pulleys that are of a different profile.

When the mechanic had a look at it he suggested that the belt was too small and that we try another. The new one sat better in the alt pulley and about 1.5 mm proud of the others.

When he tightened it he did it without a lever and just used a spanner i think to lever it out. Seemed too easy considering the PO had the boat for 5 years on a world circumnavigation and couldnīt crack the issue.

From memory but i cant be sure, when we started it post service there were no issues. surely I would have noticed it if the light was on but i cant be sure.

I have checked the batt and when running there is about 14.5v accross it.

Iīm not at the boat atm but am wondering it the belt i slipping and thatīs saying that there is an issue causing the batt light to come on or have i bumped a joint and have caused to to come on.

Any ideas?

Shea
SemusMcgilicoty is offline   Reply With Quote
Old 03-08-2017, 23:54   #2
Registered User

Join Date: Jun 2017
Location: Subic Bay Philippines
Posts: 539
Re: Battery light on Wauquiez Perkins.

Quite often there is a separate wire on the back of the alternator for the tacho/warning light, sounds like there might be a loose connection especially if you have cleaning around the engine, the charging wire is larger and separate to the sensor wires (normally bolted in place) where as the sensor wires are quite often push on clip type
Captsteve53 is offline   Reply With Quote
Reply

Tags
battery, perkins

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anchor light as mast head light under power? carlspackler Rules of the Road, Regulations & Red Tape 57 15-01-2014 07:21
Deck light and Nav light not working SFH Electrical: Batteries, Generators & Solar 1 31-10-2013 04:50
125W Light Bulb found on Port Nav Light Phoenician Electrical: Batteries, Generators & Solar 13 20-07-2013 20:58
LED light turned Nav light BLUE!!! MarkJ Electrical: Batteries, Generators & Solar 19 28-01-2009 09:19
AIR How light is to light to sail in? Perithead Off Topic Forum 26 04-12-2007 17:52



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:40.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.