Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 20-03-2013, 02:28   #1
Registered User

Join Date: Jul 2011
Location: Fiji
Boat: Grand Soleil 52
Posts: 80
Battery charger starting problem

I have a Victron Skyalla 24v battery charger that wont start charging when switched on. If left switched on it eventually starts up and charges normally.

I am long term cruising so always use the 3kw Paguro generator for AC input. The part load Voltage is 220v and frequency is 50Hz.

Is it possible that generator output AC quality has deteriorated in some way that I am not measuring? If so, could this prevent the charger responding to the 'on' switch?
Streetcar is offline   Reply With Quote
Reply

Tags
battery, charger

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:50.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.