Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 20-03-2013, 02:28   #1
Registered User

Join Date: Jul 2011
Location: Fiji
Boat: Grand Soleil 52
Posts: 67
Battery charger starting problem

I have a Victron Skyalla 24v battery charger that wont start charging when switched on. If left switched on it eventually starts up and charges normally.

I am long term cruising so always use the 3kw Paguro generator for AC input. The part load Voltage is 220v and frequency is 50Hz.

Is it possible that generator output AC quality has deteriorated in some way that I am not measuring? If so, could this prevent the charger responding to the 'on' switch?
Streetcar is offline   Reply With Quote

battery, charger

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 05:42.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.