Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 21-09-2015, 16:02   #1
Registered User

Join Date: Aug 2015
Posts: 1
Alternator stops charging after about 15 minutes.

Hello all. I'm having a charging issue. I have a hunter 410 and after starting the engine, it will charge normal for about 15 minutes and then drop to no charge at all. If I restart the engine it happens all over again. This occurs no matter what the state of charge is in the battery bank. It's a yanmar motor with a Next Step Regulator. The battery bank consists of 3 group 27 batteries of 220 ah each. Not sure whether to be looking at the regulator or the alternator. Thanks.

Sent from my iPad using Cruisers Sailing Forum
ddegange is offline   Reply With Quote
Old 21-09-2015, 16:29   #2
Registered User

Join Date: Dec 2014
Location: Brisbane, Qld, Australia
Boat: Fastback 43 catamaran
Posts: 162
Re: Alternator stops charging after about 15 minutes.

Does your next step regulator have led indicator light as this will flash a sequence to tell you what is happening, check this with the manual and you will probably find a setting may require adjusting or there is a fault ect

Sent from my D6653 using Cruisers Sailing Forum mobile app
Sardean is offline   Reply With Quote
Old 21-09-2015, 16:33   #3
Senior Cruiser
Cheechako's Avatar

Cruisers Forum Supporter

Join Date: Aug 2006
Location: Skagit City, WA
Posts: 17,232
Re: Alternator stops charging after about 15 minutes.

Are you sure it drops to no charge? My Next Steps went strong for 15-20 minutes then backed off and tapered down. Maybe something is wrong with your regulator. Also, look to see if the Next Step has a battery temp sensor wired in.... it's possible you have one shorted battery that is overheating...? Just thinkin out loud here...
"I spent most of my money on Booze, Broads and Boats. The rest I wasted" - Elmore Leonard

Cheechako is offline   Reply With Quote

alternator, charging

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
VHF stops receiving after about a minute Wainui Marine Electronics 12 15-07-2015 12:08
Weird Issue Sterling Error Light, Solar Stops Charging simonpickard Electrical: Batteries, Generators & Solar 35 10-08-2014 15:00
Help ! . . . Johnson 8hp Dies After 20 Minutes ! zippy Engines and Propulsion Systems 31 20-07-2011 02:01
Blue Smoke for first 20 minutes. tubpilot Engines and Propulsion Systems 20 10-07-2007 14:57
sat phone pre paid minutes? beau Marine Electronics 3 11-04-2007 17:01

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 17:24.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.