Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 27-01-2018, 14:57   #1
Registered User

Join Date: Oct 2008
Posts: 23
Manual bilge pumps Lagoon 420

I wanted to ensure that the manual bilge pumps in the cockpit of our L420 were servicable. I turned off the electric pumps and filled the bilges from a hose.
I cannot get the manual pumps to work, and am not even sure where the pickup is located, there doesn't seem to be an extra pickup pipe in the bilge.
Any ideas?Click image for larger version

Name:	20180128_084920.jpg
Views:	81
Size:	45.0 KB
ID:	162951
__________________

KeithB is offline   Reply With Quote
Old 27-01-2018, 15:44   #2
Registered User

Join Date: Oct 2012
Location: Home for a couple of years.
Boat: Beneteau 49
Posts: 433
Re: Manual bilge pumps Lagoon 420

I am not sure about the L420, but on my ex L450 the pickup was right next to the electric pump pickup. There should be one in each bilge.
__________________

boom23 is offline   Reply With Quote
Old 27-01-2018, 23:15   #3
Registered User
 
krafthaus's Avatar

Join Date: Apr 2011
Location: Saskatoon, Canada & Eastern Caribbean
Boat: Lagoon 420
Posts: 432
Re: Manual bilge pumps Lagoon 420

The pickup is in the bilge for sure. Check that any pickups havenít been lifted and secured up above water level by the previous owner for some reason.

Have a look and I think you should be able to disassemble these Manual pumps for cleaning/service. That might get them working.

Ours work so sorry I canít offer more help.
__________________
Wherever we want to go, we go. That's what a ship is you know - it's not just a keel and a hull and a deck and sails, that's what a ship needs. But what a ship is...really is, is freedom. ~Johnny Depp as Capt. Jack Sparrow
krafthaus is offline   Reply With Quote
Old 27-01-2018, 23:59   #4
Registered User

Join Date: Oct 2008
Posts: 23
Re: Manual bilge pumps Lagoon 420

Thanks for the suggestions. I think I will follow the pipes from the pump to find if they have been disconnected for some reason before I pull the pumps apart.
Each bilge has a Rule-Mate 2000 submersible bilge pump and a Johnson diaphragm pump with it's own pickup.
Maybe the manual pumps have been disconnected to install the second electric pump, I will report my findings!
KeithB is offline   Reply With Quote
Old 28-01-2018, 10:27   #5
Registered User
 
Smokeys Kitchen's Avatar

Join Date: Aug 2015
Location: On the boat - traveling south to the Puget Sound
Boat: 1999 Pacific Seacraft 40
Posts: 262
Re: Manual bilge pumps Lagoon 420

For what it's worth -

I just rebuilt my Whale Gusher Titan manual pump. The flapper valves had lost flexibility (like me ) and were not opening and closing sufficiently to get a suction going from the bilge out through the pump. Original pump - 18 years old.

I disconnected the lines from both sides and put a water hose in each of them to ensure that the hoses from the pump to the bilge and out through the thru hull were both clear. I ordered a couple of rebuild kits and installed one and now it's working fine.
Smokeys Kitchen is offline   Reply With Quote
Old 28-01-2018, 21:41   #6
Registered User

Join Date: Oct 2008
Posts: 23
Re: Manual bilge pumps Lagoon 420

Further investigation found that the manual pumps share the same pipes as the electric submersible pumps. There is a non return valve about 1 metre downstream from the submersible pump and this was not sealing and stopping the manual pump priming. All now working but I would not want to have to use those manual pumps for long, a lot of effort for small return!
__________________

KeithB is offline   Reply With Quote
Reply

Tags
bilge, bilge pump, lagoon, lagoon 420

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pumps, pumps and more pumps. Winf Plumbing Systems and Fixtures 13 07-03-2016 08:43
420: 420 inverter issues. Our inverter is not working and we are not able to find a manual EW-WE Lagoon Catamarans 1 25-05-2014 08:27
Manual Bilge Pumps Obsolete? virginia boy Construction, Maintenance & Refit 32 24-08-2012 16:22
Bilge Pumps vs Bilge Pumps RoJack1 Construction, Maintenance & Refit 12 30-05-2010 19:01
Using Single Diaphram Pumps as Bilge Pumps jlogan Plumbing Systems and Fixtures 12 29-09-2009 08:05



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:16.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.