Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 30-12-2016, 07:13   #46
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,279
Re: Weather Routing Plug In - Does it Actually Work

@ Hasse A
Quote:
Originally Posted by hasse_A View Post
I did and it sure works. ...
You can also use the plugin Draw, and create a boundary around the isle. Then, check the checkbox "Detect boundary" and then, the weatherroute do not cross the boundary.
As, the boundary can be more large than the isle, you can decided to add all area where the level of water is less than 5 meter (by exemple)

So, the weatherroute that you create is best than only with "Detect land".

B.R. Gilletarom.
__________________

__________________
Gilletarom is offline   Reply With Quote
Old 30-12-2016, 07:58   #47
Registered User

Join Date: Feb 2013
Location: Kourou, French Guyana
Boat: Allegro 33
Posts: 242
Re: Weather Routing Plug In - Does it Actually Work

Quote:
Originally Posted by Gilletarom View Post
@ Hasse A
So, the weatherroute that you create is best than only with "Detect land".
B.R. Gilletarom.
I see another useful way of this. I am going to test the plugin Draw to keep the passage at a minimum distance from the African coast.
There is a resent report on noonsite of an attempted boarding.

On Passage from Canary Islands to Cape Verdes: Attempted Boarding off W Sahara - November 2016 —
__________________

__________________
hasse_A is offline   Reply With Quote
Old 02-01-2017, 12:30   #48
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: Masachusetts
Boat: bristol 27
Posts: 2,788
Re: Weather Routing Plug In - Does it Actually Work

I am traveling at the moment, but I will get back to the questions soon!
__________________
boat_alexandra is offline   Reply With Quote
Old 03-01-2017, 09:42   #49
Registered User

Join Date: Jun 2010
Location: St. Petersburg, Florida
Boat: Gemini 3200
Posts: 701
Re: Weather Routing Plug In - Does it Actually Work

Quote:
Originally Posted by boat_alexandra View Post
I don't know how to properly "extrapolate" polars to higher wind speeds because the actual tactics in heavy weather differ considerably depending on the sailor.
Two possibilities come to mind. (1) You could assume that wind speeds which exceed the maximum value in the polar do not produce any increase in speed. (2) You could assume that wind speeds which exceed the maximum value in the polar produce a speed of zero.

Option (1) has the advantage of producing a route that looks reasonable even though the speeds may be quite inaccurate. Option (2) breaks the route, which calls the user's attention to the polar with the missing data. The first option makes more sense for wind speeds that slightly exceed the maximum value in the polar but becomes less and less reliable as wind speeds increase.

Maybe it would make sense to combine the two, using (1) for wind speeds up to 150% of the maximum speed in the polar and (2) for wind speeds above that threshhold.

Does that seem reasonable?

Fabbian
__________________
fgd3 is offline   Reply With Quote
Old 07-01-2017, 07:07   #50
Registered User

Join Date: Jan 2017
Location: Lyon France
Boat: ALUBAT OVNI39
Posts: 8
Re: Weather Routing Plug In - Does it Actually Work

Hello Sean d'Epagnier, Hello All,

I've been working on installing the Weather-Routing plugin page.

I am using OpenCPN 4.4.0 on Linux
Weather Routing (WR) 1.10
Climatology 1.2
GRIB 4.1

I have installed polar files for my boat :
ovni39-opencpn.xml
<?xml version="1.0" encoding="utf-8" ?>
<OpenCPNWeatherRoutingBoat version="1.10" creator="Opencpn Weather Routing plugin">
<BoatCharacteristics displacement_tons="8" lwl_ft="29" loa_ft="39" beam_ft="10" />
<BoatDrag frictional_drag="0.0170" wake_drag="0.9500" />
<Polar FileName="/usr/share/opencpn/plugins/weather_routing_pi/data/polars/ovni39-opencpn.pol" CrossOverContours="/home/linutop/.opencpn/plugins/weather_routing/contours/!?!usr!?!share!?!opencpn!?!plugins!?!weather_routi ng_pi!?!data!?!polars!?!ovni39-opencpn.pol.contours" CrossOverPercentage="0" />
</OpenCPNWeatherRoutingBoat>

ovni39-opencpn.pol
twa/tws;8;12;16;20;30;40
45;3;4;5;5.5;6;6
60;4;5;6;6.5;7;7.5
75;4.8;6.3;6.5;7.4;7.6;8
90;5.5;7;7.2;7.6;8;8.2
105;5.8;6.5;7.6;7.6;8.2;8.5
120;6;7;7.5;8;8.3;8.7
135;5.3;6.8;7.6;8.2;8.5;9
150;5;6.2;7.1;8;8.7;9
165;4;5.6;6.4;7.5;8;8.5
180;3;5;6;7;7.6;8


I think I succeeded in installation.

I just created two waypoints (start and finish) on Bresilian cost near Amazon mouth:
Start waypoint A :
01° 19.3315 S
44° 53.2793 W
Finish waypoint B
00° 44.1100 S
48° 31.1464 S

I observe that the waypoints are transformed in decimal degree.
For example, the waypoint A became :
lat : 1.32219
long: 44.88799

I compile the route with no problem .
But I am very surprised : the route is traced in Indian Ocean
In fact the coordinates of points A and B are recalculated in decimal degrees but in latitude N and longitude E.

Is there a bug or have I done a bad manipulation ?

Many thanks for your answer
__________________
jazzypan is offline   Reply With Quote
Old 07-01-2017, 12:11   #51
Registered User

Join Date: Jan 2017
Location: Lyon France
Boat: ALUBAT OVNI39
Posts: 8
Re: Weather Routing Plug In - Does it Actually Work

Sorry,
The Finish waypoint B is
00° 44.1100 S
48° 31.1464 W

Pierre
__________________
jazzypan is offline   Reply With Quote
Old 07-01-2017, 13:55   #52
Registered User

Join Date: Jan 2017
Location: Lyon France
Boat: ALUBAT OVNI39
Posts: 8
Re: Weather Routing Plug In - Does it Actually Work

It's better !

I put the minus sign before the degree to indicate S and W

I am no longer in the Indian Ocean, but just in front of the Amazon Mouth.

But the Start point "Lançois"
and the Finish point "Soure"
are not exactly at the good place.

See the screen capture :


Where is my mistake ?
Attached Thumbnails
Click image for larger version

Name:	Capture d'écran - 07012017 - 22:20:28.jpg
Views:	74
Size:	418.8 KB
ID:	139161  
__________________
jazzypan is offline   Reply With Quote
Old 07-01-2017, 14:14   #53
Registered User

Join Date: Jan 2017
Location: Lyon France
Boat: ALUBAT OVNI39
Posts: 8
Re: Weather Routing Plug In - Does it Actually Work

Here is my routing configuration from Lançois to Soure :

<?xml version="1.0" encoding="utf-8" ?>
<OpenCPNWeatherRoutingConfiguration version="1.10" creator="Opencpn Weather Routing plugin">
<Position Name="Lancoi2" Latitude="1.32219" Longitude="44.88799" />
<Position Name="Lançois" Latitude="-0.67781" Longitude="-43.11201" />
<Position Name="Soure" Latitude="0.73517" Longitude="-47.48089" />
<Position Name="Soure2" Latitude="0.73517" Longitude="-47.48089" />
<Configuration Start="Lançois" StartDate="06/01/2017" StartTime="23:49:00" End="Soure" dt="3600" Boat="/home/linutop/.opencpn/plugins/weather_routing/ovni39-opencpn.xml" Integrator="0" MaxDivertedCourse="90" MaxCourseAngle="180" MaxSearchAngle="120" MaxTrueWindKnots="100" MaxApparentWindKnots="50" MaxSwellMeters="5" MaxLatitude="90" TackingTime="0" WindVSCurrent="0" AvoidCycloneTracks="0" CycloneMonths="1" CycloneDays="0" UseGrib="1" ClimatologyType="2" AllowDataDeficient="0" WindStrength="1" DetectLand="1" DetectBoundary="0" Currents="1" InvertedRegions="1" Anchoring="1" FromDegree="0" ToDegree="180" ByDegrees="5" />
</OpenCPNWeatherRoutingConfiguration>

I hope you will understand my problem.
Your soft is very interesting

Regards

Pierre
__________________
jazzypan is offline   Reply With Quote
Old 07-01-2017, 19:34   #54
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 8,989
Re: Weather Routing Plug In - Does it Actually Work

Jazzypan you're doing well. Keep going. Learn by doing more routings
__________________
rgleason is offline   Reply With Quote
Old 08-01-2017, 02:55   #55
Registered User

Join Date: Jan 2017
Location: Lyon France
Boat: ALUBAT OVNI39
Posts: 8
Re: Weather Routing Plug In - Does it Actually Work

Thank you,
Thank you to Gilletarom who gave me the address of a French tutorial.
It works much better (see screenshot)

BUT, there is a but
OpenCPN crashes when I try to export the route or when I exit the program.

Below is the log of the session:

11:23:55 CET: 2017-01-08
11:23:55 CET: ------- Starting OpenCPN -------
11:23:55 CET: Version 4.4.0 Build 2016-05-31
11:23:56 CET: wxWidgets version: wxWidgets 3.0.0 Linux 32 bit wxGTK
11:23:56 CET: MemoryStatus: mem_total: 2003 mb, mem_initial: 12 mb
11:23:56 CET: SData_Locn is /usr/share/opencpn/
11:23:56 CET: PrivateDataDir is /home/linutop/.opencpn
11:23:56 CET: Using existing Config_File: /home/linutop/.opencpn/opencpn.conf
11:23:56 CET: Setting Viewpoint Lat/Lon -0.4419, -48.2108
11:23:56 CET: Setting Ownship Lat/Lon 43.3854, 4.837
11:23:56 CET: Styles loading from /usr/share/opencpn/uidata/styles.xml
11:23:56 CET: No styles found at: /home/linutop/
11:23:56 CET: No styles found at: /home/linutop/.opencpn/
11:23:56 CET: Using SVG Icons
11:23:56 CET: Detected display size (horizontal): 506 mm
11:23:56 CET: System default Language: fr_FR
11:23:56 CET: Opencpn language set to: fr_FR
11:23:56 CET: Creating MyFrame...size(1920, 1055) position(0, 0)
11:23:56 CET: Creating glChartCanvas
11:23:57 CET: OpenGL-> Renderer String: Mesa DRI Intel(R) 945GME x86/MMX/SSE2
11:23:57 CET: OpenGL-> Version reported: 1.4 Mesa 8.0.4
11:23:57 CET: OpenGL-> Detected Intel renderer, disabling stencil buffer
11:23:57 CET: OpenGL-> Texture rectangle format: de1
11:23:57 CET: OpenGL-> Using Vertexbuffer Objects
11:23:57 CET: OpenGL-> Using Framebuffer Objects
11:23:57 CET: OpenGL-> Using FBO Stencil buffer
11:23:57 CET: OpenGL-> Using Depth buffer clipping
11:23:57 CET: OpenGL-> Not Using compression
11:23:57 CET: OpenGL-> Minimum cartographic line width: 1.0
11:23:57 CET: OpenGL-> Minimum symbol line width: 1.5
11:23:57 CET: ChartDB Cache policy: Application target is 995 MBytes
11:23:57 CET: Loading chart db version: V018
11:23:57 CET: Chartdb: Chart directory list follows
11:23:57 CET: Chart directory #0: /data/cartes/image/Atlantique-Nord/Maroc_ouest
11:23:57 CET: Chart directory #1: /data/cartes/image/Atlantique-Sud/Bresil
11:23:57 CET: Chart directory #2: /data/cartes/image/Atlantique-Nord/Mauritanie
11:23:57 CET: Chart directory #3: /data/cartes/CM93 2012
11:23:57 CET: Chart directory #4: /data/cartes/image/Mediterranee
11:23:57 CET: Chart directory #5: /data/cartes/image/Atlantique-Nord/antilles
11:23:57 CET: Chart directory #6: /data/cartes/image/Atlantique-Nord/Canaries
11:23:57 CET: Chart directory #7: /data/cartes/image/Atlantique-Nord/Cap Vert
11:23:57 CET: Chart directory #8: /data/cartes/image/Atlantique-Nord/Madere
11:23:57 CET: Chart directory #9: /data/cartes/image/Atlantique-Nord/Senegal
11:23:57 CET: GPS Watchdog Timeout is: 6 sec.
11:23:58 CET: ChartSymbols loaded from /usr/share/opencpn/s57data/chartsymbols.xml
11:23:59 CET: Using s57data in /usr/share/opencpn/s57data
11:23:59 CET: Initializing Chart /data/cartes/CM93 2012/
11:23:59 CET: CM93Composite Chart Root is /data/cartes/CM93 2012//
11:23:59 CET: Loaded CM93 Dictionary from /data/cartes/CM93 2012//
11:23:59 CET: Loading CM93 cell /data/cartes/CM93 2012//02100900/A/02100900.A
11:23:59 CET: Loading CM93 cell /data/cartes/CM93 2012//02700900/A/02700900.A
11:24:01 CET: OpenCPN est initialisé à 6349 ms.
11:24:01 CET: Looking for UserIcons at /home/linutop/.opencpn/UserIcons
11:24:01 CET: Loading navobjects from navobj.xml
11:24:05 CET: Done loading navobjects
11:24:05 CET: ***GPS Watchdog timeout at Lat:43.3854 Lon: 4.837
11:24:06 CET: Opening NMEA Datastream Serial:/dev/ttyUSB0
11:24:06 CET: Opening NMEA Datastream Serial:/dev/ttyS0
11:24:06 CET: NMEA input device open failed: /dev/ttyUSB0
11:24:09 CET: PlugInManager searching for PlugIns in location /usr/lib/opencpn
11:24:09 CET: PlugInManager: Loading PlugIn: /usr/lib/opencpn/libgrib_pi.so
11:24:09 CET: /usr/lib/opencpn/libgrib_pi.so
API Version detected: 112
PlugIn Version detected: 401
11:24:09 CET: Opencpn language reload for: fr_FR
11:24:09 CET: Loading catalog for: opencpn-grib_pi
11:24:09 CET: Loading catalog for opencpn core.
11:24:09 CET: /usr/share/opencpn/plugins/grib_pi/data/grib.svg
11:24:09 CET: PlugInManager: Loading PlugIn: /usr/lib/opencpn/libweather_routing_pi.so
11:24:09 CET: /usr/lib/opencpn/libweather_routing_pi.so
API Version detected: 110
PlugIn Version detected: 110
11:24:09 CET: Opencpn language reload for: fr_FR
11:24:09 CET: Loading catalog for: opencpn-grib_pi
11:24:09 CET: Loading catalog for: opencpn-weather_routing_pi
11:24:09 CET: Loading catalog for opencpn core.
11:24:09 CET: PlugInManager: Loading PlugIn: /usr/lib/opencpn/libclimatology_pi.so
11:24:09 CET: /usr/lib/opencpn/libclimatology_pi.so
API Version detected: 109
PlugIn Version detected: 102
11:24:10 CET: Opencpn language reload for: fr_FR
11:24:10 CET: Loading catalog for: opencpn-grib_pi
11:24:10 CET: Loading catalog for: opencpn-weather_routing_pi
11:24:10 CET: Loading catalog for: opencpn-climatology_pi
11:24:10 CET: Loading catalog for opencpn core.
11:24:10 CET: PlugInManager: Loading PlugIn: /usr/lib/opencpn/libwmm_pi.so
11:24:10 CET: /usr/lib/opencpn/libwmm_pi.so
API Version detected: 108
PlugIn Version detected: 101
11:24:10 CET: Opencpn language reload for: fr_FR
11:24:10 CET: Loading catalog for: opencpn-grib_pi
11:24:10 CET: Loading catalog for: opencpn-weather_routing_pi
11:24:10 CET: Loading catalog for: opencpn-climatology_pi
11:24:10 CET: Loading catalog for: opencpn-wmm_pi
11:24:10 CET: Loading catalog for opencpn core.
11:24:10 CET: WMM: WMM model data loaded from file /usr/share/opencpn/plugins/wmm_pi/data//WMM.COF.
11:24:32 CET: Loading CM93 cell /data/cartes/CM93 2012//02100900/B/02400900.B
11:24:32 CET: Loading CM93 cell /data/cartes/CM93 2012//02100900/B/02400930.B
11:24:32 CET: Loading CM93 cell /data/cartes/CM93 2012//02700900/B/02700900.B
11:24:32 CET: Loading CM93 cell /data/cartes/CM93 2012//02700900/B/02700930.B
11:24:38 CET: Loading CM93 cell /data/cartes/CM93 2012//02100900/C/02580924.C
11:24:38 CET: Loading CM93 cell /data/cartes/CM93 2012//02100900/C/02580936.C
11:24:56 CET: LOGBOOK: 2017-01-08 10:24:56 UTC DR Lat 43.38540 Lon 4.83700
11:25:34 CET: Loading CM93 cell /data/cartes/CM93 2012//02100900/C/02580948.C
11:29:20 CET: Loading World Chart Q=0 in 0 ms.
11:29:20 CET: Loading World Chart Q=4 in 0 ms.
11:29:45 CET: climatology_pi: cyclone cache: 3912
11:30:00 CET: LOGBOOK: 2017-01-08 10:30:00 UTC DR Lat 43.38540 Lon 4.83700
11:30:00 CET: Using bells sound file: /usr/share/opencpn/sounds/2bells.wav
11:30:01 CET: LOGBOOK: 2017-01-08 10:30:01 UTC DR Lat 43.38540 Lon 4.83700
11:30:01 CET: Using bells sound file: /usr/share/opencpn/sounds/2bells.wav
11:30:07 CET: Using bells sound file: /usr/share/opencpn/sounds/1bells.wav
11:30:07 CET: Using bells sound file: /usr/share/opencpn/sounds/1bells.wav
OpenCPN CRASHES........

Have you an idea ?

Pierre
Attached Thumbnails
Click image for larger version

Name:	Capture-ecran.jpg
Views:	71
Size:	425.7 KB
ID:	139192  
__________________
jazzypan is offline   Reply With Quote
Old 08-01-2017, 04:27   #56
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,279
Re: Weather Routing Plug In - Does it Actually Work

Hello Jazzypan,

I will try to do the same test as you, using your data.
And I'll get back to you.

B.R. Gilletarom.
__________________
Gilletarom is offline   Reply With Quote
Old 12-01-2017, 08:50   #57
Registered User

Join Date: Jan 2017
Location: Lyon France
Boat: ALUBAT OVNI39
Posts: 8
Re: Weather Routing Plug In - Does it Actually Work

Hello Sean d'Epagnier,
hello Gilletarom,

I have un-install all OpenCPN on my Linutop machine.
The folder "/usr/share/opencpn/ has been delete.
The folder "/home/linutop/.opencpn/ has also been delete.

I have re-install OpenCPN cleanly and the plugins GRIB, Climatology and Weather-Routing

There are no route, no trace no waypoint in OpenCPN, all is clean.

I compile a new weather-route normaly with isochrones.
And OpenCPN crashes when I click on the Export button

CPU : N270 Intel at 1.6 Gkz
Ubuntu 12.04.2 LTS precise
Xfce : 1.10.0
OpenCPN 4.4.0
GRIB 4.1
Climatology 1.2
Weathe Routing 1.10

However everything works on Raspberry PI 3.
Just a little dysfunction :
To visualise the isochrone curves I have to close GRIB.
Then the export runs normally.

Pierre
__________________
jazzypan is offline   Reply With Quote
Old 12-01-2017, 10:28   #58
Registered User

Join Date: Jan 2017
Location: Lyon France
Boat: ALUBAT OVNI39
Posts: 8
Re: Weather Routing Plug In - Does it Actually Work

Hello,

For the little dysfunction on Raspberry PI 3, it's due to Open GL graphic acceleration in OpenCPN :
On Raspberry, Open GL graphic acceleration is off (not supported)
On Linutop, Open GL graphic acceleration is on

I tried on Linutop with Open GL graphic acceleration off :
I had the same behavior than on Raspberry (no isochrone curves when GRIB screen is display). Isochrone curves appear when I close the GRIB screen.
But OpenCPN still crashe when I export the weather-route ...
__________________
jazzypan is offline   Reply With Quote
Old 12-01-2017, 10:49   #59
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: Masachusetts
Boat: bristol 27
Posts: 2,788
Re: Weather Routing Plug In - Does it Actually Work

the opengl acceleration works on the raspberry 2, are you saying it won't work on raspberry 3?


As for the export crash, it is a separate issue I should try to fix.
__________________
boat_alexandra is offline   Reply With Quote
Old 12-01-2017, 14:49   #60
Registered User

Join Date: Jan 2017
Location: Lyon France
Boat: ALUBAT OVNI39
Posts: 8
Re: Weather Routing Plug In - Does it Actually Work

I misspoke : OpenGL acceleration works on Raspberry pi3, but OpenCPN becomes very much slower.
For example the compilation of a weather-route takes 10 s without acceleration and 1 mn 28 s with....
May be my screen is misconfigured (I use an HDMI to VGA box) ?
But it is not the subject......

The subject now is the crashes of OpenCPN on Ubuntu 12.04.2
__________________

__________________
jazzypan is offline   Reply With Quote
Reply

Tags
plug, weather

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changes on the Plug-in Download page & new plug-in packages nohal OpenCPN 8 04-07-2014 07:15
Composting toilets, do they actually work? Orrjames General Sailing Forum 33 19-05-2013 16:30
Does This Actually Work ? Cheechako Navigation 4 03-05-2012 05:56



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 23:53.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.