Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-03-2014, 11:45   #1
Registered User

Join Date: Jul 2007
Location: Gloucester, VA / Jackson Hole, WY
Boat: Skye 51' Obelisk
Posts: 15
Updated to New Version - Lost Old Tracks??

I just updated my OpenCPN to 3.2.2 when my old one began to freeze up on opening. Have I lost all my old tracks. I (probably naively) thought that since I chose the "Update" option that all my user data would be saved. However, when I opened the program, my tracks were gone and when I go under route manager, nothing.

Can I find that data saved elsewhere on my computer? Thanks in advance!

__________________

__________________
the mind is given, its contents are not
obelisk is offline   Reply With Quote
Old 07-03-2014, 11:58   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: Updated to New Version - Lost Old Tracks??

obelisk...
From which version did you update? On which OS? The data should survive the upgrade without any problem and stay available. The data is in the file called navobj.xml - more about it in Installing OpenCPN | Official OpenCPN Homepage and Navigation Data Backup | Official OpenCPN Homepage

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 07-03-2014, 12:02   #3
Registered User

Join Date: Jul 2007
Location: Gloucester, VA / Jackson Hole, WY
Boat: Skye 51' Obelisk
Posts: 15
Re: Updated to New Version - Lost Old Tracks??

OS is Windows 7 & and the version of OpenCPN was...I don't know. When I type navobj.xml into the search bar in Windows it comes back with "No Items Match Your Search"
__________________
the mind is given, its contents are not
obelisk is offline   Reply With Quote
Old 07-03-2014, 12:06   #4
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: Updated to New Version - Lost Old Tracks??

It's pretty possible - it resides in a folder which is hidden by default. Have a look at the pages I linked. And do not start OpenCPN - we rotate the backup on every start and keep 5 of them, so in case something went really wrong, you could be out of luck after you start the porgram more than 5 times...
__________________
nohal is offline   Reply With Quote
Old 07-03-2014, 12:22   #5
Registered User

Join Date: Jul 2007
Location: Gloucester, VA / Jackson Hole, WY
Boat: Skye 51' Obelisk
Posts: 15
Re: Updated to New Version - Lost Old Tracks??

After reading the linked pages, I am still stuck. Can't find the opencpn.ini/opencpn.config or navobj.xml files anywhere on the computer. A search of all .gpx files on the windows search tool gets me nothing. Sorry if i am being dense.
__________________
the mind is given, its contents are not
obelisk is offline   Reply With Quote
Old 07-03-2014, 12:29   #6
Registered User

Join Date: Jul 2007
Location: Gloucester, VA / Jackson Hole, WY
Boat: Skye 51' Obelisk
Posts: 15
Re: Updated to New Version - Lost Old Tracks??

^^ Also, old version was 2.5.0
__________________
the mind is given, its contents are not
obelisk is offline   Reply With Quote
Old 07-03-2014, 12:34   #7
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,759
Re: Updated to New Version - Lost Old Tracks??

Under W7 you should find the navobj.xml files under

C:\ProgramData\opencpn

Compare this with the help (? icon) pop-up of OpenCPN (logfile location).
Ok, Nohal said don't start O again...
__________________
bcn is online now   Reply With Quote
Old 07-03-2014, 12:46   #8
Moderator
 
nigel1's Avatar

Cruisers Forum Supporter

Join Date: Oct 2009
Location: Manchester, UK
Boat: Beneteau 473
Posts: 5,184
Re: Updated to New Version - Lost Old Tracks??

Have you selected to search hidden folders and files?
__________________
Nigel
Beneteau 473
Manchester, UK
nigel1 is offline   Reply With Quote
Old 07-03-2014, 12:52   #9
Registered User

Join Date: Jul 2007
Location: Gloucester, VA / Jackson Hole, WY
Boat: Skye 51' Obelisk
Posts: 15
Re: Updated to New Version - Lost Old Tracks??

OK, got the navobj file and opened it, per instruction, and all i got was a couple of waypoints, none of my tracks...

i also copied the navobj1-5 files to a separate location before doing anything, in hopes of preserving the data if i screwed up.

here is the opencpn log file. at the bottom, you can see where i updated versions but taht's all that makes sense to me. can any information be gleaned from here??

https://docs.google.com/file/d/0ByuR...?usp=drive_web
__________________
the mind is given, its contents are not
obelisk is offline   Reply With Quote
Old 08-03-2014, 03:51   #10
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,382
Re: Updated to New Version - Lost Old Tracks??

Perhaps there is an old backup available7

Sent from my GT-N5110 using Cruisers Sailing Forum mobile app
__________________
rgleason is offline   Reply With Quote
Old 08-03-2014, 07:05   #11
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: Updated to New Version - Lost Old Tracks??

obelisk...
That file on Google Drive needs some other sharing settings - like this we can't see it...

Pavel
__________________
nohal is offline   Reply With Quote
Old 08-03-2014, 12:59   #12
Registered User

Join Date: Jul 2007
Location: Gloucester, VA / Jackson Hole, WY
Boat: Skye 51' Obelisk
Posts: 15
Re: Updated to New Version - Lost Old Tracks??

Ok, Google Drive settings should be right now. Thanks for the replies, folks!
__________________
the mind is given, its contents are not
obelisk is offline   Reply With Quote
Old 08-03-2014, 13:18   #13
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: Updated to New Version - Lost Old Tracks??

obelisk...
And I though we have tested any possible corruption of the navobject in the world. We didn't...
The problem is obvious during your first run of 3.2.2:
Code:
07:33:52: Failed to load C:\ProgramData\opencpn\navobj.xml: Error reading Element value.
I counted 3 runs of version 3.2.2 in the log, so you should still have the backup of the data - it will be one of the navobj.xml.X, being much bigger then the current navobj.xml without the tracks.
If you post it somewhere, it will be easy to see why 3.2.2 does not like it and fix it.

Note: All this of course just in case it did not get totally screwed already with 2.5.0 and was the reason for it's "freezing", in which case you started it way too many times for the backups to be useful. Let's see.

Pavel
__________________
nohal is offline   Reply With Quote
Old 08-03-2014, 20:15   #14
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: Masachusetts
Boat: bristol 27
Posts: 2,803
Re: Updated to New Version - Lost Old Tracks??

I have lost tracks as well in the past, or sometimes lost part of the track.. It is more difficult for me to keep track of possible causes because I am constantly developing and dealing with many configurations and various branches.

In any case, why the arbitrary number 5? Or even better, why not merge the past navobj.xml files into a single file so data is never lost.. only remove things if the filesize is greater than a few MB, and then only rotate them if there are changes made during that run of the program. For me 1-5 are all identical files, so to me it is pointless to have any of them.
__________________
boat_alexandra is offline   Reply With Quote
Old 09-03-2014, 07:10   #15
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: Updated to New Version - Lost Old Tracks??

The number is configurable, 5 is default, for no particular reason, it was the first number I have seen on the keyboard... Feel free to come with something more bulletproof, if you feel like it is necessary and possible.
__________________

__________________
nohal is offline   Reply With Quote
Reply

Tags
lost

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:36.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.