Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-05-2011, 04:39   #1
Registered User

Join Date: May 2010
Posts: 16
Strange Chart Behavior in Latest Beta

I have used the latest beta for the past few weeks -- even on the water. Yesterday I used it and had some strange behavior. The charts began to flicker between being present and then going black. This happened several times until it finally went to only black and the open chart icons at the bottom of the screen (right above the status bar) went black, as well. I rebuilt the chart database but had the same experience. Even after restarting cpn. Eventually I got a much smaller scale black screen with chart outlines only. When I clicked on the "go to boat" icon at the top the program crashed.

The only difference with the previous time I used it, when it worked flawlessly, was that I had my instruments connected via NMEA (using a Keyspan USB to Serial adapter.) The instruments worked perfectly with the plugin.

When I returned home and started the program (without instruments or GPS), it again worked fine.

Is this a known behavior with a known fix?

Many thanks.

Ed
__________________

__________________
sailracer is offline   Reply With Quote
Old 05-05-2011, 16:44   #2
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: Strange Chart Behavior in Latest Beta

Quote:
Originally Posted by sailracer View Post
I have used the latest beta for the past few weeks -- even on the water. Yesterday I used it and had some strange behavior. The charts began to flicker between being present and then going black. This happened several times until it finally went to only black and the open chart icons at the bottom of the screen (right above the status bar) went black, as well. I rebuilt the chart database but had the same experience. Even after restarting cpn. Eventually I got a much smaller scale black screen with chart outlines only. When I clicked on the "go to boat" icon at the top the program crashed.

The only difference with the previous time I used it, when it worked flawlessly, was that I had my instruments connected via NMEA (using a Keyspan USB to Serial adapter.) The instruments worked perfectly with the plugin.

When I returned home and started the program (without instruments or GPS), it again worked fine.

Is this a known behavior with a known fix?

Many thanks.

Ed
Hi,SailRacer,
Gee that doesn't sound good.I've got a usb/serial adapter - as far as I know,they've been fairly benign with OpenCPN.I know that's not a lot of help-might be model specific..or,what was plugged into it?

Anything in the log?OpenCPN has a verbose one and it contains a pretty good history...likely,it'll include both bad and good runnings.(Everyone should always check the log before posting,I've learned!)
__________________

__________________
HappySeagull is offline   Reply With Quote
Old 06-05-2011, 06:45   #3
Registered User

Join Date: May 2010
Posts: 16
Re: Strange Chart Behavior in Latest Beta

Thanks for suggesting i check the log.

First of all, I followed the advice in the manual and copied the link from the About menu item and it opened it in my web browser. Unfortunately, the log from two days ago, when I had the trouble, was already gone. It only shows today and yesterday -- the two most recent times I ran the program. I'll have to try again tomorrow when I'm back on the water with the same configuration as when I had the trouble. I'll save the log.

By the way, is there a way to find the log file -- and config file -- manually without pasting the path into a web browser? I cannot find the log or config files in my opencpn directory. I checked my Windows 7 file and folder permissions and I have it set to see hidden and system files. Am I missing something?
__________________
sailracer is offline   Reply With Quote
Old 06-05-2011, 06:47   #4
Registered User

Join Date: May 2010
Posts: 16
Re: Strange Chart Behavior in Latest Beta

Duh! My poor eyesight. I see the opencpn data files are not in "Program Files" but in "Program Data." Found all relevant files.
__________________
sailracer is offline   Reply With Quote
Old 06-05-2011, 07:51   #5
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: Strange Chart Behavior in Latest Beta

Sailracer,if you get Opcn "acting badly" again,can you get a screengrab and post it too?Pictures are worth a thousand words...

(General Windose directions for this:PrtScr on your keyboard then Ctrl+V on any loose picture file-then Ctrl+S as whatever.jpg (or.png) and upload to the forum(paperclip in the advanced posting toolbar)

for anyone lurking:
"To find the location of the log file go to the ToolBar click on "About OpenCPN", the button furthest to the right. ....A quick way to view the logfile is to copy the full file path and then paste this into the address field in a web browser."
Thanks,sailracer!I didn't know that!
But I made a shortcut to the folder because I'm a tweakfreak.
__________________
HappySeagull is offline   Reply With Quote
Reply

Tags
charts

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raymarine Chart Plotter - Strange Track / Heading Angle FraidNot Navigation 4 18-07-2010 15:39
Xantrex ProSine 2.0 behavior Microship Electrical: Batteries, Generators & Solar 16 13-08-2009 10:50
Strange behaviour on Raymarine Track mode with ECS chart plotter zlimmie Navigation 3 10-07-2008 13:56
Bloody disgracefull behavior! viking69 Off Topic Forum 43 11-06-2007 09:49



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:14.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.