Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 28-02-2016, 14:50   #1
Registered User

Join Date: Jul 2015
Location: Plano, Texas
Posts: 68
Squiddio issue

Since GoodAnchorage has gone adios, I thought I would try squiddio. It appears to have a problem with the current OpenCPN code on github. I have tried both a local build and the File Thingie build of the addon using my reasonably fresh OpenCPN build. In both cases, as soon as I enable the addon I get the circle of death. The only other addons I have loaded are watchdog, draw, weather routing and climatology. These all work like champs.

It may well be something has changed in the latest git tree.

I tried the version that is linked from the addon page as well the version in Maurice's repository and get the same result.

Let me know if I can do anything to help sort this.

I would send the crashdump itself but at almost 3M, it is too large even zipped.

Regards,
Doug
Attached Files
File Type: pdf squiddio crash files.7z.pdf (406.1 KB, 9 views)
__________________

__________________
dwoodall is offline   Reply With Quote
Old 28-02-2016, 15:08   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: Squiddio issue

Doug...
Looking at the log it seems like the plugin crashes while loading the data stored locally on your machine, please make a backup of the GPX files in C:\ProgramData\opencpn\squiddio and then remove all of them. If it resolves the problem, I would like to have a look at them to pinpoint the crash.

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 28-02-2016, 15:32   #3
Registered User

Join Date: Jul 2015
Location: Plano, Texas
Posts: 68
Re: Squiddio issue

Hi Pavel,

Did as you asked. Actually renamed the directory and created a new Squiddio directory with nothing in it. When I opened OpenCPN again, it crashed. The last thing in the log was this:

4:15:02 PM: PlugInManager searching for PlugIns in location C:\Program Files (x86)\OpenCPN\plugins
4:15:02 PM: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins\squiddio_pi.dll
4:15:02 PM: C:\Program Files (x86)\OpenCPN\plugins\squiddio_pi.dll
API Version detected: 113
PlugIn Version detected: 7
4:15:05 PM: PlugInManager: Initializing PlugIn: C:\Program Files (x86)\OpenCPN\plugins\squiddio_pi.dll
4:15:05 PM: squiddio_pi: Init()
4:15:05 PM: squiddio_pi: getting .gpx layer files from: C:\ProgramData\opencpn\\squiddio

The directory is empty. It also hangs with the squiddio dll being open so the only way one can remove it is restarting the PC.

I restarted and manually removed the squiddio dll as well as edited out the entries in the openpcn.ini file and all runs fine.

Thanks for your help.

Regards,
Doug
__________________
dwoodall is offline   Reply With Quote
Old 28-02-2016, 16:11   #4
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: Squiddio issue

Doug...
No matter what I try, can't make it crash. Can you try to install the official 4.2.0 and the official plugin from opencpn.org and see if it fails for you?

Thanks

Pavel
__________________
nohal is offline   Reply With Quote
Old 28-02-2016, 20:01   #5
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,394
Re: Squiddio issue

Doug,

You should use the opencpn.org download version, but I am using
squiddio_pi-0.7-ov4.2-maurice-win32 12/23/2016 from File Thingie
and it works. Also the bdbcat version works but does not have languages as complete.

Try reducing number of plugins as pavel says. Also try rename your opencpn.ini and start o to make a new one, see if it works. Then go from there. You can copy your old opencpn.ini back later.
Attached Thumbnails
Click image for larger version

Name:	squiddio.jpg
Views:	52
Size:	192.5 KB
ID:	119799  
__________________
rgleason is offline   Reply With Quote
Old 28-02-2016, 21:38   #6
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: Squiddio issue

Rick...

What, pray tell, is the "bdbcat" version?

Does the version currently on opencpn.org not work?
http://opencpn.navnux.org/plugins/sq...-0.7-win32.exe

Please slow down in sending end users to your file thingie for released PlugIns. We need to get the "official" releases right, and save the "thingie" for experimental Beta testing of Windows images. If the "official" downloads are not right, please help us fix them.

This will avoid confusion, I think. Also, I doubt you want to be responsible for maintaining a production server full of released OCPN PlugIns....

Thanks for all your help
Dave
__________________
bdbcat is offline   Reply With Quote
Old 29-02-2016, 07:49   #7
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,394
Re: Squiddio issue

The squiddio bdbcat version was a reminder it was from your fork and it fixed squiddio, (mauro's did not work), then pavel added translations, now mauro merged and it works.

RE OpenCPN Beta File Thingie
Ok, what should I do?
Just not put notices in the Forum?
or Just put notices in the O Beta Windows Plugins thread?

There are several plugins I am having trouble building properly
and there are a few that don't work for me.

Also I am just updating them as the language files become available.
__________________
rgleason is offline   Reply With Quote
Old 01-03-2016, 04:34   #8
Registered User

Join Date: Jul 2015
Location: Plano, Texas
Posts: 68
Re: Squiddio issue

Hi Pavel,

I did as you asked. Got the released version of O and Squiddio. It will load initially, but hangs if I try to zoom in or out. If I delete squiddio, all works fine. This is with CM-93 charts, fwiw. Also, when I first installed it, it immediately crashed O, but when I restarted it, it worked for a bit but as soon as I tried to zoom it crashed. I do see all the squiddio markers. I guess the next step would be to delete the opencpn directory and start fresh. Still, it seems to me that something is wrong. Again, with the official release builds of O and squiddio from opencpn.org. FWIW, when I looked at the crash dump, it looks like it is generating a memory fault. Have anything changed in the include files that might not have made it into squiddio?

We are into to End of Quarter testing here, so I don't have a lot of time, but spring break is next week and I look into this further if I can be of assistance.

Regards,
Doug
__________________
dwoodall is offline   Reply With Quote
Old 01-03-2016, 07:55   #9
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,394
Re: Squiddio issue

Pavel, just to help. I don't seem to be having those problems on Win10, Opencpnv4.2
with squiddio_pi-0.7-ov4.2-mauro-MPR14-win32 dated 2/27/2016 using CM93 charts on and zooming in and out, with Opengl off. (Dave, do not use this file, as per bdbcat and pavel.)

Then tested again with Opengl on and Texture compression with caching on.
There are pauses as the graphics are processed and the cache filled, but it is working fine with no black screens.

Dave, try turning off squiddio and zooming in and out. -Any difference?
Also Opengl on or off? Texture on or off? What graphics processor?

Did you rebuild the chart database? If opengl and cache are on, turn it off and shutdown and then turn it back on try it. Often when upgrading the chart database and opengl need attention.
__________________
rgleason is offline   Reply With Quote
Old 01-03-2016, 11:37   #10
Registered User

Join Date: Jul 2015
Location: Plano, Texas
Posts: 68
Re: Squiddio issue

OpenGL on, Win 10 system. I did try turning it off by disabling the plugin, but that causes it to crash as well. Yes, I have rebuilt the chart database. I actually deleted my opencpn.ini and started fresh as well. Still the same result. Again, all released items. The only other plugins I have installed or Draw, Watchdog, Weather Route and Climatology. All work great without squiddio.

Regards,
Doug
__________________
dwoodall is offline   Reply With Quote
Old 01-03-2016, 11:48   #11
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,394
Re: Squiddio issue

Doug, I'll download the website plugin in about 3 hours and try it. Sorry about the name. Have to go vote in primary.
__________________
rgleason is offline   Reply With Quote
Old 01-03-2016, 15:04   #12
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,394
Re: Squiddio issue

Doug,
I downloaded and installed Pavel's version. Its working for me, with good downloads etc.
You've used this before, right? So you've entered your user name and number properly?

I am sorry I can't seem to identify the problem. Have you looked at the log file?

I did notice that when I bring up preferences by click on green squiddio lighthouse icon there are options to send and receive logs with friends.
I have those both on "never".
I just tried "Once a day" and things sort of froze up, but by resetting to "never" the problem disappeared. I don't know how those work, but will ask. I have checked the website in my panel and I don't see any settings for adding friends, but there must be a place to do this. It seems like a great idea.
__________________
rgleason is offline   Reply With Quote
Old 01-03-2016, 16:44   #13
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,394
Re: Squiddio issue

The squiddio user dashboard has the ability to invite friends to follow and an area to manage your log posts and friends you are following.
__________________
rgleason is offline   Reply With Quote
Old 06-03-2016, 05:40   #14
Registered User

Join Date: Jul 2015
Location: Plano, Texas
Posts: 68
Re: Squiddio issue

A quick update on this. I deleted my opencpn directory and reinstalled from the release. Still squiddio did not work. I renamed my programdata/opencpn and then squiddio worked. I went about my business (its testing week, so a lot of long days). Yesterday I opened opencpn and it hung again. I restarted my pc and deleted squiddio and everything worked. I have no idea what is going on with it at this point. I guess it is somewhat moot in that squiddio itself doe not have a lot of useful information in it, but I would like to sort this out. Also I notice that squiddio does not include an uninstaller and it the dll stays open when opencpn crashes forcing a restart if you want to delete it. I am on spring break this week, so I should have a little time to look more into this. If I can figure out how, I will move it into the main tree of opencpn and launch it in debug mode to at least figure out where it is getting stuck.

Regards,
Doug.
__________________

__________________
dwoodall is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
squiddio plugin boat_alexandra OpenCPN 108 09-08-2017 08:20
Major issue with new Mercury RIB phorvati Auxiliary Equipment & Dinghy 19 22-06-2008 05:23
Atomic 4 issue DaveK Engines and Propulsion Systems 23 03-09-2006 13:22
Hey Cascade29. Nice article on Cascade boats in the New issue of Good Old Boat Thomas Stone Monohull Sailboats 4 25-12-2003 15:23



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 17:21.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.