Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-02-2014, 09:36   #1
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
S63_PI Alpha Test 0.2.0

Ahoy, OpenCPN'ers...

The next Alpha test (0.2.0) of the S63 PlugIn is available for download now.

o-charts


1. Installation:
No change from previous version instructions. Windows installer should be better able to manage parallel installations now.

2. Operation:
You will note that installing S63 cells is now a two step process.

a. Import Cell permits,
and then ...
b. Import the chart cells from the S63 Exchange set, generally from the ENC_ROOT directory.

The reason for this change in UI is in order to allow updates from your chart provider. When you receive an updated Exchange Set from your chart supplier, you may import the ENC_ROOT directory using the "Import Charts/Updates" button. Cells imported as updates are applied automatically to the correct existing base cells.
Normally, you will Import Cell permits only once, when you receive the permits from the chart supplier.

Important note:
If you have previously installed permits/cells with the 0.1.0 s63_pi, you will experience some SENC thrashing until you remove your existing cell permits, and then (re)import the appropriate permits and cells from the S64 test set.

3. Testing:
We are now ready to begin critical testing of chart rendering and performance. After initial loading of an S63 chart, the performance (zoom, pan, etc) should be very nearly the same as an S57 chart of equivalent scale/complexity. Likewise for rendering fidelity and object queries.
Please note that the s63_pi does not support "rollover" LIGHT object hi-lighting as the standard OpenCPN S57 charts do. This is work in progress. Likewise for chart Thumbnails in Single-Chart-Mode.
Everything else should work and look the same as in the base S57 support in OCPN.

Plans:
The next release will be the first official Beta of s63_pi. At that point we expect to advise that you may confidently purchase and install some real S63 cell permits and chart sets. We will have instructions/advice for this step as it comes closer.


Thanks
Dave
__________________

__________________
bdbcat is offline   Reply With Quote
Old 01-02-2014, 10:30   #2
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Alpha Test 0.2.0

Testing erroneous userpermit does not bring up the correct error msg but
"ERROR: s63_pi could not execute OCPNsenc utility"

Under Windows this one...

Hubert
__________________

__________________
bcn is offline   Reply With Quote
Old 01-02-2014, 11:09   #3
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: S63_PI Alpha Test 0.2.0

What about a version for Linux 64bit?

Gerhard
__________________
CarCode is online now   Reply With Quote
Old 01-02-2014, 12:30   #4
Senior Cruiser
 
sailorF54's Avatar

Cruisers Forum Supporter

Join Date: Dec 2009
Location: Perros-Guirec, France
Boat: Jeanneau Sunshine 36
Posts: 829
Re: S63_PI Alpha Test 0.2.0

When rebuilding the S63 chart database, the log spits out for (apparently) all the charts


Code:
20:23:03: Loading chart data for C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GB301620.000
20:23:03: CPL ERROR 1: File `C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GB301620.000' does not appear to have
a valid ISO 8211 header.

20:23:03:    s57chart::BuildS57File  Unable to open C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GB301620.000
20:23:03:    Cannot initialize ENC file C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GB301620.000
20:23:03:    ...initialization failed for C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GB301620.000
20:23:03:    CreateChartTableEntry() failed for file: C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GB301620.000
20:23:03: Loading chart data for C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GBK01620.000
20:23:03: CPL ERROR 1: File `C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GBK01620.000' does not appear to have
a valid ISO 8211 header.

20:23:03:    s57chart::BuildS57File  Unable to open C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GBK01620.000
20:23:03:    Cannot initialize ENC file C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GBK01620.000
20:23:03:    ...initialization failed for C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GBK01620.000
20:23:03:    CreateChartTableEntry() failed for file: C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301620\3\0\GBK01620.000
20:23:03: Loading chart data for C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301640\4\0\GB301640.000
20:23:03: CPL ERROR 1: File `C:\Users\admini\Desktop\IHO S-64 [S-63 TDS v1.2]\8 Data Exchange Media\Test 8a\V01X01\ENC_ROOT\GB\GB301640\4\0\GB301640.000' does not appear to have
a valid ISO 8211 header.
............
__________________
sailorF54 is offline   Reply With Quote
Old 01-02-2014, 12:40   #5
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Alpha Test 0.2.0

Question: did you remove all the old (= from the 0.1.0 version) permits first?
Highlight (you can highlight all at the same time ) and remove. Takes its time.

Then the chart outlines should disappear. Please try panning, selecting another chart and/or restart OpennCPN.
Cleaning up the first alpha seems to be very necessary....

Had some crap as well....
__________________
bcn is offline   Reply With Quote
Old 01-02-2014, 14:16   #6
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: S63_PI Alpha Test 0.2.0

Testing om Linux 64 bits, compiled from Git.
No luck so far. Restarting, deleting all old stuff including s63charts & S63ENCS in .opencpn, etc. Similar messages to sailorF54.
Also, the plugin version is still called 0.1 in Options ?

Thomas
__________________
cagney is offline   Reply With Quote
Old 01-02-2014, 14:31   #7
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: S63_PI Alpha Test 0.2.0

Testers...

If you are having trouble upgrading to 0.2.0, do this:

1. Delete S63SENC and s63charts directory in your config directory.
2. Delete the chartlist.dat file.
3. Edit your config file, and remove [ChartDirectories] key and all contents therof.

Start O, and then load permits/cells.

Thanks for your patience.
Dave
__________________
bdbcat is offline   Reply With Quote
Old 01-02-2014, 15:14   #8
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: S63_PI Alpha Test 0.2.0

hello Dave,

Quote:
Originally Posted by bdbcat View Post
Testers...

If you are having trouble upgrading to 0.2.0, do this:

1. Delete S63SENC and s63charts directory in your config directory.
2. Delete the chartlist.dat file.
3. Edit your config file, and remove [ChartDirectories] key and all contents therof.

Start O, and then load permits/cells.

Thanks for your patience.
Dave
O331328,
First I unsinstall old S63 plugin.
Then I use CCleaner
Then I install S63 0.2.0
Then I run O
Then I activate S63 plugin (I read 0.1 version ???)

I think that I have tryed all you have said in this page with permi.txt on 8b and the chart in 8b.

Dave, I do not have any trouble ! All seem Ok, No crash ! .... BUT, BUT ...


The database do not insert any S63. And then Nothing appear in the screen. No red borderline ! No chart usable !
In opencpn ini folder, only s63charts sub-folder appear.

Here join opencpn.ini, opencpn.log.

B.R Gilletarom
Attached Files
File Type: doc opencpn_S63_0.2_O331328_First_test.zip.doc (55.8 KB, 26 views)
__________________
Gilletarom is offline   Reply With Quote
Old 01-02-2014, 15:21   #9
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Alpha Test 0.2.0

With the Windows Installer I had to indicate the /3.3.1328/plugin directory manually - where did you install?
(the pi is named 0.1 in the plug-in tab for the alpha 0.2)
__________________
bcn is offline   Reply With Quote
Old 01-02-2014, 15:35   #10
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: S63_PI Alpha Test 0.2.0

hello Dave,

Wouahhhh !!!

Second test. This time, I delete folder s63charts, I delete CM93, files : opencpn.ini, navobject.xml, navobjects1/2/3/4/5.xml, charlist.

Then I run O
I change language
I add CM93 directory
I add NZ chart directory.

Then I was ready to test S63_2.

I activate it without problem
I add userpermit without problem
I import cells permits without problem with 8a
I use the second new button and I test 8a ENC Root

And all is good. S63 run correctly !!!
Attached Thumbnails
Click image for larger version

Name:	2014-02-01_OCPN_331328_S63_0.2_All_is_good.jpg
Views:	114
Size:	111.0 KB
ID:	75118  
__________________
Gilletarom is offline   Reply With Quote
Old 01-02-2014, 15:59   #11
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: S63_PI Alpha Test 0.2.0

Hello,

Other test.

See join screen copy with settings

With "paper chart" more details are displayed than with "Simplified". See join screen copy. Buoys and beacons are not displayed by example.

When I change 2 colors for 4 colors, no problem.

When I exchange, with "Paper chart", "Plain" with "Symbolized", the screen appear grey. Idem with other kind of change in settings. Then, I f use CM93, all is ok but if I return to S63, the grey colour is already present.
In this case, the only method to return to normals colors is to shutdown O an re-run it.
Attached Thumbnails
Click image for larger version

Name:	2014-02-01_OCPN_331328_S63_0.2_settings.jpg
Views:	109
Size:	79.8 KB
ID:	75120   Click image for larger version

Name:	2014-02-01_OCPN_331328_S63_0.2_Paper_chart.jpg
Views:	100
Size:	152.4 KB
ID:	75121  

Click image for larger version

Name:	2014-02-01_OCPN_331328_S63_0.2_Simplified.jpg
Views:	109
Size:	103.7 KB
ID:	75122   Click image for larger version

Name:	2014-02-01_OCPN_331328_S63_0.2_but_some_time_all_is_grey.jpg
Views:	94
Size:	125.3 KB
ID:	75126  

__________________
Gilletarom is offline   Reply With Quote
Old 02-02-2014, 03:54   #12
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: S63_PI Alpha Test 0.2.0

Dave

I had no problems with a fresh install on XP (no previous 0,1 version).
No luck on Kubuntu 64, even with a spanking new empty .opencpn directory.

Thomas
__________________
cagney is offline   Reply With Quote
Old 02-02-2014, 12:26   #13
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Alpha Test 0.2.0

WinXP, Win7 and Win8 are running.
Have seen some grey areas as well but those disappear when panning or zooming.

OS-X 10.9 installs and is running.

Hubert
__________________
bcn is offline   Reply With Quote
Old 02-02-2014, 12:57   #14
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Alpha Test 0.2.0

Dave,

a proposal:
right now the charts are decrypted and added to the eSENC "on-demand".

What about a batch process: "decrypt all not yet decrypted charts".
(one can go and have a beer and on return it's done)


Hubert
__________________
bcn is offline   Reply With Quote
Old 02-02-2014, 14:34   #15
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: S63_PI Alpha Test 0.2.0

Hello Dave,

Quote:
Originally Posted by bcn View Post
Dave,

a proposal:
...
What about a batch process: "decrypt all not yet decrypted charts".
(one can go and have a beer and on return it's done)

Hubert
Oh yes! Able to drink a beer quietly .... Very good idea ...

And if this could be the case for S57 also unencrypted. Because, for example, the chartss of the Netherlands, it is unpleasant to have to wait every time you change a chart view of the large number of charts for that country.

B.R. Gilletarom.
__________________

__________________
Gilletarom is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 04:23.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.