Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 23-05-2015, 19:06   #16
Registered User
 
Zmtndoc's Avatar

Join Date: Mar 2013
Location: Cairns
Boat: Mumby Cybercat 48
Posts: 18
Re: S63 PlugIn Version 1.0 Released

OK,

For other users that are not aware of the tricks and turns in this process -

I was looking for the InstallPermit within My Account window on o-charts.org site. Not there.

Go to the home page.

Look at the tiny text on the home page on the left lower corner. Click the InstallPermit hyperlink then upload the .fpr file and then the InstallPermit is displayed.

Tx
__________________

__________________
Zmtndoc is offline   Reply With Quote
Old 10-07-2015, 12:25   #17
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: S63 PlugIn Version 1.0 Released

I'm setting up my new laptop - 64 bit Intel with Kubuntu (and dual boot).
I found out that it' possible to install the 32 bit plugin version on my 64 bit. It seemingly worked ... but a lot of libraries were swapped for the 32 bit versions. The end result was a mess, with no graphical boot possible next time I tried to start the laptop, and a bit of repair-work necessary to sort things out.
It should not be possible to even try a stupid thing like this and imagine trying to troubleshoot a failed installation, in this forum, with a Linux beginner when she can't even boot (the normal way).
I think that a line like:
Quote:
Multi-Arch: no
in the packages control files would take care of the problem, but I have not tested this.

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Old 10-07-2015, 12:37   #18
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,758
Re: S63 PlugIn Version 1.0 Released

Thomas,

can you lodge an entry into Flyspray?
A 1.x version of the PI is in the pipeline so this issue should make it into it.

Hubert
__________________
bcn is offline   Reply With Quote
Old 10-07-2015, 12:37   #19
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: S63 PlugIn Version 1.0 Released

Thomas...
The multi-arch is intentional, we are trying to avoid having more binaries packaged inside the DEB.
You say that upon installation it removed the amd64 versions of the libraries frrm your system completely?

Pavel
__________________
nohal is offline   Reply With Quote
Old 10-07-2015, 15:04   #20
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: S63 PlugIn Version 1.0 Released

Pavel

Here is what went on:

Code:
Start-Date: 2015-07-10  14:44:26
Install: libedit2:i386 (3.1-20130712-2, automatic), libtinfo5:i386 (5.9+20140118-1ubuntu1, automatic), libxcb-dri2-0:i386 (1.10-2ubuntu1, automatic), gcc-4.8-base:i386 (4.8.4-2ubuntu1~14.04, a
utomatic), libxfixes3:i386 (5.0.1-1ubuntu1.1, automatic), libatk1.0-0:i386 (2.10.0-2ubuntu2, automatic), libjpeg-turbo8:i386 (1.3.0-0ubuntu2, automatic), libxau6:i386 (1.0.8-1, automatic), lib
pciaccess0:i386 (0.13.2-1, automatic), libgraphite2-3:i386 (1.2.4-1ubuntu1, automatic), libxext6:i386 (1.3.2-1ubuntu0.0.14.04.1, automatic), libice6:i386 (1.0.8-2, automatic), libgssapi-krb5-2
:i386 (1.12+dfsg-2ubuntu5.1, automatic), libx11-xcb1:i386 (1.6.2-1ubuntu2, automatic), libxi6:i386 (1.7.1.901-1ubuntu1.1, automatic), libpng12-0:i386 (1.2.50-1ubuntu2, automatic), libpango-1.0
-0:i386 (1.36.3-1ubuntu1.1, automatic), libdrm-intel1:i386 (2.4.60-2~ubuntu14.04.1, automatic), libxcursor1:i386 (1.1.14-1, automatic), libgl1-mesa-dri-lts-utopic:i386 (10.3.2-0ubuntu1~trusty2
, automatic), libkrb5-3:i386 (1.12+dfsg-2ubuntu5.1, automatic), libnih-dbus1:i386 (1.0.3-4ubuntu25, automatic), libllvm3.5:i386 (3.5-4ubuntu2~trusty2, automatic), libgl1-mesa-glx-lts-utopic:i3
86 (10.3.2-0ubuntu1~trusty2, automatic), libfontconfig1:i386 (2.11.0-0ubuntu4.1, automatic), libsm6:i386 (1.2.1-2, automatic), libcups2:i386 (1.7.2-0ubuntu1.6, automatic), libtiff5:i386 (4.0.3
-7ubuntu0.3, automatic), libcomerr2:i386 (1.42.9-3ubuntu1.2, automatic), libselinux1:i386 (2.2.2-1ubuntu0.1, automatic), libdrm-radeon1:i386 (2.4.60-2~ubuntu14.04.1, automatic), libfreetype6:i
386 (2.5.2-1ubuntu2.4, automatic), libxcb1:i386 (1.10-2ubuntu1, automatic), libcgmanager0:i386 (0.24-0ubuntu7.3, automatic), libgcc1:i386 (4.9.1-0ubuntu1, automatic), libpangocairo-1.0-0:i386 
(1.36.3-1ubuntu1.1, automatic), libc6:i386 (2.19-0ubuntu6.6), libglib2.0-0:i386 (2.40.2-0ubuntu1, automatic), libuuid1:i386 (2.20.1-5.1ubuntu20.4, automatic), libtxc-dxtn-s2tc0:i386 (0~git2013
1104-1.1, automatic), libxcb-render0:i386 (1.10-2ubuntu1, automatic), libnih1:i386 (1.0.3-4ubuntu25, automatic), libxrender1:i386 (0.9.8-1build0.14.04.1, automatic), libdbus-1-3:i386 (1.6.18-0
ubuntu4.3, automatic), libthai0:i386 (0.1.20-3, automatic), liblzma5:i386 (5.1.1alpha+20120614-2ubuntu2, automatic), libharfbuzz0b:i386 (0.9.27-1ubuntu1, automatic), libpixman-1-0:i386 (0.30.2
-2ubuntu1, automatic), libpangoft2-1.0-0:i386 (1.36.3-1ubuntu1.1, automatic), libwxbase2.8-0:i386 (2.8.12.1+dfsg-2ubuntu2, automatic), libcairo2:i386 (1.13.0~20140204-0ubuntu1.1, automatic), l
ibxcb-glx0:i386 (1.10-2ubuntu1, automatic), libudev1:i386 (204-5ubuntu20.12, automatic), libavahi-common-data:i386 (0.6.31-4ubuntu1, automatic), libxdmcp6:i386 (1.1.1-1, automatic), libavahi-c
lient3:i386 (0.6.31-4ubuntu1, automatic), libxcb-sync1:i386 (1.10-2ubuntu1, automatic), libjasper1:i386 (1.900.1-14ubuntu3.2, automatic), libp11-kit0:i386 (0.20.2-2ubuntu2, automatic), libgtk2
.0-0:i386 (2.24.23-0ubuntu1.2, automatic), libdrm-nouveau2:i386 (2.4.60-2~ubuntu14.04.1, automatic), libxcb-shm0:i386 (1.10-2ubuntu1, automatic), libgnutls26:i386 (2.12.23-12ubuntu2.2, automat
ic), libavahi-common3:i386 (0.6.31-4ubuntu1, automatic), libglapi-mesa-lts-utopic:i386 (10.3.2-0ubuntu1~trusty2, automatic), libgpg-error0:i386 (1.12-0.2ubuntu1, automatic), libxinerama1:i386 
(1.1.3-1, automatic), libgdk-pixbuf2.0-0:i386 (2.30.7-0ubuntu1, automatic), zlib1g:i386 (1.2.8.dfsg-1ubuntu1, automatic), libxcomposite1:i386 (0.4.4-1, automatic), libxdamage1:i386 (1.1.4-1ubu
ntu1, automatic), libxxf86vm1:i386 (1.1.3-1, automatic), libexpat1:i386 (2.1.0-4ubuntu1, automatic), libjbig0:i386 (2.0-2ubuntu4.1, automatic), libelf1:i386 (0.158-0ubuntu5.2, automatic), libx
cb-dri3-0:i386 (1.10-2ubuntu1, automatic), libxcb-present0:i386 (1.10-2ubuntu1, automatic), libdatrie1:i386 (0.2.8-1, automatic), libtasn1-6:i386 (3.4-3ubuntu0.3, automatic), libstdc++6:i386 (
4.8.4-2ubuntu1~14.04, automatic), libpcre3:i386 (8.31-2ubuntu2, automatic), libdrm2:i386 (2.4.60-2~ubuntu14.04.1, automatic), libkeyutils1:i386 (1.5.6-1, automatic), libx11-6:i386 (1.6.2-1ubun
tu2, automatic), libxrandr2:i386 (1.4.2-1, automatic), libglu1-mesa:i386 (9.0.0-2), libkrb5support0:i386 (1.12+dfsg-2ubuntu5.1, automatic), libk5crypto3:i386 (1.12+dfsg-2ubuntu5.1, automatic),
 libgcrypt11:i386 (1.5.3-2ubuntu4.2, automatic), gcc-4.9-base:i386 (4.9.1-0ubuntu1, automatic), libxshmfence1:i386 (1.1-2, automatic), libffi6:i386 (3.1~rc1+r3.0.13-12, automatic), libwxgtk2.8
-0:i386 (2.8.12.1+dfsg-2ubuntu2), libjpeg8:i386 (8c-2ubuntu8, automatic)
Remove: xserver-xorg-video-vesa-lts-utopic:amd64 (2.3.3-1build2~trusty1), xserver-xorg-video-siliconmotion-lts-utopic:amd64 (1.7.7-2build2~trusty1), libxatracker2-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), xserver-xorg-input-wacom-lts-utopic:amd64 (0.25.0-0ubuntu1~trusty1), xserver-xorg-video-nouveau-lts-utopic:amd64 (1.0.11-1ubuntu2~trusty1), xserver-xorg-video-openchrome-lts-utopic:amd64 (0.3.3-1build2~trusty1), xserver-xorg-video-modesetting-lts-utopic:amd64 (0.9.0-1build1~trusty1), libgbm1-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), xserver-xorg-video-intel-lts-utopic:amd64 (2.99.914-1~exp1ubuntu4.3~trusty1), xserver-xorg-video-sisusb-lts-utopic:amd64 (0.9.6-2build2~trusty1), libgl1-mesa-dri-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), libopenvg1-mesa-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), libgl1-mesa-glx-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), xserver-xorg-input-mouse-lts-utopic:amd64 (1.9.0-1build2~trusty1), xserver-xorg-video-vmware-lts-utopic:amd64 (13.0.2-3ubuntu1~trusty1), xserver-xorg-core-lts-utopic:amd64 (1.16.0-1ubuntu1.2~trusty2), xserver-xorg-video-r128-lts-utopic:amd64 (6.9.2-1build2~trusty1), libgles1-mesa-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), xserver-xorg-lts-utopic:amd64 (7.7+7ubuntu2~trusty1), xserver-xorg-input-synaptics-lts-utopic:amd64 (1.8.1-1ubuntu1~trusty1), xserver-xorg-video-mach64-lts-utopic:amd64 (6.9.4-2~trusty1), xserver-xorg-video-all-lts-utopic:amd64 (7.7+7ubuntu2~trusty1), xserver-xorg-video-cirrus-lts-utopic:amd64 (1.5.2-2build1~trusty1), xserver-xorg-video-radeon-lts-utopic:amd64 (7.4.0-2ubuntu2~trusty1), xserver-xorg-video-mga-lts-utopic:amd64 (1.6.3-2build1~trusty1), xserver-xorg-video-trident-lts-utopic:amd64 (1.3.6-0ubuntu6~trusty1), xserver-xorg-video-fbdev-lts-utopic:amd64 (0.4.4-1build2~trusty1), xserver-xorg-video-tdfx-lts-utopic:amd64 (1.4.5-1build2~trusty1), libglapi-mesa-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), xserver-xorg-video-ati-lts-utopic:amd64 (7.4.0-2ubuntu2~trusty1), libwayland-egl1-mesa-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), xserver-xorg-input-all-lts-utopic:amd64 (7.7+7ubuntu2~trusty1), xserver-xorg-video-neomagic-lts-utopic:amd64 (1.2.8-1build2~trusty1), xserver-xorg-video-savage-lts-utopic:amd64 (2.3.7-2ubuntu3~trusty1), libegl1-mesa-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), xserver-xorg-input-vmmouse-lts-utopic:amd64 (13.0.0-1build2~trusty1), libegl1-mesa-drivers-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2), xserver-xorg-input-evdev-lts-utopic:amd64 (2.9.0-1ubuntu2~trusty1), libgles2-mesa-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
:

The "repair" looked like this
Code:
Start-Date: 2015-07-10  18:48:48
Commandline: apt-get upgrade -f
Install: xserver-xorg-video-vmware:amd64 (13.0.2-2ubuntu1, automatic), xserver-xorg-video-siliconmotion:amd64 (1.7.7-2build1, automatic), libegl1-mesa:amd64 (10.1.3-0ubuntu0.4, automatic), libopenvg1-mesa:amd64 (10.1.3-0ubuntu0.4, automatic), libegl1-mesa-drivers:amd64 (10.1.3-0ubuntu0.4, automatic), xserver-xorg-video-sisusb:amd64 (0.9.6-2build1, automatic), xserver-xorg-video-savage:amd64 (2.3.7-2ubuntu2, automatic), xserver-xorg-input-all:amd64 (7.7+1ubuntu8.1, automatic), xserver-xorg-input-wacom:amd64 (0.23.0-0ubuntu2, automatic), xserver-xorg-video-glamoregl:amd64 (0.6.0-0ubuntu4, automatic), libllvm3.4:amd64 (3.4-1ubuntu3, automatic), libllvm3.4:i386 (3.4-1ubuntu3, automatic), libgl1-mesa-dri:amd64 (10.1.3-0ubuntu0.4, automatic), libgl1-mesa-dri:i386 (10.1.3-0ubuntu0.4, automatic), xserver-xorg-video-neomagic:amd64 (1.2.8-1build1, automatic), xserver-xorg-input-synaptics:amd64 (1.7.4-0ubuntu1, automatic), xserver-xorg-input-evdev:amd64 (2.8.2-1ubuntu2, automatic), xserver-xorg-core:amd64 (1.15.1-0ubuntu2.7, automatic), libglapi-mesa:amd64 (10.1.3-0ubuntu0.4, automatic), libglapi-mesa:i386 (10.1.3-0ubuntu0.4, automatic), xserver-xorg-input-mouse:amd64 (1.9.0-1build1, automatic), xserver-xorg-video-vesa:amd64 (2.3.3-1build1, automatic), xserver-xorg-video-cirrus:amd64 (1.5.2-1build1, automatic), xserver-xorg-video-all:amd64 (7.7+1ubuntu8.1, automatic), libspice-server1:amd64 (0.12.4-0nocelt2ubuntu1, automatic), xserver-xorg-video-qxl:amd64 (0.1.1-0ubuntu3, automatic), libgles2-mesa:amd64 (10.1.3-0ubuntu0.4, automatic), libgl1-mesa-glx:amd64 (10.1.3-0ubuntu0.4, automatic), libgl1-mesa-glx:i386 (10.1.3-0ubuntu0.4, automatic), libxatracker2:amd64 (10.1.3-0ubuntu0.4, automatic), xserver-xorg-video-intel:amd64 (2.99.910-0ubuntu1.6, automatic), xserver-xorg-video-ati:amd64 (7.3.0-1ubuntu3.1, automatic), libglamor0:amd64 (0.6.0-0ubuntu4, automatic), xserver-xorg-video-mach64:amd64 (6.9.4-1build1, automatic), xserver-xorg-video-tdfx:amd64 (1.4.5-1build1, automatic), xserver-xorg-video-fbdev:amd64 (0.4.4-1build1, automatic), libwayland-egl1-mesa:amd64 (10.1.3-0ubuntu0.4, automatic), xserver-xorg-video-trident:amd64 (1.3.6-0ubuntu5, automatic), xserver-xorg-video-openchrome:amd64 (0.3.3-1build1, automatic), xserver-xorg:amd64 (7.7+1ubuntu8.1, automatic), xserver-xorg-input-vmmouse:amd64 (13.0.0-1build1, automatic), xserver-xorg-video-radeon:amd64 (7.3.0-1ubuntu3.1, automatic), xserver-xorg-video-sis:amd64 (0.10.7-0ubuntu6, automatic), xserver-xorg-video-s3:amd64 (0.6.5-0ubuntu4, automatic), xserver-xorg-video-modesetting:amd64 (0.8.1-1build1, automatic), xserver-xorg-video-r128:amd64 (6.9.2-1build1, automatic), xserver-xorg-video-mga:amd64 (1.6.3-1build1, automatic), xserver-xorg-video-nouveau:amd64 (1.0.10-1ubuntu2, automatic)
Upgrade: libnss3-nssdb:amd64 (3.17.4-0ubuntu0.14.04.1, 3.19.2-0ubuntu0.14.04.1), libnss3:amd64 (3.17.4-0ubuntu0.14.04.1, 3.19.2-0ubuntu0.14.04.1)
Remove: libgl1-mesa-glx-lts-utopic:i386 (10.3.2-0ubuntu1~trusty2), libglapi-mesa-lts-utopic:i386 (10.3.2-0ubuntu1~trusty2)
End-Date: 2015-07-10  18:50:32

Start-Date: 2015-07-10  18:58:58
Commandline: /usr/sbin/synaptic
Purge: s63_pi:i386 (1.0.0)
End-Date: 2015-07-10  18:59:03
/Thomas
__________________

__________________
cagney is offline   Reply With Quote
Reply

Tags
lease, plug

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Convert s63/s57 to raster Storkur OpenCPN 17 18-09-2014 13:12
Git build, problems with plugins (s63, climatology) jfburkhart OpenCPN 1 19-07-2014 00:49
Garmin Radar PlugIn Version 1.4 Released bdbcat OpenCPN 8 20-06-2014 18:03
Open CPN - ROT & S63 charts Quidnunc OpenCPN 9 13-05-2013 19:16
S63 User Permits BjarneK Navigation 3 24-01-2012 19:21



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 15:52.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.