Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-07-2010, 06:20   #1
Registered User

Join Date: Jul 2010
Posts: 4
S-57 Rendering Problem

Is openCPN completely supporting S-57 charts?

I try to import some s-57 data into openCPN and they look like
.

Comapred to other viewer


Or did I miss some configuration?

thanks
__________________

__________________
twal is offline   Reply With Quote
Old 06-07-2010, 07:33   #2
Senior Cruiser
 
sailorF54's Avatar

Cruisers Forum Supporter

Join Date: Dec 2009
Location: Perros-Guirec, France
Boat: Jeanneau Sunshine 36
Posts: 833
Have you tried hitting the larger scale chart available (dark green bar at left of pale green one at bottom)
Press the A+ button to display labels.
Untick the M_Qual line on Mariners' Standard list to get rid of the ubiquitous U symbol
Is the S-57 chart you display freely available, so that we can try ?
US S-57 charts render (almost ) perfectly....
__________________

__________________
sailorF54 is offline   Reply With Quote
Old 06-07-2010, 08:41   #3
Registered User

Join Date: Jul 2010
Posts: 4
You are right! openCPN works perfectly!! almost :P

I just missed the scale (green) bar at bottom. Since in a region I have different S-57 files for different scales.

Is it possible to let openCPN render "proper" maps according to the current coordination with current scale value?

I must manually select a detailed map (via green bar) when I zoom in some region to get a detailed view, while zooming out, openCPN will eventually select the overview map (but with strange transition).
__________________
twal is offline   Reply With Quote
Old 06-07-2010, 09:41   #4
Senior Cruiser
 
sailorF54's Avatar

Cruisers Forum Supporter

Join Date: Dec 2009
Location: Perros-Guirec, France
Boat: Jeanneau Sunshine 36
Posts: 833
I'm not sure if I get you right, but have you enabled 'quilting' (toolbox, Settings). You should have seamless coverage at all scales...
__________________
sailorF54 is offline   Reply With Quote
Old 06-07-2010, 14:00   #5
Registered User

Join Date: Jul 2010
Posts: 4
Quote:
Originally Posted by sailorF54 View Post
I'm not sure if I get you right, but have you enabled 'quilting' (toolbox, Settings). You should have seamless coverage at all scales...
yes, I have tried enabling chart quilting. But openCPN will take too much time to reload chart files for every map zooming/panning.
__________________
twal is offline   Reply With Quote
Old 06-07-2010, 14:06   #6
Senior Cruiser
 
sailorF54's Avatar

Cruisers Forum Supporter

Join Date: Dec 2009
Location: Perros-Guirec, France
Boat: Jeanneau Sunshine 36
Posts: 833
Last resort: try deselecting 'Show chart outlines' if it is on. This often speeds things up...
__________________

__________________
sailorF54 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery-Charging Regulator Problem ? MasterVolt Problem ? RJV Electrical: Batteries, Generators & Solar 18 06-11-2011 23:53
C-Map / GPS Problem TOM Navigation 21 14-03-2011 05:55
Comparison of Chart Rendering in Various Nav Programs JesperWe Navigation 21 14-02-2010 09:01
VHF Tx problem JusDreaming Marine Electronics 2 26-07-2008 07:44
trying to fix problem MacPepper Electrical: Batteries, Generators & Solar 16 26-05-2008 04:39



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:04.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.