Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 15-05-2016, 09:37   #1
Registered User

Join Date: Sep 2015
Posts: 9
RPI2, opencpn and language

Hello,
I can't configurate OPENCPN 4.2 in french (or any other language, except english).
In "user interface", "language", when I choose any language, no change. English remains
configuration: RPI2 with Jessie (in french)
opencpn source: github.com/OpenCPN/OpenCPN.git

What's wrong?
Thanks for help

François
__________________

__________________
Douz is offline   Reply With Quote
Old 15-05-2016, 15:07   #2
Registered User

Join Date: Oct 2014
Location: Netherlands
Boat: Halmatic 30
Posts: 403
Re: RPI2, opencpn and language

The French language is missing. The easy way is to install locales-all. Then you get all the other languages en you can cerainly choose the French language in OpenCPN.

I have not tried the French language but the Dutch (Pay Bas) language works this way.

Bram
__________________

__________________
verkerkbr is offline   Reply With Quote
Old 15-05-2016, 15:33   #3
Registered User

Join Date: Sep 2015
Posts: 9
Re: RPI2, opencpn and language

Thank you for your answer.
Unfortunatly, it doesn't work :-(
__________________
Douz is offline   Reply With Quote
Old 16-05-2016, 00:38   #4
Registered User

Join Date: Oct 2014
Location: Netherlands
Boat: Halmatic 30
Posts: 403
Re: RPI2, opencpn and language

Allo Douz,

just changed the Dutch Language for the French.

sudo apt-get update (list of the latest files)

sudo apt-get upgrade (latest updates)

sudo apt-get install locales-all or use Synaptic (find locales-all)

Then change the language in OpenCPN to Francois or other french languages.

Then a restart and you have the French language.

Bonjour,

Bram
__________________
verkerkbr is offline   Reply With Quote
Old 16-05-2016, 01:23   #5
Registered User

Join Date: Sep 2015
Posts: 9
Re: RPI2, opencpn and language

Thank you Bram.
I'm afraid I'm totally idiot. I have done what you said and no progress...

It's really strange:
In "user interface", I do "Francais" and "Apply". No change,then I restart as I'm invited to do. English spoken.
Then I redo "user interface" and "Dutch" (for example) "Apply". Then some words are in french...amazing, isn'it?
But when I restart, it returns in English, as usual...
__________________
Douz is offline   Reply With Quote
Old 16-05-2016, 01:42   #6
Registered User

Join Date: Oct 2014
Location: Netherlands
Boat: Halmatic 30
Posts: 403
Re: RPI2, opencpn and language

Allo Douz,

i'am also using Debian Jessie with the OpenPlotter image.Which works great.

Perhaps there is something wrong with the OpenCPN settings.

I'am not sure this helps, but you can try it.

Remove ./opencpn folder and do a repeat of the settings in O.. Ctl-H shows the ./ files.

Bram
__________________
verkerkbr is offline   Reply With Quote
Old 16-05-2016, 01:47   #7
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: RPI2, opencpn and language

Quote:
Originally Posted by Douz View Post
Thank you Bram.
I'm afraid I'm totally idiot. I have done what you said and no progress...

It's really strange:
In "user interface", I do "Francais" and "Apply". No change,then I restart as I'm invited to do. English spoken.
Then I redo "user interface" and "Dutch" (for example) "Apply". Then some words are in french...amazing, isn'it?
But when I restart, it returns in English, as usual...
Normally on ubuntu when installed from PPA your opencpn filer is located /usr/share/opencpn/
/usr/lib/opencpn

The reason is that when compiling yourself versus installing from PPA, the file location of opencpn files is different. You will have to locate where your filea are and adjust paths to find the language files. ( or maybe move files to the location above)
__________________
petter5 is offline   Reply With Quote
Old 16-05-2016, 11:26   #8
Registered User

Join Date: Sep 2015
Posts: 9
Re: RPI2, opencpn and language

YESSS !!!
Thank you guys !!
I have just copy the file opencpn.mo which was in /usr/local/share/locale/fr/LC_MESSAGES in the folder: /usr/share/locale/fr/LC_MESSAGES
It's in french now !
Un grand merci

François
__________________

__________________
Douz is offline   Reply With Quote
Reply

Tags
enc, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RPI2, opencpn and language Douz Meets & Greets 1 16-05-2016 12:25
OPENCPN on RPI2 and the Chartdldr plugin AlaskamanUSCG OpenCPN 23 01-10-2015 10:33
OpenCPN, RPI2 and SPI screen Douz OpenCPN 2 26-09-2015 12:13
OpenCPN, Dasboard, file language Gilletarom OpenCPN 0 30-12-2012 02:11
OpenCPN / Mac OS X 10.5.8 problems with language ChannelIslander OpenCPN 0 18-12-2011 12:00



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 11:37.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.