Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 28-07-2011, 02:08   #1
Registered User

Join Date: Mar 2011
Posts: 8
Problem with Anchor Alarm in Ubuntu 11.04

Hello,

I have a problem with the anchor alarm in opencpn 2.5. When the alarm is running, no sound is coming out. Do you have an idea ? I'm using Ubuntu 11.04.
__________________

__________________
vince7887 is offline   Reply With Quote
Old 28-07-2011, 09:15   #2
Registered User

Join Date: Feb 2010
Posts: 4
Re: Problem with Anchor Alarm in Ubuntu 11.04

I have the same exact problem. other apps do produce Sound. Thanks
__________________

__________________
jcividan is offline   Reply With Quote
Old 28-07-2011, 09:25   #3
cat herder, extreme blacksheep
 
zeehag's Avatar

Cruisers Forum Supporter

Join Date: Jul 2008
Location: furycame alley , tropics, mexico for now
Boat: 1976 FORMOSA yankee clipper 41
Posts: 17,775
Images: 56
Send a message via Yahoo to zeehag Send a message via Skype™ to zeehag
Re: Problem with Anchor Alarm in Ubuntu 11.04

wow--folks can drag anchor and watch the lappy at same time>?? who is resetting anchor?? what are you gonna hit??? what is wrong with eyeballs doing the anchor watch??
zeehag is offline   Reply With Quote
Old 28-07-2011, 09:30   #4
Registered User

Join Date: Feb 2010
Posts: 4
The problem is with AIS ALARMS they do not sound either.
__________________
jcividan is offline   Reply With Quote
Old 28-07-2011, 11:17   #5
Registered User

Join Date: Mar 2011
Posts: 8
Re: Problem with Anchor Alarm in Ubuntu 11.04

Nobody has an solution?
__________________
vince7887 is offline   Reply With Quote
Old 29-07-2011, 03:48   #6
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almerķa, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Re: Problem with Anchor Alarm in Ubuntu 11.04

This is most likely a problem with the ubuntu sound architecture.. haven't found a solution yet :P
__________________
sv Libertalia
idpnd is offline   Reply With Quote
Old 30-07-2011, 11:17   #7
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: Problem with Anchor Alarm in Ubuntu 11.04

This problem has buggered me to, so now was the time to do some digging.
OpenCPN uses "wxSound" that is based on Linux old sound standard OSS.

As from Ubuntu 10.10 the support for OSS is no longer compiled into the kernel.
Ubuntu even goes as far as to blacklist the oss kernel drivers in/etc/modprobe.d/alsa-base.conf, so no use installing the "oss-compat" package.

The Good News is that a simple workaround is available. Pulseaudio, supports OSS emulation with an app called "padsp", so instead of starting OpenCPN

Code:
$opencpn
use
Code:
$padsp opencpn
If you use to click an icon, change the link for the icon.
Tested on Ubuntu 11.04 64bit ans 10.10 32 bit.

Use this workaround, for now. I expect a more permanent solution down the line.

Thomas
__________________
cagney is offline   Reply With Quote
Old 30-07-2011, 17:38   #8
Registered User

Join Date: Feb 2010
Posts: 4
Yes it works!!

Thank you very much
__________________
jcividan is offline   Reply With Quote
Old 07-08-2011, 01:43   #9
Registered User

Join Date: Mar 2011
Posts: 8
Re: Problem with Anchor Alarm in Ubuntu 11.04

Hello cagney,

Thank you so much to give us a bit of you time for resolving this problem. But for me your answer doesn't work. When I type in a terminal the line code ($padsp opencpn), the program starts normally, but the anchor alarm doesn't sound more (?). And, in the terminal i can read this message : (opencpn:1970): Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

Can I do something ? This fonction of anchor alarm would be helpful for me.

I use Ubuntu 11.04 (64 bits) and opencpn 2.5.0

Thank you for all,

Vincent
__________________
vince7887 is offline   Reply With Quote
Old 07-08-2011, 04:11   #10
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: Problem with Anchor Alarm in Ubuntu 11.04

Quote:
Originally Posted by vince7887 View Post
Hello cagney,

Thank you so much to give us a bit of you time for resolving this problem. But for me your answer doesn't work. When I type in a terminal the line code ($padsp opencpn), the program starts normally, but the anchor alarm doesn't sound more (?). And, in the terminal i can read this message : (opencpn:1970): Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

Can I do something ? This fonction of anchor alarm would be helpful for me.

I use Ubuntu 11.04 (64 bits) and opencpn 2.5.0

Thank you for all,

Vincent
I have the same set up as you - Ubuntu 11.04 (64 bits) and opencpn 2.5.0. I get the anchor alarm OK, but then I run into other problems.
See OpenCPN Version 2.5 Release
The solution to this is clearly to use ALSA instead of OSS i OpenCPN.
I'm sure it will be fixed that way, now that it's obvious that the presently used Wx-widgets coding isn't enough.

Thomas
__________________
cagney is offline   Reply With Quote
Old 07-08-2011, 04:35   #11
Registered User

Join Date: Mar 2011
Posts: 8
Re: Problem with Anchor Alarm in Ubuntu 11.04

I'm not sure to follow you. What is " Wx-widgets" ? Where can i switch for using "Alsa" instead Oss ? in the soud control panel of ubuntu ?

I'm using a eee pc 1001 px. The sound is working perfectly with others apps. I'm making a mistake in the procedure that you describe ?

Thank's for your help.

Vincent
__________________
vince7887 is offline   Reply With Quote
Old 07-08-2011, 04:49   #12
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: Problem with Anchor Alarm in Ubuntu 11.04

Quote:
Originally Posted by vince7887 View Post
I'm not sure to follow you. What is " Wx-widgets" ? Where can i switch for using "Alsa" instead Oss ? in the soud control panel of ubuntu ?

I'm using a eee pc 1001 px. The sound is working perfectly with others apps. I'm making a mistake in the procedure that you describe ?

Thank's for your help.

Vincent
No error from your side, and nothing you can do.

( Experienced Linux users that are up to recompiling the Linux kernel, can fix this, see, OpenCPN Version 2.5 Release )

This must be fixed by the programmers. It is a bug in OpenCPN.

Thomas
__________________
cagney is offline   Reply With Quote
Old 10-08-2011, 04:23   #13
Registered User

Join Date: Aug 2011
Posts: 1
Re: Problem with Anchor Alarm in Ubuntu 11.04

Quote:
Originally Posted by vince7887 View Post
Hello cagney,

Thank you so much to give us a bit of you time for resolving this problem. But for me your answer doesn't work. When I type in a terminal the line code ($padsp opencpn), the program starts normally, but the anchor alarm doesn't sound more (?). And, in the terminal i can read this message : (opencpn:1970): Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

Can I do something ? This fonction of anchor alarm would be helpful for me.

I use Ubuntu 11.04 (64 bits) and opencpn 2.5.0

Thank you for all,

Vincent
Hi, I think you should skip the $ sign before padsp, it is meant to show the prompt only.
So just type:

padsp opencpn

In a terminal window.

(technically, using a dollar sign calls for the variable padsp which is empty so the effect is like just typing "opencpn")
__________________
lboc is offline   Reply With Quote
Old 11-08-2011, 19:02   #14
Obsfucator, Second Class
 
dacust's Avatar

Cruisers Forum Supporter

Join Date: Feb 2008
Location: Southeast USA.
Boat: 1982 Sea Ray SRV360
Posts: 1,743
Re: Problem with Anchor Alarm in Ubuntu 11.04

Quote:
Originally Posted by lboc View Post
Hi, I think you should skip the $ sign before padsp, it is meant to show the prompt only.
So just type:

padsp opencpn

In a terminal window.

(technically, using a dollar sign calls for the variable padsp which is empty so the effect is like just typing "opencpn")
That's a pretty good first post ya made there, lboc. Welcome to the forum.

-dan
dacust is offline   Reply With Quote
Old 12-08-2011, 01:15   #15
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almerķa, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Re: Problem with Anchor Alarm in Ubuntu 11.04

Quote:
padsp opencpn
Thanks Iboc - sadly doesnt work on this ubuntu machine, crashes sound..
__________________

__________________
sv Libertalia
idpnd is offline   Reply With Quote
Reply

Tags
alarm, anchor

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raytheon ST5000+ Problem Capt.Don Marine Electronics 13 21-10-2013 14:31
Computer Problem ... Salt and Moisture canucksailor Marine Electronics 7 08-07-2011 20:20
Problem Since 2.2.918 - Garmin Won't Work MarkJ OpenCPN 28 29-06-2011 18:40
Furuno Radar Problem - Help !! Greg4cocokai Marine Electronics 0 29-06-2011 01:43



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:15.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.