Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-01-2014, 10:39   #16
Registered User

Join Date: Aug 2013
Posts: 29
Re: Problem Installing Opencpn

Quote:
Originally Posted by cagney View Post
If you have problems with dependencies, use one of the methods that handles that automatically. Read the the manual page again.
Also be sure to pick a package that is compatible with 12.04.
https://launchpad.net/~opencpn/+archive/opencpn for stable 3.2.2 downloads.

Thomas
Thanks Thomas for your reply,

I went to Download OpenCPN | Official OpenCPN Homepage and clicked on Download OpenCPN 3.2.2 for 32 bits *Ubuntu 12.04

The Ubuntu Software Center opened and the message Cannot install 'libgl1-mesa-glx' appeared.

Is it a dependency problem? (I don't know what a dependency is).
How can I solve this problem?

Thierry
__________________

__________________
aneblanc is offline   Reply With Quote
Old 21-01-2014, 11:02   #17
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: Problem Installing Opencpn

Thierry

Looking around a bit it seems that this subject has up in he past.
I think that the problem is that the updates to 12.04, has renamed the package. A recompile should help ...
It seems worth trying the recipe from post #3 here ->
[SOLVED] Unable to install openCPN - libgl1-mesa-glx problem

So it's back to the launchpad link i my last post.

An alternative is to try the 12.04 package of beta 3.3.1304, it's very good and stable.


Link here:https://launchpad.net/~nohal/+archiv...cise1_i386.deb

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Old 21-01-2014, 11:13   #18
Registered User

Join Date: Aug 2013
Posts: 29
Re: Problem Installing Opencpn

Quote:
Originally Posted by cagney View Post
Thierry

Looking around a bit it seems that this subject has up in he past.
I think that the problem is that the updates to 12.04, has renamed the package. A recompile should help ...
It seems worth trying the recipe from post #3 here ->
[SOLVED] Unable to install openCPN - libgl1-mesa-glx problem



Thomas
Thanks for your patience with me, for finding the fix online and for your quick answer.

As far as I can see it works now

Cheers

Thierry
__________________
aneblanc is offline   Reply With Quote
Old 21-01-2014, 11:22   #19
Registered User

Join Date: Aug 2013
Posts: 29
Re: Problem Installing Opencpn

Or so I thought!

Following is the recipe I used and lower down new problems and OpenCPN just opened and closed again. And the terminal is kind of locked in a loop now.

Let me know what you think!

Thierry


thierry@thierry-Inspiron-910:~$ sudo add-apt-repository ppapencpn/opencpn
You are about to add the following PPA to your system:
A Chartplotter and GPS Navigation Software.

OpenCPN is a free software (GPLv2) project to create a concise chartplotter and navigation software for use as an underway or planning tool. OpenCPN is developed by a team of active sailors using real world conditions for program testing and refinement.
More info: https://launchpad.net/~opencpn/+archive/opencpn
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpz2RNxc/secring.gpg' created
gpg: keyring `/tmp/tmpz2RNxc/pubring.gpg' created
gpg: requesting key C865EB40 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpz2RNxc/trustdb.gpg: trustdb created
gpg: key C865EB40: public key "Launchpad PPA for OpenCPN" imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK
thierry@thierry-Inspiron-910:~$ sudo apt-get update
Get:1 Ubuntu security notices | Ubuntu precise-security Release.gpg [198 B]
Get:2 http://dl.google.com stable Release.gpg [198 B]
Get:3 Ubuntu security notices | Ubuntu precise-security Release [49.6 kB]
Hit http://dl.google.com stable Release.gpg
Get:4 Index of / precise Release.gpg [72 B]
Get:5 Index of / precise Release.gpg [316 B]
Hit Index of / precise Release.gpg
Get:6 Index of / precise-updates Release.gpg [198 B]
Hit Index of / precise-backports Release.gpg
Get:7 http://dl.google.com stable Release [1,338 B]
Hit Index of / precise Release
Get:8 Index of / precise-updates Release [49.6 kB]
Hit Index of / precise Release
Get:9 Index of / precise Release.gpg [489 B]
Get:10 Index of / precise Release [11.9 kB]
Hit The Opera .deb Repository stable Release.gpg
Hit http://dl.google.com stable Release
Get:11 Index of / precise Release [2,603 B]
Hit The Opera .deb Repository stable Release
Get:12 http://dl.google.com stable/main i386 Packages [464 B]
Get:13 Ubuntu security notices | Ubuntu precise-security/main Sources [96.7 kB]
Hit Index of / precise/main Sources
Ign http://dl.google.com stable/main TranslationIndex
Get:14 Index of / precise/main Sources [711 B]
Hit Index of / precise-backports Release
Hit Index of / precise/main i386 Packages
Ign Index of / precise/main TranslationIndex
Hit http://dl.google.com stable/main i386 Packages
Get:15 Index of / precise/main i386 Packages [1,142 B]
Hit Index of / precise/main Sources
Hit Index of / precise/restricted Sources
Get:16 Ubuntu security notices | Ubuntu precise-security/restricted Sources [2,494 B]
Get:17 Index of / precise/main i386 Packages [642 B]
Ign Index of / precise/main TranslationIndex
Hit Index of / precise/universe Sources
Hit Index of / precise/multiverse Sources
Hit Index of / precise/main i386 Packages
Hit Index of / precise/restricted i386 Packages
Hit Index of / precise/universe i386 Packages
Hit Index of / precise/multiverse i386 Packages
Hit Index of / precise/main TranslationIndex
Hit Index of / precise/multiverse TranslationIndex
Get:18 Ubuntu security notices | Ubuntu precise-security/universe Sources [30.5 kB]
Ign http://dl.google.com stable/main TranslationIndex
Hit The Opera .deb Repository stable/non-free i386 Packages
Ign Index of / precise/main TranslationIndex
Get:19 Ubuntu security notices | Ubuntu precise-security/multiverse Sources [1,797 B]
Hit Index of / precise/restricted TranslationIndex
Hit Index of / precise/universe TranslationIndex
Get:20 Index of / precise-updates/main Sources [448 kB]
Get:21 Ubuntu security notices | Ubuntu precise-security/main i386 Packages [377 kB]
Ign The Opera .deb Repository stable/non-free TranslationIndex
Get:22 Ubuntu security notices | Ubuntu precise-security/restricted i386 Packages [4,620 B]
Get:23 Ubuntu security notices | Ubuntu precise-security/universe i386 Packages [94.3 kB]
Get:24 Ubuntu security notices | Ubuntu precise-security/multiverse i386 Packages [2,650 B]
Get:25 Ubuntu security notices | Ubuntu precise-security/main TranslationIndex [74 B]
Get:26 Ubuntu security notices | Ubuntu precise-security/multiverse TranslationIndex [72 B]
Get:27 Ubuntu security notices | Ubuntu precise-security/restricted TranslationIndex [72 B]
Get:28 Ubuntu security notices | Ubuntu precise-security/universe TranslationIndex [73 B]
Get:29 Ubuntu security notices | Ubuntu precise-security/main Translation-en [168 kB]
Hit Ubuntu security notices | Ubuntu precise-security/multiverse Translation-en
Hit Ubuntu security notices | Ubuntu precise-security/restricted Translation-en
Ign Index of / precise/main Translation-en_CA
Get:30 Ubuntu security notices | Ubuntu precise-security/universe Translation-en [56.1 kB]
Ign Index of / precise/main Translation-en
Ign Index of / precise/main Translation-en_CA
Ign Index of / precise/main Translation-en
Get:31 Index of / precise-updates/restricted Sources [7,039 B]
Get:32 Index of / precise-updates/universe Sources [101 kB]
Get:33 Index of / precise-updates/multiverse Sources [8,486 B]
Get:34 Index of / precise-updates/main i386 Packages [768 kB]
Ign http://dl.google.com stable/main Translation-en_CA
Ign http://dl.google.com stable/main Translation-en
Ign http://dl.google.com stable/main Translation-en_CA
Ign http://dl.google.com stable/main Translation-en
Ign Index of / precise/main Translation-en_CA
Ign The Opera .deb Repository stable/non-free Translation-en_CA
Ign Index of / precise/main Translation-en
Ign The Opera .deb Repository stable/non-free Translation-en
Get:35 Index of / precise-updates/restricted i386 Packages [11.5 kB]
Get:36 Index of / precise-updates/universe i386 Packages [236 kB]
Get:37 Index of / precise-updates/multiverse i386 Packages [14.4 kB]
Get:38 Index of / precise-updates/main TranslationIndex [3,564 B]
Get:39 Index of / precise-updates/multiverse TranslationIndex [2,605 B]
Get:40 Index of / precise-updates/restricted TranslationIndex [2,461 B]
Get:41 Index of / precise-updates/universe TranslationIndex [2,850 B]
Hit Index of / precise-backports/main Sources
Hit Index of / precise-backports/restricted Sources
Hit Index of / precise-backports/universe Sources
Hit Index of / precise-backports/multiverse Sources
Hit Index of / precise-backports/main i386 Packages
Hit Index of / precise-backports/restricted i386 Packages
Hit Index of / precise-backports/universe i386 Packages
Hit Index of / precise-backports/multiverse i386 Packages
Hit Index of / precise-backports/main TranslationIndex
Hit Index of / precise-backports/multiverse TranslationIndex
Hit Index of / precise-backports/restricted TranslationIndex
Hit Index of / precise-backports/universe TranslationIndex
Hit Index of / precise/main Translation-en_CA
Hit Index of / precise/main Translation-en
Hit Index of / precise/multiverse Translation-en
Hit Index of / precise/restricted Translation-en
Hit Index of / precise/universe Translation-en_CA
Hit Index of / precise/universe Translation-en
Hit Index of / precise-updates/main Translation-en_CA
Get:42 Index of / precise-updates/main Translation-en [334 kB]
Hit Index of / precise-updates/multiverse Translation-en
Hit Index of / precise-updates/restricted Translation-en
Hit Index of / precise-updates/universe Translation-en_CA
Get:43 Index of / precise-updates/universe Translation-en [135 kB]
Hit Index of / precise-backports/main Translation-en
Hit Index of / precise-backports/multiverse Translation-en
Hit Index of / precise-backports/restricted Translation-en
Hit Index of / precise-backports/universe Translation-en
Fetched 3,029 kB in 8s (343 kB/s)
Reading package lists... Done
thierry@thierry-Inspiron-910:~$ sudo apt-get install opencpn
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
thunderbird-globalmenu linux-headers-3.2.0-55-generic gir1.2-ubuntuoneui-3.0 linux-headers-3.2.0-55
libubuntuoneui-3.0-1 linux-headers-3.5.0-23 linux-headers-3.5.0-23-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libtinyxml2.6.2 libwxbase2.8-0 libwxgtk2.8-0
Suggested packages:
libgnomeprintui2.2-0
The following NEW packages will be installed:
libtinyxml2.6.2 libwxbase2.8-0 libwxgtk2.8-0 opencpn
0 upgraded, 4 newly installed, 0 to remove and 7 not upgraded.
Need to get 38.3 MB of archives.
After this operation, 76.4 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 Index of /ubuntu precise/universe libwxbase2.8-0 i386 2.8.12.1-6ubuntu2 [597 kB]
Get:2 Index of /opencpn/opencpn/ubuntu precise/main opencpn i386 3.2.2-0~precise1 [34.4 MB]
Get:3 Index of /ubuntu precise/universe libwxgtk2.8-0 i386 2.8.12.1-6ubuntu2 [3,254 kB]
Get:4 Index of /ubuntu precise/universe libtinyxml2.6.2 i386 2.6.2-1build1 [35.7 kB]
Fetched 38.3 MB in 1min 1s (621 kB/s)
Selecting previously unselected package libwxbase2.8-0.
(Reading database ... 360470 files and directories currently installed.)
Unpacking libwxbase2.8-0 (from .../libwxbase2.8-0_2.8.12.1-6ubuntu2_i386.deb) ...
Selecting previously unselected package libwxgtk2.8-0.
Unpacking libwxgtk2.8-0 (from .../libwxgtk2.8-0_2.8.12.1-6ubuntu2_i386.deb) ...
Selecting previously unselected package libtinyxml2.6.2.
Unpacking libtinyxml2.6.2 (from .../libtinyxml2.6.2_2.6.2-1build1_i386.deb) ...
Selecting previously unselected package opencpn.
Unpacking opencpn (from .../opencpn_3.2.2-0~precise1_i386.deb) ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Setting up libwxbase2.8-0 (2.8.12.1-6ubuntu2) ...
Setting up libwxgtk2.8-0 (2.8.12.1-6ubuntu2) ...
Setting up libtinyxml2.6.2 (2.6.2-1build1) ...
Setting up opencpn (3.2.2-0~precise1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place




thierry@thierry-Inspiron-910:~$ opencpn
ALSA lib pcm.c:2217snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2217snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2217snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib audio/pcm_bluetooth.c:1614audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1614audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1614audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1614audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_dmix.c:957snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gdk-CRITICAL **: IA__gdk_window_get_width: assertion `GDK_IS_WINDOW (window)' failed

(opencpn:10314): Gdk-CRITICAL **: IA__gdk_window_get_height: assertion `GDK_IS_WINDOW (window)' failed

(opencpn:10314): Gdk-CRITICAL **: gdk_window_invalidate_rect_full: assertion `GDK_IS_WINDOW (window)' failed

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13

(opencpn:10314): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 13
__________________
aneblanc is offline   Reply With Quote
Old 21-01-2014, 11:30   #20
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: Problem Installing Opencpn

Thierry...
It seems like still running to me. What can we imagine as "opened and closed".
Isn't the window just minimized somewhere?
Anyway - press Ctrl-C to stop it.

Pavel
__________________
nohal is offline   Reply With Quote
Old 21-01-2014, 11:32   #21
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: Problem Installing Opencpn

All those command line warnings are not from OpenCPN, and usually quite harmless.
Please upload the "opencpn.log". It's in your home directory.

Thomas
__________________
cagney is offline   Reply With Quote
Old 21-01-2014, 12:04   #22
Registered User

Join Date: Aug 2013
Posts: 29
Re: Problem Installing Opencpn

14:09:47 AST:

________

14:09:47 AST: 2014-01-21
14:09:47 AST: ------- Starting OpenCPN -------
14:09:47 AST: Version 3.2.2 Build 2013-05-08
14:09:47 AST: wxWidgets version: wxWidgets 2.8.12
14:09:47 AST: MemoryStatus: mem_total: 992 mb, mem_initial: 57 mb
14:09:47 AST: SData_Locn is /usr/share/opencpn/
14:09:47 AST: Creating new Config_File: /home/thierry/.opencpn/opencpn.conf
14:09:48 AST: Styles loading from /usr/share/opencpn/uidata/styles.xml
14:09:48 AST: No styles found at: /home/thierry/
14:09:48 AST: No styles found at: /home/thierry/.opencpn/
14:09:48 AST: Setting Viewpoint Lat/Lon 33.358, -79.282
14:09:48 AST: Setting Ownship Lat/Lon 33.358, -79.282
14:09:48 AST: System default Language: en_CA
14:09:48 AST: Opencpn language set to: en_US
14:09:57 AST: ChartSymbols loaded from /usr/share/opencpn/s57data/chartsymbols.xml
14:09:58 AST: Using s57data in /usr/share/opencpn/s57data
14:09:58 AST: Setting Viewpoint Lat/Lon 33.358, -79.282
14:09:58 AST: Setting Ownship Lat/Lon 33.358, -79.282
14:09:59 AST: PlugInManager searching for PlugIns in location /usr/lib/opencpn
14:09:59 AST: PlugInManager: Loading PlugIn: /usr/lib/opencpn/libdashboard_pi.so
14:09:59 AST: /usr/lib/opencpn/libdashboard_pi.so Version detected: 106
14:09:59 AST: PlugInManager: Loading PlugIn: /usr/lib/opencpn/libgrib_pi.so
14:09:59 AST: /usr/lib/opencpn/libgrib_pi.so Version detected: 107
14:09:59 AST: ChartDB Cache policy: Max open chart limit is 20.
14:09:59 AST: Chartlist file not found, config chart dir array is empty. Chartlist target file is:/home/thierry/.opencpn/chartlist.dat
__________________
aneblanc is offline   Reply With Quote
Old 21-01-2014, 12:12   #23
Registered User

Join Date: Aug 2013
Posts: 29
Re: Problem Installing Opencpn

It's working now, THANKS

Thierry
__________________
aneblanc is offline   Reply With Quote
Old 21-01-2014, 13:55   #24
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: Problem Installing Opencpn

Quote:
Originally Posted by aneblanc View Post
It's working now, THANKS

Thierry
Well, that's great! Congratulations......
As Nohal said, there were no signs of OpenCPN not running. Not in the command line output, nor in the logfile.

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Reply

Tags
enc, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New IAC Fleetcode Plugin for OpenCPN CBorchardt OpenCPN 72 27-02-2016 12:42
Opencpn installation under Ubuntu 12.04 Idiens OpenCPN 8 29-05-2013 06:51
Problem with OpenCPN Windswept4 OpenCPN 8 18-11-2012 15:48
OpenCPN, Mapsource Chartpak Capt.Don OpenCPN 4 13-11-2011 09:24
Problem with OpenCPN 2.5.0 nixontankgirl OpenCPN 3 29-10-2011 13:59



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:49.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.