Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-01-2017, 19:34   #1
Registered User

Join Date: Sep 2010
Location: Canada
Boat: Nautlus 36 pilothouse
Posts: 15
PlugIn problem

I have downloaded the latest version Opencpn 4.4 for Mac OS. I acquired several plugins and opened each one, all appeared to upload properly. When I try to activate them they do not show up in "PLUGINS". They are in the right folder I think. The included plugins are in this folder. What am I doing wrong?
__________________

__________________
Ray & Dianna
S/V Opus 5
Campbell River, BC
Ray-Dianna is offline   Reply With Quote
Old 09-01-2017, 02:48   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,226
Re: PlugIn problem

Did you restart OpenCPN? May we have a look at your logfile? I see no such problem on my Mac.

Pavel
__________________

nohal is offline   Reply With Quote
Old 09-01-2017, 03:00   #3
Registered User

Join Date: Nov 2014
Location: Netherlands
Posts: 219
Re: PlugIn problem

Quote:
Originally Posted by Ray-Dianna View Post
They are in the right folder I think. The included plugins are in this folder.
What folder are you referring to?

Make sure that the new version is called OpenCPN in your Application forder.
The plugins are only installed in the application OpenCPN.
You can see if the plugin is installed by right clicking on the OpenCPN icon and select Show Package Contents.
Then go to PlugIns folder and see the plugins that are installed properly.
ptulp is offline   Reply With Quote
Old 09-01-2017, 03:16   #4
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 1,996
Re: PlugIn problem

I don't know why developers don't make an installer for the Mac version of OpenCPN but only for the plugins. This discrepancy often leads to problems for people new to the Mac OS.

Gerhard
CarCode is offline   Reply With Quote
Old 09-01-2017, 03:27   #5
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,532
Re: PlugIn problem

Ay Gerhard,

you have one, don't you?
And if we say "please", the magic word?

bcn is offline   Reply With Quote
Old 09-01-2017, 04:10   #6
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 1,996
Re: PlugIn problem

Quote:
Originally Posted by bcn View Post
Ay Gerhard,

you have one, don't you?
And if we say "please", the magic word?

Hubert
years ago I was able to help. Now I have my own very different version of OpenCPN and it doesn't help anymore. Some developers knows however that I once gave the hint how to make installers for Mac and they have done so for plugins but not for the main program.

Gerhard
CarCode is offline   Reply With Quote
Old 09-01-2017, 18:45   #7
Registered User

Join Date: Sep 2010
Location: Canada
Boat: Nautlus 36 pilothouse
Posts: 15
Re: PlugIn problem

Thanks to all who replied, a good read of the manual cleared up the issue and it is now running okay.
__________________
Ray & Dianna
S/V Opus 5
Campbell River, BC
Ray-Dianna is offline   Reply With Quote
Old 10-01-2017, 02:13   #8
Registered User

Join Date: Nov 2014
Location: Netherlands
Posts: 219
Re: PlugIn problem

Quote:
Originally Posted by bcn View Post
Ay Gerhard,

you have one, don't you?
And if we say "please", the magic word?

I noticed that in the latest download for OSX the installer window just displays the one OpenCPN icon, while Pavel submitted fix "Make the DMG look fancy" on 8 May 2016 that should show the OpenCPN icon together with an arrow and the Applications icon, making it a bit more clear that the OpenCPN should be moved to the Application folder.
Seems that this fix did not work for some reason.

Peter
ptulp is offline   Reply With Quote
Old 10-01-2017, 03:50   #9
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 1,996
Re: PlugIn problem

Keep in mind also that since Sierra the GateKeeper does not allow to install unknown software anymore. In the security settings there are only allowed downloads from the App Store or from certificated developers (signed software). It is possible to circumvent this safety setting however.

Gerhard
__________________

CarCode is offline   Reply With Quote
Reply

Tags
plug

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Navico Radar Plugin + heading problem Jonna OpenCPN 17 15-02-2018 23:54
S63 Plugin Problem Kudder OpenCPN 4 28-11-2015 08:37
BSB4 Plugin problem lake_fever OpenCPN 1 02-06-2015 21:47
SAR Plugin problem prof_mariner OpenCPN 0 09-02-2015 19:13
OpenCPN Plugin problem gknott OpenCPN 3 15-06-2012 12:36

Advertise Here


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 15:52.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×

ShowCase vBulletin Plugins by Drive Thru Online, Inc.