Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 24-10-2015, 11:48   #1
Registered User

Join Date: Oct 2010
Posts: 23
OpenCPN won't install under Ubuntu 15.10

I just did a fresh install of Ubuntu 15.10, then added the OpenCPN ppa and did the "apt-get update", but on install I get this message:

E: Package 'opencpn' has no installation candidate

Sure enough, in Synaptic, opencpn does not exist, although various opencpn plugins are available.

I have never had this problem with previous Ubuntu or Linux Mint versions.
__________________

__________________
zerubbabel is offline   Reply With Quote
Old 24-10-2015, 12:01   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: OpenCPN won't install under Ubuntu 15.10

The OpenCPN 4.0.0 package in the production PPA is still pending to be copied for 15.10.
Try again in a few hours or use 4.1.1022 from the beta PPA where the Wily packages are already available.

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 24-10-2015, 12:31   #3
Registered User

Join Date: Oct 2010
Posts: 23
Re: OpenCPN won't install under Ubuntu 15.10

Thank you!
__________________
zerubbabel is offline   Reply With Quote
Old 26-10-2015, 03:17   #4
Registered User

Join Date: Oct 2010
Posts: 23
Re: OpenCPN won't install under Ubuntu 15.10

Still doesn't install:

opencpn:
Depends: libtinyxml2.6.2 but it is not installable
Depends: libwxbase2.8-0 but it is not going to be installed
Depends: libwxgtk2.8-0 but it is not going to be installed
Depends: wx2.8-i18n but it is not going to be installed
Depends: opencpn-tcdata but it is not going to be installed
Depends: opencpn-gshhs-low but it is not going to be installed
Recommends: xcalib but it is not going to be installed
Recommends: opencpn-doc but it is not going to be installed
Recommends: opencpn-gshhs-crude but it is not going to be installed
Recommends: opencpn-gshhs-intermediate but it is not going to be installed
Recommends: opencpn-gshhs-high but it is not going to be installed
Recommends: opencpn-gshhs-full but it is not going to be installed
__________________
zerubbabel is offline   Reply With Quote
Old 12-11-2015, 18:59   #5
Registered User
 
Harryws's Avatar

Join Date: Nov 2008
Location: Canberra Australia
Boat: Adams Bluewater 42
Posts: 19
Images: 5
Send a message via Skype™ to Harryws
Re: OpenCPN won't install under Ubuntu 15.10

Any update on Opencpn install with Ubuntu 15.10?
__________________
All men dream....the dreamers of the day are dangerous for they may make their dreams reality (apologies T E Lawrence) www.malua.com.au
Harryws is offline   Reply With Quote
Old 12-11-2015, 19:06   #6
Registered User

Join Date: Oct 2010
Posts: 23
Re: OpenCPN won't install under Ubuntu 15.10

I'm running 4.1.1108 just fine now.
__________________
zerubbabel is offline   Reply With Quote
Old 12-11-2015, 20:00   #7
Registered User
 
Harryws's Avatar

Join Date: Nov 2008
Location: Canberra Australia
Boat: Adams Bluewater 42
Posts: 19
Images: 5
Send a message via Skype™ to Harryws
Re: OpenCPN won't install under Ubuntu 15.10

Great Thanks I downloaded and installed 4.1.1022 and it works fine. I cant do without it
__________________
All men dream....the dreamers of the day are dangerous for they may make their dreams reality (apologies T E Lawrence) www.malua.com.au
Harryws is offline   Reply With Quote
Old 01-03-2016, 04:56   #8
Registered User

Join Date: Feb 2016
Location: Tulsa Oklahoma
Posts: 2
Re: OpenCPN won't install under Ubuntu 15.10

I find myself in the same position as 'zerubbabel' - I've downloaded OpenCPN 4.2 on my Windows 10 machine and it works great, but cannot seem to load it on my Ubuntu 15.10 machine. I get the same message and find various plugins like the quote below.

I could not find the beta version 4.1.1022 (or any other beta versions on the OpenCPN.org web site.

Can you point me in the right direction, or give other guidance?

Quote:
Originally Posted by zerubbabel View Post
I just did a fresh install of Ubuntu 15.10, then added the OpenCPN ppa and did the "apt-get update", but on install I get this message:

E: Package 'opencpn' has no installation candidate

Sure enough, in Synaptic, opencpn does not exist, although various opencpn plugins are available.

I have never had this problem with previous Ubuntu or Linux Mint versions.
__________________
davcorsta is offline   Reply With Quote
Old 01-03-2016, 08:42   #9
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: OpenCPN won't install under Ubuntu 15.10

PPA 's for Opencpn 4.2 is still not yet in the official respiratory.

To install 4.2 under Ubuntu for now:
Code:
sudo add-apt-repository ppa.launchpad.net/nohal/opencpn/ubuntu
Code:
sudo apt-get update
Code:
sudo apt-get install opencpn
/Petter
__________________
petter5 is offline   Reply With Quote
Old 01-03-2016, 10:25   #10
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,769
Re: OpenCPN won't install under Ubuntu 15.10

Just a bit of patience..
Not talking about days
__________________
bcn is offline   Reply With Quote
Old 01-03-2016, 10:30   #11
Registered User

Join Date: Feb 2016
Location: Tulsa Oklahoma
Posts: 2
Re: OpenCPN won't install under Ubuntu 15.10

Petter,

Thanks for the guidance. I had to edit the first command to "sudo add-apt-repository ppa:nohal/opencpn" before my computer would actually add the repository. Once that was done everything went smoothly.

Thanks again for the help.

David
__________________
davcorsta is offline   Reply With Quote
Old 01-03-2016, 18:13   #12
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: OpenCPN won't install under Ubuntu 15.10

Hi all...
All the OpenCPN related packages associated with the 4.2 release have been pushed to the official stable PPA (ppapenpcn/opencpn) a couple of minutes ago.
The beta PPA (ppa:nohal/opencpn) will soon start to receive the bleeding edge stuff for the next development cycle so if you want to stay with the stable release, make sure to disable it.

Thanks for your patience and as usually please report any problems observed.

Pavel
__________________
nohal is offline   Reply With Quote
Old 01-03-2016, 23:25   #13
Registered User

Join Date: May 2010
Posts: 81
Re: OpenCPN won't install under Ubuntu 15.10

Hi Pavel,

Thank you very much for all your hard work. I will try it out on Xubuntu 15.10 tomorrow.

Cheers, ....Erik.
Home
__________________
ve7mdl is offline   Reply With Quote
Old 02-03-2016, 06:51   #14
Registered User
 
sy_gilana's Avatar

Join Date: Jan 2005
Location: On board
Boat: Van de Stadt 50'
Posts: 1,101
Send a message via Skype™ to sy_gilana
Plugin Issues?

@ Pavel. The update appeared on my Update Manager this AM, and I agreed.

Two things of concern, the Grib D/L window produces a file not readable error, see attachment.

1 Why is the PU trying to run Testdisk???

2 The "Thinking Pinwheel" (hourglass) keeps running after clicking any of the plugins.

Linux 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Attached Thumbnails
Click image for larger version

Name:	opencpnerror.jpg
Views:	45
Size:	40.3 KB
ID:	119907  
__________________
Tight sheets to ya.
http://gilana.org
sy_gilana is offline   Reply With Quote
Old 02-03-2016, 06:57   #15
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: OpenCPN won't install under Ubuntu 15.10

sy_gilana...
Maybe I missed something, but the file you are trying to open (testdisk-7.0.linux26-x86_64.tar.bz2) is definitely not a grib file - why do you think the grib plugin should open it and do anything with it's content but saying it can't do anything with it?

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Reply

Tags
enc, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install opencpn in Ubuntu 14 bhcva OpenCPN 3 03-06-2014 14:35
Opencpn installation under Ubuntu 12.04 Idiens OpenCPN 8 29-05-2013 06:51
How to Install OpenCPN on Ubuntu claire OpenCPN 3 01-11-2012 01:26
OpenCPN 3.0 won't install PDA1 OpenCPN 5 06-06-2012 07:39
Bluetooth GPS Setups Won't Stay in Ubuntu ? fyndi OpenCPN 6 03-11-2011 03:31



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 21:05.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.