Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 28-04-2012, 06:34   #61
Registered User
 
Rik-lu's Avatar

Join Date: May 2010
Location: Luxembourg
Boat: HR40
Posts: 196
Images: 2
Re: OpenCPN Version 2.6 Beta Build 1624

Quote:
Originally Posted by bdbcat View Post
Rik-Lu....

quote:
Code:
"go to toolbox / etc / tracks 
the descriptions  "seconds" and "distance " are missing   
(win7-64)"
May we have a screenshot? They look fine to me.....

Thanks
Dave
__
__________________

__________________
Hi from Rik
Rik-lu is offline   Reply With Quote
Old 28-04-2012, 11:56   #62
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: OpenCPN Version 2.6 Beta Build 1624

Quote:
Originally Posted by cagney View Post
Dave
Don't know, but I just started an upgrade to 12.04. Perhaps that will sort it out.

Thomas
Dave
No change with the upgrade. With the same problem on at least 3 different 64 bit systems, including win7, it smells like a more general 64 bit problem.

An interesting thing with my upgrade was that the old opencpn.conf created a segfault when using a version compiled with the new system. Attached below.

opencpn.conf.7z.doc

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Old 28-04-2012, 12:45   #63
Registered User
 
svpresent's Avatar

Join Date: Nov 2008
Location: At the moment in the Spanish Ria's
Boat: Reinke, 15m, Present
Posts: 105
Re: OpenCPN Version 2.6 Beta Build 1624

Dave,
Thanks for the great job.
Re. 207: Upload to my Furuno 33 failed. The Furuno 33 differs from the 30 and 32 with respect to upload syntax. I'll do some more testing and send you the spec's that work for the 33 using another program.

Cheers, Len.
__________________
svpresent is offline   Reply With Quote
Old 28-04-2012, 17:46   #64
Registered User

Join Date: Feb 2011
Posts: 490
Re: OpenCPN Version 2.6 Beta Build 1624

One problem I hav encounter in the version 2.6.1624 is that it return an error reading the:- ENC .txt files for many charts. Is this important for a correction?
Regards
P_dub
__________________
P_Dub is offline   Reply With Quote
Old 29-04-2012, 08:25   #65
Registered User

Join Date: Sep 2011
Posts: 205
Re: OpenCPN Version 2.6 Beta Build 1624

Hello Dave,

i have problems running the beta in Kubuntu 12.04.
maybe this happens in a virtual environment (VMWare, Oracle) only.

the toolbar-preferences dialog crashes when selecting the second (GPS)
or following tabs (+OK-button).

if select in Settings "Use OpenGL" +OK, then the toolbar disappears 'til
set in opencpn.conf OpenGL to false.

best regards,
konni
__________________
konni is offline   Reply With Quote
Old 29-04-2012, 08:38   #66
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Version 2.6 Beta Build 1624

Thomas....

64 bit problems.

I am going to have a hard time debugging this without a 64 bit reference system available.

Lets step back: Is there any previous version or Beta that worked correctly with your AMD64 setup?

Dave
__________________
bdbcat is offline   Reply With Quote
Old 29-04-2012, 09:14   #67
Registered User
 
LeaseOnLife's Avatar

Join Date: Apr 2008
Location: out cruising again
Boat: Sailboat
Posts: 1,046
Re: OpenCPN Version 2.6 Beta Build 1624

Sorry for a late response, we sailed from Miami to NC....


Quote:
Originally Posted by bdbcat View Post
Thomas/Dirk

multiple cm93 bug:
I see the problem. Workaround for now:

We need at least three files in this dir
/opt/navigation/Charts/CM93/Cm93 jan 2011/00900840/A

Note that I pulled this file name from Thomas's log. Dirk, yours will be similar. Show us your log if you can't find it.
I guess I need help.... Here is the log after adding a second cm93 dir, when opencpn hangs:
Code:
...
11:03:05: Searching directory: S:\CHARTS\VECTOR\CM93ED2\CM93ED2-201101 for 00300000.a
11:03:05: Found probable CM93 database in S:\CHARTS\VECTOR\CM93ED2\CM93ED2-201101
11:03:14: Loading chart data for S:\CHARTS\VECTOR\CM93ED2\CM93ED2-201101\00300000\A\00300000.A
11:03:14: CM93Composite Chart Root is S:\CHARTS\VECTOR\CM93ED2\CM93ED2-201101\
...
11:03:15: Searching directory: S:\CHARTS\VECTOR\CM93ED2\CM93ED2-2002 for 00300000.a
11:03:15: Found probable CM93 database in S:\CHARTS\VECTOR\CM93ED2\CM93ED2-2002
Quote:
There is only one file in that dir right now.
Second and third file name can be anything, and can be junk.

so,

Code:
$touch /opt/navigation/Charts/CM93/Cm93 jan 2011/00900840/A/junk1

$touch /opt/navigation/Charts/CM93/Cm93 jan 2011/00900840/A/junk2
Also need to do the same for the other two cm93 roots.

Root cause of problem: Fetching dir/file names iteratively in code depends on the order in which they were written to disk. Mine appear to be jumbled up, so no problem. Yours are nice and regular, so we have some trouble distinguishing among the three cm93 root dirs.
I created 2 junk empty text files (no touch command on winblows). my best guess, where to add two junk text files, is:
S:\CHARTS\VECTOR\CM93ED2\CM93ED2-2002\00300000\A

Now, OpenCPN doesn't hang anymore, but now I am getting the following error in the log:
Code:
11:09:45: Searching directory: S:\CHARTS\VECTOR\CM93ED2\CM93ED2-2002 for 00300000.a
11:09:45: Found probable CM93 database in S:\CHARTS\VECTOR\CM93ED2\CM93ED2-2002
11:09:49: Loading chart data for S:\CHARTS\VECTOR\CM93ED2\CM93ED2-2002\00300000\A\junk
11:09:49:    ...creation failed for S:\CHARTS\VECTOR\CM93ED2\CM93ED2-2002\00300000\A\junk
11:09:49:    CreateChartTableEntry() failed for file: S:\CHARTS\VECTOR\CM93ED2\CM93ED2-2002\00300000\A\junk
Not sure what I should do next

Quote:
Dirk, are you on Windows?
Yes. XP-SP3, a patch doesn't help me much.... a next beta would be great.

Dirk
__________________
LeaseOnLife is offline   Reply With Quote
Old 29-04-2012, 09:25   #68
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: OpenCPN Version 2.6 Beta Build 1624

Quote:
Originally Posted by bdbcat View Post
Thomas....

64 bit problems.

I am going to have a hard time debugging this without a 64 bit reference system available.

Lets step back: Is there any previous version or Beta that worked correctly with your AMD64 setup?

Dave
Dave

The text for the Trackpoints radiobuttons worked in 2.6.1609. I just re-installed and tested again.

The windows decoration for the tides is different. I can't get it now, even testing the official 64 bit 2.5 package, which, as you said earlier, points towards a change in a 64 bit library.

Thomas
__________________
cagney is offline   Reply With Quote
Old 29-04-2012, 09:27   #69
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Version 2.6 Beta Build 1624

Dirk...

Please cancel my lame attempt at a workaround. It really is make-work at this point, since a new Beta will be forthcoming maybe tomorrow.

Sorry for the glitch
Dave
__________________
bdbcat is offline   Reply With Quote
Old 29-04-2012, 10:26   #70
Registered User
 
LeaseOnLife's Avatar

Join Date: Apr 2008
Location: out cruising again
Boat: Sailboat
Posts: 1,046
Re: OpenCPN Version 2.6 Beta Build 1624

Quote:
Originally Posted by bdbcat View Post
Dirk...

Please cancel my lame attempt at a workaround. It really is make-work at this point, since a new Beta will be forthcoming maybe tomorrow.

Sorry for the glitch
Dave
Superb!

Thanks, Dirk
__________________
LeaseOnLife is offline   Reply With Quote
Old 29-04-2012, 11:56   #71
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Version 2.6 Beta Build 1624

Thomas...

Code:
The text for the Trackpoints radiobuttons worked in 2.6.1609. I just re-installed and tested again.
Well. that makes no sense. I look at the git logs, and find no relevant changes to the dialog code between 1609 and 1624.

Did the 1609 test use the same libraries as 1624?

Head scratching
Dave
__________________
bdbcat is offline   Reply With Quote
Old 29-04-2012, 12:10   #72
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Version 2.6 Beta Build 1624

Thomas...

Missing Tide dialog decorations:

Embarrassing bug.
Try changing the color scheme to the "other" normal display.
The decorations only are shown for one of the four possible color schemes.

The idea here was to suppress the decorations for dusk and night modes, since we could not control the color well on Windows platforms. The bug is that we suppress the decorations for the wrong color scheme.

Fixed for next Beta.
Dave
__________________
bdbcat is offline   Reply With Quote
Old 29-04-2012, 13:21   #73
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: OpenCPN Version 2.6 Beta Build 1624

Quote:
Originally Posted by bdbcat View Post
Thomas...

Missing Tide dialog decorations:

Embarrassing bug.
Try changing the color scheme to the "other" normal display.
The decorations only are shown for one of the four possible color schemes.

The idea here was to suppress the decorations for dusk and night modes, since we could not control the color well on Windows platforms. The bug is that we suppress the decorations for the wrong color scheme.

Fixed for next Beta.
Dave
Dave

Thanks

Quote:
Code:

The text for the Trackpoints radiobuttons worked in 2.6.1609. I just re-installed and tested again.

Well. that makes no sense. I look at the git logs, and find no relevant changes to the dialog code between 1609 and 1624.

Did the 1609 test use the same libraries as 1624?

Head scratching
Dave
Yes, I installed 16.09 on my present setup. Even going back in the "history" of Synaptic, there are no changes in wx libraries since April 9:th, so the compilation environment should be the same.
Or... are we looking at other libraries as well?
I just tested a 1609 portable, no problem there.

So much for Linux, but there is Rik-lu on Win 7 as well. A change in Lin&Win libraries at the same time???

I think we need feedback from more users on 64 bits systems.

Joining you in head scratching.

Thomas
__________________
cagney is offline   Reply With Quote
Old 29-04-2012, 14:26   #74
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: OpenCPN Version 2.6 Beta Build 1624

Text shows in Ubuntu 12.04 32bit but ghosted.
Text not shown in WinXP.
Text shown in Win8 32bit.

All at the same machine (same graphic card) with the above virtual engines.
Attached Thumbnails
Click image for larger version

Name:	TextUbuntu.jpg
Views:	74
Size:	94.4 KB
ID:	40549   Click image for larger version

Name:	TextWinXP.jpg
Views:	75
Size:	67.5 KB
ID:	40550  

Click image for larger version

Name:	TextWin8.jpg
Views:	79
Size:	93.3 KB
ID:	40551  
__________________
CarCode is online now   Reply With Quote
Old 30-04-2012, 07:17   #75
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Version 2.6 Beta Build 1624

Thomas...

Are you still having trouble with user tide harmonics?

Dave
__________________

__________________
bdbcat is offline   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 04:31.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.